PDA

View Full Version : After upgrade Windows XP virtual machine fails to boot with BSOD



DaTa
Nov 4, 2009, 02:58 PM
Hello,

If you have a problem with Windows XP virtual machine which has several CPUs and fails to boot after upgrade from Parallels Desktop version 4 to version 5, please follow the article:

http://kb.parallels.com/en/6873

Thank you.

RodneyW
Nov 5, 2009, 09:44 AM
Thank you! That fixed one of my problems. That only leaves 2-N...

Bob in Calabasas
Nov 5, 2009, 11:16 AM
This is great but the configuration screen, while showing the number of CPU's and the memory, will not allow me to make any changes to any of the configuration options and that includes the Boot Sequence.

Markus Bischoff
Nov 5, 2009, 05:14 PM
no change after cpu set to 1

is there any other tip that helps…

maybe the developer start to do something????

ive ben in the service chat fro paralles, this people there are verry low first level supporters they know how to use there database but did not know anything about paralels - they ask me to repair my windows partition (bootcamp) but i cant because my syystem is service pack 3 and my inst cd is servicepack 1 this does not work…
and on bootcamp windows runs perfect - no problems. SO the Problem is only Paralles.

So if any developer read this pleas do something

I-che
Nov 6, 2009, 04:31 AM
Markus,
please post some more details about your confituration here:
- exact Windows version with SP (guess it is XP)
- exact BSOD you get
Your case is different from the one in 6873 article; most probably you will have to submit support ticket.

Markus Bischoff
Nov 6, 2009, 04:49 AM
it is a windows XP Professionell (done all the updates) so it is SP3

deled the applemnt.sys bring no change

1 CPU ore 8 ore 2 does bring any effect

Bootcamp works fine, also VM and paralels 4

nothing special

my computer is the newest Macpro with 6gb ram and 10.6.1

i already submit a support ticket, i was in the service chat with someone he told me he will forward this to a higher support level because hi did not understand the problem. He ask me to reinstall my windows or do a repair of my windows (my windows cd is sp1 im already on sp3 with many updates....- so repair will not work)

aso send the problem from the paralles application itself

markus Bischoff:


one Ticket number is: 806039

ReidB
Nov 6, 2009, 12:47 PM
I'm getting the BSOD after upgrading. tried the 1 cpu thing but no luck.
I'm running snow leopard on a macpro. guest OS: XP SP3. Get the DRIVER_IRQL_NOT_LESS_OR _EQUAL error.

Don't think it actually upgraded my virtual machine from 4. Bootcamp works fine if I boot into it natively.
thanks!

nill s
Nov 7, 2009, 02:41 AM
The guest is WinXP Pro SP3 32bit.

When I power the VM on and after several seconds of waiting I get bluescreen and the VM is forced to reboot. Next XP shows "start windows normally" option, but still the same error. I tried to recover the VM to the "clean" snapshot which is taken after the XP install, but after the reboot the XP still gives me the same bluescreen error again. If the xp copes to boot to the desktop it will crash a few seconds later!

Before this day, the XP VM worked fine, i don't know where this error came from?

AlbertoC
Nov 9, 2009, 05:31 PM
I'm experiencing what looks like the same problem

I have a macbook pro and a mac pro: both run snow leopard (10.6.1); I have been using parallels desktop 4 with the windows XP of my BootCamp partition; I purchased two upgrades to paralells desktop 5; I installed one on the macbook pro and it worked fine: it initially told me that it couldn't find the VM, but then I restarted the macbook pro, tried again and it worked; I just tried to install 5 on my mac pro and it doesn't work; windows XP starts, then I get long an error message stating that windows had to be stopped and asking whether I want to restart normally or use last known configuration; in both cases, it tries to restart and I get the same error, over and over again; in short, it doesn't work; I started windows from within bootcamp and it works;

I contacted support and, as it happened with my last support problem, I started receiving unhelpful suggestions, such as reducing the number of processors to 1 (it was already the case), re-installing the VM, etc.; with my previous problem it took over a month before a qualified support person finally stepped in and solved the problem;

voom
Nov 10, 2009, 02:14 PM
I also have the same problem as ReidB shown above (BSOD with the same modules). I've changed to 1 processor and deleted the floppy disk and I still get the same problem.

Win XP 32bit SP3 running from a bootcamp drive.

Are there any other suggestions than the KB article for using 1 processor which is not working for some people?

STim
Nov 11, 2009, 02:53 AM
We just got several indications from customers in email support queue that the issue with Boot Camp BSOD is solved for them by upgrading to Snow Leopard 10.6.2. Please try this solution in case you are using Windows Boot Camp partition and still get BSOD even after applying 1CPU workaround described in KB.

Brandon Rogers
Nov 11, 2009, 06:30 PM
Didn't work - still got the same error. I installed the new update for Snow Leopard and still get the BSOD

AlbertoC
Nov 12, 2009, 02:27 PM
upgraded to 10.6.2 but still getting the same error

AlbertoC
Nov 12, 2009, 04:25 PM
here are more details on the error message I get (I'm also attaching a file with the error window):

the file that seems to be causing problem is called: MDPMGRNT.sys

and the technical information reads as follows:

*** STOP: 0x000000BE (0xF7409C5C, 0x0784B121, 0xF78AE4FC, 0x0000000B)
*** MDPMGRNT.sys - Address F74DACF2 base at F74D7000, Datestamp 4a12f82D

may a tech support person can make sense of this and find a solution

AlbertoC
Nov 12, 2009, 05:03 PM
following up on my previous message (not yet posted): it appears that the MDPMGRNT file is a MacDrive 7 (Mediafour) partition driver file; I took it out of C:\windows\System32\drivers but MacDrive reinstalls it immediately...

I started WindowsXP in safe mode and I can start the VM without problems...; if I restart windows normally I get the same error apparently caused by that MacDrive file that has reinstalled itself the drivers folder

the strange thing is that I also have MacDrive 7 on my macbook pro and I was able to upgrade successfully to Parallels Desktop 5 and everything works fine; I only have this problem on my Mac Pro desktop...

AlbertoC
Nov 13, 2009, 01:12 PM
OK, I de-installed MacDrive from the Windows XP Boot Camp partition and after doing so I was able to launch the Parallels Desktop 5 VM, install parallels tools etc.; so, everything seems now to be working fine ... except that I still don't understand why on my MacBook Pro I can have MacDrive and Parallels without any conflict (when I launch the VM I am told that MacDrive will not work in the VM environment, which makes sense, but MacDrive doesn't cause any conflict) , while on the Mac Pro I cannot do that because there seems to be a conflict

MichaelU
Nov 14, 2009, 11:06 AM
Hi,

I use the same configuration:

Modellname: Mac Pro
Modell-Identifizierung: MacPro4,1
Prozessortyp: Quad-Core Intel Xeon
Prozessorgeschwindigkeit: 2,93 GHz
Anzahl der Prozessoren: 1
Gesamtzahl der Kerne: 4
L2-Cache (pro Kern): 256 KB
L3-Cache: 8 MB
Speicher: 6 GB
Geschwindigkeit für Prozessorverbindungstyp: 4.8 GT/s
Boot-ROM-Version: MP41.0081.B04
SMC-Version (System): 1.39f5
SMC-Version (Prozessormodul): 1.39f5

Win XP professional 32bit SP3 running from a bootcamp drive (NTFS).

I was upgrading to 10.6.2 before installing Parallels.
(Installation file: ParallelsDesktop-parallels-de_DE-5-1.0.9220.531119.dmg).

After upgrading from Parallels 4.0 to 5.0: Same problem with the blue screen.

PARALLELS TEAM - PLEASE HELP!

Best regards,
Michael

wenfeen
Nov 16, 2009, 08:28 AM
This did not work for me. Within the virtual machine processors area, two processors are indicated and are grayed out so I cannot change. Seems like I get a slightly different message each time I unsuccessfully try to boot up my Windows XP Home version.

RodneyW
Nov 16, 2009, 04:39 PM
This did not work for me. Within the virtual machine processors area, two processors are indicated and are grayed out so I cannot change. Seems like I get a slightly different message each time I unsuccessfully try to boot up my Windows XP Home version.

You must first stop your VM before you can change the number of CPUs. The VM is running even after the OS fails to start unless you explicitly stop it. Once the VM is stopped, the number of CPUs will not be greyed out.

wenfeen
Nov 16, 2009, 07:04 PM
I couldn't change the configuration of CPU's, then went into the Console utility which showed a program crashing, one that I had uninstalled a few months ago "Littlesnitch". I searched for traces of Littlesnith which I found in one of the Libraries (can't remember which one) After deleting and restarting, I was able to change the CPU setting in Parallels to "1" and Windows XP booted without any problem.

I-che
Nov 16, 2009, 09:40 PM
wenfeen, you need to shut downl virtual machine. this is kind of setting that can not be applied on-the-fly. please try with stopped vm.

LucaD
Nov 18, 2009, 05:19 AM
Same BSOD here.

Model Name: Mac Pro
Model Identifier: MacPro4,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.26 GHz
Number Of Processors: 2
Total Number Of Cores: 8

Error
*** STOP: 0x000000BE (0xF788fc34, 0x0A3D6121, 0XF78A251C, 0X0000000B)
*** NDIS.SYS - Address F788FC34 base at F786A000, DateStamp 48025d03

I hope this issue can be easily sorted out...

Kirk Dickinson
Nov 18, 2009, 01:27 PM
I have tried all the things in this post, except I have yet to upgrade to 10.6.2 yet.

No joy. XP won't boot even in safe mode. One CPU, graphic acceleration turned off.

IngeborgS
Nov 20, 2009, 02:17 AM
Same BSOD here:

Model Name: Mac Pro
Model Identifier: MacPro4,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.66 GHz
Number Of Processors: 1
Total Number Of Cores: 4
RAM: 6 GB
MacOS 10.6.2 German
Bootcamp Tools: 3.0
Windows XP SP3

DRIVER_IRQL_NOT_LESS_OR_EQUAL
Error
*** STOP: 0x000000D1 (0xF752FC5C, 0x000000FF, 0X0000001, 0XF7AB4629)
*** ftdisk.sys - Adress F752FC5C base at F752E000, DateStamp amp 3b7d8419
*** AppleMNT.sys - Address F7AB4629 base at F7AB4000, DateStamp 4a15a557

audioeric
Nov 24, 2009, 01:33 PM
Getting same BSOD here on start up of Boot Camp installation with Parallels..

Attached screenshot

27" iMac Core i7 2.8 Ghz
8 GB RAM

I've gone in under Boot Camp and done all Windows updates, I've switched CPU's to one, and have even turned off the printer, network connection, and DVD in the configuration of parallels to try to avoid IRQ issues.. Still nothing, same exact problems..

ftdisk.sys
AppleMNT.sys

Any thoughts on this? Seems like a lot of people are having the same issue...

IngeborgS
Nov 25, 2009, 09:16 AM
Is it a problem with the new processors build at the MacPro Early in 2009 and the newest iMacs?
Maybe the settings at Parallels 5 to 1 processor cannot avoid that several cores will work and therefore a BSOD is generated?
In the meantime I already have received the 4-th message of the Technical Support, which is not concerned with the failing integration of boat camp but rather tell me basic tips.
I think that nobody knows a solution. So we have to hope for a new Parallels build.

IngeborgS
Nov 29, 2009, 10:56 AM
I have created a Screen-Movie about the start attempt. You can see at the beginning the hard disk symbol recognized (green bar). If the Windows-XP logo appears there is probably no more accesses (no green bar).
If I start Bootcamp at the native mode and the black failing start window disappears, I will got the same problems: After new start with Mac OS 10.6.2 and start of Parallels, the black failing start window stays disappeared, however, the BSOD and the endless loop was coming again.
Screen_movie (http://public.me.com/gschwiebert/de/)

I-che
Nov 29, 2009, 08:50 PM
IngeborgS, what is the ticket number at Parallels support system?

FranciscoP
Nov 29, 2009, 10:26 PM
I have the same issue with the blue screen. VM created in 3.0, upgraded to Snow Leopard so I was forced to upgrade to parallels 5. After the upgrade, windows starts to boot, and then goes to the blue screen and restarts. Tried changing to 1 processor, but it was already set to 1. Please help.

http://www.tonepad.com/fpstuff/parallels5bsod.png

IngeborgS
Nov 30, 2009, 01:21 AM
The ticket number at Parallels support system = 816416

IngeborgS
Dec 1, 2009, 11:32 AM
Below you can find the 7th reply to Parallel's Technical Support:
Hello,
No, my Bootcamp Partition is ok.
If I start native with Bootcamp, so it works fine.
If I start Bootcamp with Parallels 4 (before the upgrade to Parallels 5) it works fine as well.
I have said it here always again!

Your links below describe MS information of BSOD error, if Windows cannot start (but native it can start see my first lines).

Today I have deleted the Bootcamp partition and created a new at Mac OS 10.6.2.
Then I have installed via Bootcamp a fresh Windows XP SP 2. At this small windows installation I have only add to Bootcamp-Drivers and Parallels 5 drivers. Then I start Parallels 5 again.
What do you think has happened? Yes I have got the same BSOD as before!!!!
Certainly I had installed Parallels 5 again; I have physical disconnected all FireWire and USB devices. Only my monitor the mouse and the Keyboard stay connected. All without any success!!

I think I have hard worked, but this to do is not my job!! I think there is nothing more what I have not already tried out.

Do you work for a new build? When?

JVdW2000
Dec 5, 2009, 02:09 AM
Hi,

I have exaclty the same issues as you all:

Hardw: new iMac Quad 27'
latest 10.6.2 factory install
nothing connectede except USB KB and BT new mouse.

Installed XP Pro SP3 version 2002, and updated in standalone boot the latest patches from MS.
Standalone Bootcamp works fine
VM Fusion 3 install works fine
P5 does not install - but gives BSOD during VM config

Par 5 desktop install hangs during first time VM config in step 1/4 always at about 25-30% progress
Since VM Fusion 3 successful instal, reinstalled P5. Now it does not hang anymore, it give BSOD, like other person pasted in theis thread:

Driver_IRQL_NOT_LESS_OR_EQUAL
STOP:0x000000D1 (some hex address)
ftdisk.sys - address sone hex address
AppleMNT.sys - again hex address

I can't create ticket as this is a trial version. I do have P3 on other machine installed. I already checked - the VM config setup for Bootcamp client and for Win XP both were already set up for 1 CPU.

Did anyone get anyware here, or did you all give up and use VM Fusion 3 ?

kind regards
JVDW

IngeborgS
Dec 6, 2009, 01:33 AM
If you use a MacPro (Early 2009) or a an iMac Late 2009 27 inch with Core i5 or i7:
see the thread here (http://forum.parallels.com/showthread.php?p=394164#post394164)

CuoghiD
Dec 7, 2009, 03:45 AM
Hello, yesterday I upgraded from Parallels 4 to 5, this morning I tried to open the Bootcamp partition with Windows XP and I had the same issue explained in this discussion (if I had read this discussion before I surely choose not to upgrade...)

My MacPro is an "early 2009" 2x2,6 Quad Core with Leopard.

http://img197.imageshack.us/img197/9512/parallelserror1.jpg

Now I will try to uninstall Parallels 5 and install again version 4, waiting for a solution to this issue.

StevenT
Dec 8, 2009, 11:09 PM
When I first launched Parallels 5.x, it asked to "back up and convert" existing VM (named winxp.hdd) or just "convert". I selected "convert" since I had copied a version of the VM (winxp.hdd) to my back up drive. The conversion never completed (after an hour) and Parallels 5.x had to be Forced Quit. Now I cannot open my VM (winxp.hdd, about 33 GB file) in any version of Parallels.

I tried to migrate using Parallels Transport and I get a message "the virtual hard disk you specificed is a Parallels virtual hard disk. You needn't convert it to Par. format. Please specify another disk"

I can open Parallels Desktop 5.x app, but cannot open my winxp.hdd disk (about 33 GB). I tired the File/Open and File/Import commands in Parallels Desktop.

I even tried to reinstall my winxp.hdd backup from Time Capsule, but that file will not copy down.

How can I open and retrieve my files from my Winxp.hdd drive?

Product Version: 5.0
Computer Type: MacBook
Build Number: 9220
Amount of memory: 2-4GB
Host OS: Mac OS X 10.5.x Leopard
Host OS details:
Where did you buy our product?: From an online store
How many licences have you purchased?: 1-2
Guest OS: Windows XP Professional
Guest OS type: 32-bit
Number of CPUs in Virtual machine: 1
Amount of Guest OS memory:

Thanks,
Steve Tello
Ticket ID 829869

warnergt
Dec 16, 2009, 08:57 AM
I have(had) this problem with the DRIVER_IRQL_NOT_LESS_OR_EQUAL BSOD on:
new quad-core i5 iMac,
Bootcamp 3.0,
Parallels 5.0.

The system boots fine in Bootcamp.

My workaround was to boot in Bootcamp and rename c:/windows/systems32/drivers/AppleMNT.sys. (I renamed it to AppleMNT_keep.sys).

Now, I can boot and run with Parallels 5. However, I'm wondering what doesn't work without that file.

MickColl
Apr 9, 2010, 02:14 AM
Disabling p3.sys using Windows Recovery console resolved my BSOD issue, when upgrading from 3.0 to 5.0 on XP.

It appears to be a pentium 3 driver, which the VM doesn't need. After diabling it I was able to complete the conversion of my VM and running XP happily now.

MissC
May 11, 2010, 03:59 AM
I couldn't change the configuration of CPU's, then went into the Console utility which showed a program crashing, one that I had uninstalled a few months ago "Littlesnitch". I searched for traces of Littlesnith which I found in one of the Libraries (can't remember which one) After deleting and restarting, I was able to change the CPU setting in Parallels to "1" and Windows XP booted without any problem.

We have the same situation. Help. What should we do.?