PDA

View Full Version : Ping works Windows <-> Windows but not Mac ->Windows


imok
Apr 17, 2010, 06:33 PM
I cannot ping the P/Windows XP from the Mac side by using computer name. Only IP pinging works.

I have installed Parallels/Windows XP on Snow Leopard Mac OS X server. I enabled WINS server on the Mac Server and also set the static IP on the P/Windows XP and set the WINS to point back to the Mac Server.

All IP address pinging works perfect between Mac < -- > Windows and even Windows <-->Windows. Also all Pinging between P/Windows <--> Windows using computer names works.

However I cannot Ping Mac --> P/Windows using computer names. just using IP.

From Mac terminal:
admin$ ping winxp1.local <-- Ping: cannot resolve winxp1.local: Unknown host
admin$ ping 192.168.1.42 <-- Show the packet speed info.

From another Windows computer
c:> ping winxp1.local <- works as expect

Here is the winxp1.local ipconfig
C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : winxp1
Primary Dns Suffix . . . . . . . : local
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : local

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Parallels Ethernet Adapter #2
Physical Address. . . . . . . . . : 00-1C-42-ED-8D-93
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.42
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.41
Primary WINS Server . . . . . . . : 192.168.1.41

C:\Documents and Settings\Administrator>


I have SMB and DNS services running on the Mac OS X Server.

Any help please?

Thanks