PDA

View Full Version : vmmain.kext causing jumpy/erratic mouse under CPU load (Leopard)


mathboynz
Dec 20, 2007, 04:26 AM
Finally tracked the cause of something that has been bugging the heck out of me for a while.

Under Leopard 10.5.1, under CPU load (at least 1 core of my core 2 duo maxing out) the trackpad pointer would jump about, usually about 2-3 seconds apart, would also become slow and basically super annoying to use. The funny thing is it would only happen when NOT connected to my wireless network (would happen even if airport was turned off). Checking the console would show lots of "kernel [Parallels] IPI stat: rescheduled 1 cpus out of 2." which struck me as odd since Parallels wasn't even running.

Anyway, tracked it down to vmmain.kext which gets loaded at startup from the parallels script in /library/startupitems/parallels.

Again, Parallels does not need to be running at all for the mouse pointer to be affected.

I'm currently working around the issue by removing the startupparameters.plist (thus making parallels services, vmmain.kext etc not load at startup, and if I want to run parallels I just manually start the needed extensions/services (wrote an applescript which just basically does "sudo sh /Library/StartupItems/Parallels/Parallels start; sudo sh /Library/StartupItems/ParallelsTransporter/ParallelsTransporter start") and then stop the services after I'm done with parallels.

Never happened under Tiger though, must be a leopard thing. I'm pretty sure airport has something to do with it as it only happens when I'm not connected to a wireless network.

Anyways, hope this may help someone.

Eru Ithildur
Dec 21, 2007, 02:51 PM
Have you downloaded the recent wireless update for MacBooks? That might have some fix, as there were some bugs in the MB's wireless drivers.

mathboynz
Dec 21, 2007, 05:18 PM
hmmm, was that update only for macbooks? (I have a 2.4ghz macbook pro and I can't remember any wireless update). Just checked software update and nothing.

Jay.

brkirch
Dec 21, 2007, 06:23 PM
I've seen that bug, but AFAIK it only happens when you have disabled a CPU using CHUD. Unloading the kernel extension will remove the extra CPU load, but unless you have a reason to be running with a CPU disabled I'd recommend you re-enable it, then you won't need to be reloading the kernel extension every time before you run Parallels (that is, assuming you are having this problem because of a disabled CPU).

mathboynz
Dec 21, 2007, 06:31 PM
Nope, don't have CHUD tools installed and have not disabled a CPU at all. It's interesting that you mention it though because I really only notice the pointer bug when I run some numerical experiments I'm working on in MATLAB, which uses multiple threads but only seems to max out 1 CPU, so maybe it does have something to do with situations when 1 CPU is only available to other processes?

Anyways, thanks for the tip.

Jay.