PDA

View Full Version : virtual memory minimum too low


Larry Dryden
Jul 30, 2008, 12:56 PM
I'm not sure if this is the right forum for this question, but i keep getting this message on bootup, and then the computer freezes. I have tried going into safe mode but this doesn't work either. where to now

John@Parallels
Jul 31, 2008, 02:29 AM
What is the message?

Larry Dryden
Jul 31, 2008, 11:14 AM
That was the message - your virtual memory minimum is too low, Windows is increasing the size of your virtual memory paging file - then nothing happens. The only way I could get it to boot was to run explorer in the task manager. I checked my VM, and it was set ok - 1500, so I don't know what the problem was. I haven't tried a reboot since.

John@Parallels
Jul 31, 2008, 11:41 AM
It is Windows message
run msconfig and check how many startup items you have and disable unneeded

Anthony Heath
Nov 14, 2008, 06:11 PM
I just want to say that the response to this question is BS.
Tell me exactly how a constant message coming up that says my virtual memory is too small can be solved my running msconfig and looking at how many start up processes there are!

I get this same message all the time and I'm running the latest version on a brand new VM with only 3 apps installed.

This started happening after I ran windows update and installed SP3.

So how about not giving a BS response this time.

BTW I did run msconfig and the only startup items are parallels tools items.

EarPlug
Nov 25, 2008, 09:45 AM
I am receiving the same message after running compressor. When you go to XP Computer Management to change the file size it fails.

Jack

phesopheon
Nov 25, 2008, 10:09 AM
I just want to say that the response to this question is BS.

I agree. BS answer.

I got this message too, back in V3. I ended up adding a second drive to my configuration and I moved the paging file to that drive. It ended my problem. As soon as I had this setup working, and windows was happy, I shut windows down and made a copy of that second .hdd file. This copy is a nice small file. As I use windows, the second .hdd file organically grows. Occasionally I copy the backup of the .hdd file over (when windows is shut down!) to reset things. It seems to work and windows never complains.

I think the option to set the virtual memory settings is somehwere in My computer->properties. I forget exactly where it is.

Paul

EarPlug
Nov 25, 2008, 10:16 AM
I solved the problem. Went to My Computer, right Click the properties and find the virtual memory stuff under Performance. Set the Virtual Memory Swap file to OFF. Restart. Then go back and set the Min 768 Max 1536. It should say the file exists Overwrite? YES.

The Deletes the old file and recreates a new swap file.

Jack

timsauve
Nov 30, 2008, 10:09 AM
Jacks solution worked for me, too. It solved the "Windows - Virtual Memory Too Low" message.

My problem also started after running Compressor.

Tim

jams001
Dec 1, 2008, 02:43 AM
virtual memory minimum too low oh really how could you say that??


___________________
Great thing to know about busby seo test (http://pinayspeak.com/pinaytest/).

jams001
Dec 1, 2008, 02:45 AM
virtual memory minimum too low how could you say that,can you explain it cause i don't is that??

EarPlug
Dec 1, 2008, 09:11 AM
virtual memory minimum too low how could you say that,can you explain it cause i don't is that??

Virtual Memory is actually a file on your hard disk called a Swap File. When the operating system doesn't have enough real memory to complete an operation (like a large image file) it uses the Virtual Memory file to simulate real memory.

It appears that running Compressor corrupts this file and it needs to be recreated.

Jack

Chetw7@yahoo.com
Dec 1, 2008, 03:01 PM
I ran compressor thinking it would help. Now I get virtual memory too low. How do I recreate the swap file????

EarPlug
Dec 1, 2008, 04:29 PM
I ran compressor thinking it would help. Now I get virtual memory too low. How do I recreate the swap file????

GOTO Control Panel - System - Advanced Tab - Performance - Settings

Under Performance Options - Advanced - Virtual Memory - Change

Select - No Paging File - then hit SET - Then OK out of all screens. This Deletes the Swap File

Restart Windows - Then Go back to:

GOTO Control Panel - System - Advanced Tab - Performance - Settings

Under Performance Options - Advanced - Virtual Memory - Change

Select - Custom Size - 768 as Min and 1536 as Max and hit set then OK. This creates a new Swap File

Restart Windows

Ephra
Jan 25, 2009, 05:00 AM
Isn't this way too much?? (768 as min and 1536 as max) What have to be the settings in the VM configuration then exactly, do I have to change anything there?

kat
Jan 25, 2009, 05:32 AM
Hi Ephra,

The "(768 as min and 1536 as max)" is the recommended range to set your VM between. (This range is determined by the amount of Memory in you computer. You cannot allocate more memory to the VM than what is installed in your host computer.)
You can use the optimal size as a guide line.

kat

Ephra
Jan 26, 2009, 05:27 AM
hi Kat,

thanks, I set it up to 768/1536 and my VM is performing faster! Great! (and popup 'virtual memory too low' is gone)

pacowaco
Jul 7, 2010, 09:53 AM
Thanks to you all; this has been driving me nuts for over a year (I just kind of put up with it as it didn't appear to cause problems per se, but was always niggled by it). Problem gone me happy!

RavenD
Jan 9, 2011, 12:08 PM
This kind of problem I had has been solved by turning of the virtual memory (http://virtualmemoryfix.com) swap file then recreating a new swap file that will overwrite the old one. Thanks to Jack's suggestion.

DylanD
Oct 31, 2011, 02:20 PM
Thank you for showing us what to do! In Windows 7, it's a little different...

I went to Control Panel, and searched "Virtual" and it came up with a 'Windows Help & Support' took me to "Change the size of Virtual Memory" which was under.... System.


I solved the problem. Went to My Computer, right Click the properties and find the virtual memory stuff under Performance. Set the Virtual Memory Swap file to OFF. Restart. Then go back and set the Min 768 Max 1536. It should say the file exists Overwrite? YES.

The Deletes the old file and recreates a new swap file.

Jack