PDA

View Full Version : F11 and F12 keys not working in Leopard


glenn.gilbert
Jan 27, 2008, 11:56 PM
As discussed elsewhere (but the thread's not accepting new posts), the F11 and F12 keys don't seem to work with Leopard.

It appears Leopard is keeping these keys to itself.

Problem: running Visual Studio in a VM. F5 and all it's siblings are working. F10 is fine. However, F11 and F12 don't work (F11 is used a lot). Nor do they work in any other application, e.g. IE.

These function keys are NOT mapped to Desktop or Dashboard (sys pref > kbd > kbd). When these settings are on, desktop and dashboard show. When off, they aren't passed to Parallels.

Build info: Parallels 5584, Leopard 10.5.1.

Is this a bug in Parallels or Leopard?

Is there another thread discussing this?

jeremyNYC
Feb 19, 2008, 12:04 PM
I'm having the same problem. I'm on 10.5.2 running Parallels 3 build 5584 (Win XP).

Any ideas what could be happening. I use F12 all the time for Dreamweaver previews and since upgrading to 10.5 F12 does not work in Parallels.

MaximS
Feb 22, 2008, 06:05 AM
Due to numerous users wishes, Parallels developers made F9 - F12 keys working the way they usually work on Mac: F9 - All windows, F10 - Application windows, F11 - Desktop, F12 - Dashboard.

Please use Actions -> Send Keys option.

jeremyNYC
Feb 22, 2008, 11:17 AM
Ok, the Send Keys menu option works, but defeats the purpose of using a keyboard shortcut! As a developer, I use Adobe Dreamweaver, InDesign, etc. all of which use the F9F12 keys. In Dreamweaver especially I use F12 to preview every page I make.

Is there a way to permanently set it so that F12 just works?

I have my Mac Dashboard and Expos shortcuts to NOT use F9F12 so there is no conflict there.

Thanks.

davidcarne
Feb 22, 2008, 04:28 PM
I'd like to add my support to jeremyNYC re F11/F12 - I bought parallels purely so I can use a windows EDA application on Mac OS X - and F11/F12 are shortcuts I need, otherwise I'm far less productive. Can this be a preferences option somewhere? Otherwise its going to be a real pain to retrain myself to use all new shortcuts.

Cheers,

--David Carne

MaximS
Feb 26, 2008, 05:51 AM
For now there is no way to use these shortcuts under Leopard. It will be provided in future.

HughLynch
Feb 26, 2008, 11:10 AM
I'm also having this problem as a VisualStudio user. As a workaround, I have remapped shift+F10 to do Debug.StepInto, but it is still a pain. Another option I am considering is using remote desktop to my windows VM from another windows machine.

jeremyNYC
Feb 26, 2008, 11:27 AM
Ok, please do include it! I know I am not the only developer who uses these keys VERY often in Adobe products...

yyz1970
Mar 5, 2008, 10:46 PM
Add me to the list of requesters for this feature. There should be an option in the Virtual Machine settings to map all function keys to their Windows equivalent.

I am trying to use Visual Studio, and debugging is very difficult when all of the function keys aren't working as expected.

xm242mx
Mar 9, 2008, 02:13 PM
I have the same problem - the F11 and F12 keys ar not working. I do not use the spezial functions of Leopard with these keys but they dont work.

Yesterday I tried an other VM product and see those keys are working well.

But this should not be the way to solve the problem.

I'm using parallels 3.0 buildt 5584

rlbstark
Mar 11, 2008, 03:30 PM
If full and accurate keyboard functionality in the guest is important to you, let me share my experience as a Parallels user from the beta days through build 5584.

My overall opinion is that such functionality has not been their top priority. In fact, most of the keyboard-related changes I have seen tend towards emphasizing the presence of OS X within the guest as much as possible. The remapping of Command-C and friends to the copy, paste, etc. functions is a prime example.

I use a windows keyboard, no less, and yet the context menu key has been broken for as long as I can remember. (See http://forum.parallels.com/archive/index.php/t-12848.html for example.) Sure, the right windows key remaps to a context menu key, which is great for some people. Heck, the majority of users use a Mac keyboard and need that remapping to have a context menu key at all. But from my perspective, instead I see one dead key and one mislabeled key and no options from Parallels to change that. Worse, that fact's been staring me in the face almost every workday for the last year, now.

Even before the change we're discussing here, to get the expose keys and command-tab to pass through to the guest instead, you had to change an OS X system preference in Universal Access, of all places.

I can understand their perspective. The biggest market is probably people who like OS X but are stuck using some Windows app or another. Most of them probably want to be as close to OS X as possible, even in the guest. But some of those very applications that tie them to Windows/DOS (and thus to Parallels) can be keyboard intensive, so this is a sensitive issue. I've waited patiently for change, made requests and observed others making theirs, and nearly two years later haven't seen satisfactory progress in those directions (though I'll say in a heartbeat they've made great progress in other areas).

For reasons like this, I just recently tried a demo of VMWare Fusion in Leopard. It's too early to comment in general, but I can make some comments related to this topic. Without having to enable access for assistive devices in Universal Access ahead of time, *one* checkbox in *Fusion's* preferences let me control whether the guest or host received the command-tab and expose keys. (You're stuck if you wanted one but not the other, though.) Later I plugged in my Windows keyboard, let OS X identify it, and launched Fusion for round two. My right windows and context menu keys finally function as printed on the keyboard. It's a small thing, but it's a small thing that matters to me.

I could say that I'm two years closer to Parallels offering similar choices and ease of use in this area. I could also say I've waited two years too many.

bed42
Mar 30, 2008, 08:39 PM
I am a new customer - just bought Parallels, for windows development. I also use F11 and F12 all the time in my dev enviroments and Parallels having an option to allow these is pretty crucial.

far
Apr 11, 2008, 09:50 PM
For now there is no way to use these shortcuts under Leopard. It will be provided in future.

You didn't qualify "in future".

Hopefully, Parallels will provide this necessary functionality in the near future, rather than in the distant future.

Ideally, anything having to do with the behavior of keyboard elements should be configurable by the user.

Thank you.

Thor
May 13, 2008, 08:04 AM
Unbelievable. Like everyone else here, I need these keys for development and am really disappointed that I don't even have the option. To force upon people something that really needs to be an option, no two users are the same, is just bad development. Even send keys is not an option for me because I need to be able to hit shift + f11, and unless I'm missing something, I don't see a way to accomplish that.

It's too bad we just spent the money yesterday on this because I'd rather revert to the version I was using then deal with this.

sylver
May 18, 2008, 12:10 PM
I use the f12 key quite a bit for development as well. I was going to buy parallels for my mac so i would not have to use bootcamp; but i think i will hold off until this issue is fixed
or use vmware fusion.

snazzer
May 22, 2008, 09:15 AM
Not too great that this isn't working for us developers. I'm a VC++ user, and F11 is "step in" when debugging. Quite crucial really.

Anyway, the workaround is to use OSX's custom keyboard shortcuts to press the Send Keys->F11/F12 for you when in parallels.

Open System Preferences->Keyboard/Mouse
- Go to Keyboad Shortcuts
- Click the + sign to add a shortcut

Then enter
- Parallels as the Application,
- Menu Title is F11 or F12 (depending on what you want)
- Keyboard Shortcut is F11 or F12

Once done, you should see F11/F12 show up next to the Send Keys->F11/F12 in Parallels.

Now if you are in your virtual machine, pressing F11/F12 should basically press that menu item for you.

Unfortunately, things like Shift-F11 (step out in VC++) won't work. But hopefully the Parallels team will sort that out soon (Please).

sylver
May 22, 2008, 10:09 AM
Thanks for the tip at least that gets me started on the right track I defiantly use f12 a lot and this makes my life so much easier

chrisb46
May 27, 2008, 06:55 AM
Actually I think there's a way around this, as long as you don't mind changing the OS X show desktop shortcut. If you go into Expose and change the shortcut for Show Desktop to something else other than F11 (I went for Shift F11) that then makes plain F11 available. You can then set up an OS X keyboard shortcut as above, mapping F11 to the Send Keys - F11 menu option.

Same thing should work for F12?

leok7v
Sep 21, 2008, 03:48 PM
Dear Parallels,

You write:

>Due to numerous users wishes, Parallels developers made F9 - F12 keys
> working the way they usually work on Mac: F9 - All windows,
> F10 - Application windows, F11 - Desktop, F12 - Dashboard.

Parallels are for people who used to Windows or need them due to the course of their work (how is about DEBUGGING?!)

I bought several copies of Parallels and suggested many others. I estimate I brought your company > dozen customers and they each brought more. I think I made a mistake.

I am software developer myself taking care about hundreds of thousands of customers and they also wish the sky and the star...

Pardon me shouting but:
WHEN YOU IMPLEMENT SUCH A DISRUPTIVE FEATURE AS REMAPPING KEYBOARD SHORTCUTS AND MAKING THEM UNAVAILABLE FOR TARGET PLATFORM YOU MUST PROVIDE A WAY (SIMPLE TICK BOX IN PREFERENCES WILL SUFFICE) TO SWITCH THIS FEATURE OFF AND LET PEOPLE USE THREE VERY USEFUL KEYBOARD SHORTCUTS (Plus Ctrl+, Shoft+, Alt+ overall you have STOLEN!!! about 9 keyboard combinations - for the sake of Mac idiots that "Just click" anyhow).

PLEASE FIX IT ASAP (or better yet IMMEDIATELY).

It's been almost a year and it is 5 minutes fix.

Thanks for listening.

Leo

MaximS
Sep 23, 2008, 01:26 AM
leok7v, you can use Fn+F11 shortcut for F11 (and others) key in VM.

Also, please, read http://www.parallels.com/en/download/file/doc/Parallels_Desktop_for_Mac_User_Guide.pdf, page 232.

far
Sep 23, 2008, 11:02 AM
... you can use Fn+F11 shortcut for F11 (and others) key in VM.


I do NOT want to use ANY modifiers (such as fn) with f11 and f12. I want to be able to use f11 and f12 by themselves, from within the VM under Parallels, to accomplish the same tasks that I normally accomplish by using f11 and f12 while running Windows on a PC.

Thank you

leok7v
Sep 23, 2008, 05:23 PM
Maxim,

>you can use Fn+F11 shortcut for F11 (and others) key in VM

I can also stand on my head and wiggle my toes. So what?

Actually I cannot use Fn+F11 because I switched Fn to be used
for Mac specific shortcuts and F<number> for programs. I treasure
my keyboard shortcuts and do NOT want to waste them on Macintosh
specific actions that I probably invoke as often as once a month.

The fix for the issue will take LESS ENERGY than arguing and advising your customers.

You are already losing people to VMWARE and you will lose more if you won't start listening and fixing thing. The feature request is simple:

Make transparent translation of ALL keys an option in Parallels Preferences. That is all.

Good luck pressing Fn+Alt+Ctrl+Shift+F12 on you Mac...

Leo

leok7v
Sep 23, 2008, 05:34 PM
Parallels,

How about every time I want to press Alt+F12 (several dozens times a day) to find symbol definitions in MS Dev Studio or JetBrains IntelliJ Idea or Shift+F11 to exit a method in a debugger (several dozen times a day too) you ship me a customer support rep to hold `Fn` button for me... This will make my day. Don't forget all other software developers you sold Parallels too. Ship them a customer rep Fn hand holding person.

Leo

xm242mx
Oct 2, 2008, 05:54 AM
Hi there,

the only way to fix this function key problem is to switch to anohter VM-machine.
I tried VM-ware Fusion and it the keys all work properly.

Martin Mazur
Jan 15, 2009, 07:03 AM
Has there been any updates on this BUG (yes i consider this a bug). I use my F-keys in Visual Studio all day and this is starting to bug me, really, really, really hard.

Has anyone got this working?

STim
Jan 15, 2009, 07:26 AM
If you are on Parallels Desktop 4, go to Parallels Desktop menu->Preferences->Keyboard&Mouse and uncheck the "Enable Mac OS X system shortcuts" checkbox.

This will let Mac OS system shortcuts like F9-F12 go directly into VM without being intercepted by Mac OS itself.

gjritter
Feb 9, 2009, 12:55 PM
If you are on Parallels Desktop 4, go to Parallels Desktop menu->Preferences->Keyboard&Mouse and uncheck the "Enable Mac OS X system shortcuts" checkbox.

This will let Mac OS system shortcuts like F9-F12 go directly into VM without being intercepted by Mac OS itself.

Unfortunately, turning this option on prevents the use of Command-Tab to switch between windows applications and mac applications. I can now alt-tab through applications within windows, and command-tab between mac applications, but I can't command-tab to switch from a windows app to a mac app. (I'm running in full-screen mode.)

NeveM
Jun 17, 2009, 03:03 PM
I did this but it makes no difference. I need my F12, I use it constantly in Dreamweaver and Flash. All I get is the volume turned up. How do I get it just to work, by pressing only F12? I found pressing fn control 12 works but it's really clumsy.


If you are on Parallels Desktop 4, go to Parallels Desktop menu->Preferences->Keyboard&Mouse and uncheck the "Enable Mac OS X system shortcuts" checkbox.

This will let Mac OS system shortcuts like F9-F12 go directly into VM without being intercepted by Mac OS itself.

andwi
Jul 10, 2009, 03:42 AM
I have checked "Use all F1, F2..." in system preferences and when running parallels in full screen mode everything works the way I want (all F-keys recognized by Windows and command-tab working to switch to mac applications) with one exception: shift F11 will show the Mac desktop in slow motion. I have disabled all relevant system shortcuts that are available in system prefs. In my recollection this has been the behavior for several builds.