Results 1 to 10 of 10

Thread: /etc/psa-spf/spfbehavior: No such file or directory

  1. #1

    Question /etc/psa-spf/spfbehavior: No such file or directory

    Hi,

    I get this error :


    qmail-queue-handlers[9735]: handlers_stderr: Unable to open file /etc/psa-spf/spfbehavior: No such file or directory System error 2: No such file or directory
    in /usr/local/psa/var/log/maillog


    I get it every 3/4 minutes in my log. I have no spfbehavior file in /etc/psa-spf

    Is this normal or how do I correct this error? I think this make spf not working, isn't it?



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    What is version of your Plesk? As I remember it can be fixed for 9.2.3 with psa-hotfix3-9.2.3 package reinstallation.



  3. #3

    Default

    I'm using Plesk 9.3.0



  4. #4

    Default

    I still don't know what to do to correct this error



  5. #5
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    File /etc/psa-spf/spfbehavior should appear after you switch on SPF filter in Plesk interface.



  6. #6

    Default

    /etc/psa-spf/spfbehavior doesn't appear after switching on SPF filter :/



  7. #7
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    Try to change 'SPF checking mode'. I have tried it on my test environment and I see /etc/psa-spf/spfbehavior now.



  8. #8

    Default

    Still doesn't work for me Is there a log file that can give me a better idea of what's going on?



  9. #9
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    Check that you have correct permissions there and maybe try to reinstall corresponding package with force:

    # rpm -qf /etc/psa-spf/
    psa-mail-driver-common-9.5.1-cos5.build95100410.11

    # stat /etc/psa-spf/
    File: `/etc/psa-spf/'
    Size: 4096 Blocks: 8 IO Block: 4096 directory
    Device: bfh/191d Inode: 20170187 Links: 2
    Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 31/ popuser)



  10. #10

    Default

    Same problem:
    qmail-queue-handlers[24005]: handlers_stderr: Unable to open file /etc/psa-spf/spfbehavior: Permission denied System error 13: Permission denied

    I have turned on and turned off SPF checking via Plesl - no change.

    I have looked at /etc/psa-spf
    (lrwxrwxrwx 1 root root 12 Dec 27 2009 psa-spf -> /etc/psa/spf)
    cd psa-spf
    [root@webfeat psa-spf]# ls -l
    total 12
    -rw-r--r-- 1 root root 1 Sep 27 08:35 spfbehavior
    -rw-r--r-- 1 root root 74 Sep 22 20:28 spfexp
    -rw-r--r-- 1 root root 29 Sep 22 20:28 spfguess
    -rw-r--r-- 1 root root 0 Apr 14 12:22 spfrules
    [root@webfeat psa-spf]# cat 'spfbehavior' | less

    1
    (END)
    [root@webfeat psa-spf]# rpm -qf /etc/psa-spf/
    psa-mail-driver-common-9.5.2-cos5.build95100504.12


    I have made a change to rule via Plesk (from 3 to 1) and change was reflected in file spfbehavior = no change either.
    Error messages continue:
    qmail-queue-handlers[15643]: handlers_stderr: Unable to open file /etc/psa-spf/spfbehavior: Permission denied System error 13: Permission denied



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •