Results 1 to 7 of 7

Thread: Keeping two VM copies in sync

  1. #1
    Bit Poster
    Join Date
    Jul 2007
    Posts
    7

    Default Keeping two VM copies in sync

    I have a WinXP VM that I prefer to run off a firewire disk so my MacOS is not fighting the VM for the disk. I keep a copy of this VM on my local drive just in case I need it and don't have the firewire drive with me. They are listed as separate machines in the Virtual Machine List, which is fine, but does anyone have any thoughts on how to synchronize any changes made on one VM to the other?

    I never have them both running at the same time and I usually shut down the VM when done as it takes about the same amount of time to reboot as to resume. So far I've been using rsync in a script file to copy from one to another, but that seems inefficient. Anyone have any ideas?



  2. #2
    Tera Poster
    Join Date
    Nov 2009
    Location
    Hamburg
    Posts
    626

    Default

    Hmmm... the easiest way I could imagine is to copy the VM from one drive to the other. Eg if you're mainly working with the VM on the FW drive, copy it over to your hard drive once you've shut it down. That may, of course, take some time if the virtual hard drive is large. I do this the other way round - I make backups of my VM (which sits on my Mac's hard drive) to a USB drive every few days.

    On a related note, do you really find a speed improvement when you keep your VM on a (presumably external) FW drive? How much, just about? I'm asking because I think most everyone here has an interest in making the VM as fast as possible. I would have thought that that mattered only when both Mac and VM are accessing the disk a lot, worst case being both Mac and VM are thrashing when they begin to run out of memory. Thanks for any info!



  3. #3
    Bit Poster
    Join Date
    Jul 2007
    Posts
    7

    Default

    I've found that using rsync as is to do the entire contents causes Parallels to report the VM as corrupted. I could get around it by removing and re-adding the VM, but that was a pain. I was able to get it to sync properly as long as I exclude the config.pvs file (I also throw in the parallels.log file in for good measure). I wish it could do bit level copies rather than having to copy the full contents over each time, but oh well.

    To answer your question about the firewire drive, it is considerably faster, but only when disk access is involved. My MBP (with a 5400RPM HD) barely notices when the VM is booting off the FW disk, but it's a definite slow down when booting off a local disk. This isn't as much of an issue on my other MBP which has a 7200RPM HD. I haven't tested any of this on my wife's iMac, but I'm sure the results will be similar.



  4. #4
    Tera Poster
    Join Date
    Nov 2009
    Location
    Hamburg
    Posts
    626

    Default

    Ooooh, thanks for that morsel. I'm running the VM off an MBAir's internal disk, I'll try running it off an external USB disk (can't be that much slower than the Air's internal disk:-)



  5. #5
    Tera Poster
    Join Date
    Nov 2009
    Location
    Hamburg
    Posts
    626

    Default

    I am now running a VM off an external USB drive connected to my MBAir and there are indeed significant VM performance benefits. Which I guess proves that the hard disks that Apple puts into its MBAirs aren't particularly fast.

    Great tip, that! I'll try to see whether this is really the VM fighting the Mac for hard disk access; I'll try moving the virtual disk that holds my VM's virtual memory to the external disk, maybe that's already sufficient to boost the speed.



  6. #6
    Bit Poster
    Join Date
    Jul 2007
    Posts
    7

    Default

    Glad to hear!

    How are you breaking up the virtual memory? Did you just create a separate virtual disk for it?



  7. #7
    Tera Poster
    Join Date
    Nov 2009
    Location
    Hamburg
    Posts
    626

    Default

    Yes, a separate virtual disk which is just 2 GB (I'm running a 1 GB VM and the VM's virtual memory is fixed to 1.5 GB). I briefly tested putting just the virtual disk containing the VM's swap file on the external drive today; it seems less promising than putting the entire VM on a separate disk, at least juding by startup time (boot -> Windows 7 desktop including all widgets is fully shown) - but I didn't reboot the Mac in between, so there may be all kinds of reasons. I'll do a little more extensive investigation tonight.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •