Page 1 of 2 1 2 LastLast
Results 1 to 20 of 22

Thread: Optical drive not recognized by some Linux 2.6.20 kernels

  1. #1

    Default Optical drive not recognized by some Linux 2.6.20 kernels

    This is a continuation of the thread I started here: http://forums.parallels.com/thread8763.html

    The problem is essentially that if I boot a Linux virtual machine in Parallels (build 3188) running the newer flavors of kernel version 2.6.20, the virtualized optical drive does not work. I wanted to blame this on Parallels, but the fact is that the optical drive works just fine with early versions of the 2.6.20 kernel and 2.6.19 and lower. So, it must have been a kernel change that caused the problem.

    I am specifically having the issue in Ubuntu Feisty Herd 5, Ubuntu Feisty Beta, and Fedora 7 test 2 and test 1.

    I filed a bug report with Ubuntu here: https://launchpad.net/ubuntu/+source....20/+bug/95830

    I am hoping it gets looked at since the issue will likely affect other Parallels users who run Linux VMs.

    Speak up if anyone else has this problem or if you have an Intel Mac to test the problem with.



  2. #2

    Default

    I just added a bug report for the Fedora side of things in RedHat's bugzilla. Check it out at: https://bugzilla.redhat.com/bugzilla....cgi?id=233814

    I guess now it is time to wait and see if anyone notices. I think I'm going to shoot a quick email to the Parallels team with those bug report links as well.



  3. #3

    Default

    Hehe...looks like I wasn't making this up...

    See these other threads:
    http://forums.parallels.com/thread10333.html
    http://forums.parallels.com/thread10297.html

    Also, there have been updates in both the Fedora and especially the Ubuntu bug reports. Check them out for more info:
    Fedora: https://bugzilla.redhat.com/bugzilla....cgi?id=233814
    Ubuntu: https://launchpad.net/bugs/95830



  4. #4
    Kilo Poster
    Join Date
    Apr 2006
    Posts
    49

    Default

    I have the same problem, please fix this!

    I'm a parallels user since day one (no joke) and I've also pre ordered it during the first beta period.

    It's a pitty that I now have to install vmware fusion because I need Ubuntu 7 today (University Project).

    lg philipp



  5. #5
    Mega Poster
    Join Date
    Jan 2007
    Posts
    230

    Default

    There is an error into Parallels CDROM emulation ( but may be not error at all) .
    For those who familar with linux kernel - inquiry command for CDROM comes with zero into Cylinder IDE register. Parallels doesn't like zero value there.
    It will be fixed into future. I don't know will update comes or release including this fix.

    So. there is a work around to avoid this checking, simply set VM type as SOLARIS, in this case CDROM will work. But... of couse Ubuntu may work unstable or even fails. Because incorrect OS type is set. Anyway I succesfully booted Ubuntu 7.04

    This also true for Fedora Core 7 (As I've seen error log here https://bugs.launchpad.net/ubuntu/+s....20/+bug/95830)

    I've checked it more , all commands come with zero into Cylinder IDE register, so It will be fixed surely.
    Last edited by mmika; Apr 4, 2007 at 09:59 AM.



  6. #6

    Default Installing Ubuntu 7.04 on Parallels success

    here is what I did
    as suggested by the user mmika before me, select solaris as your machine and then boot and install.
    when you are done just click on the configuration of the virtual machine and change it back to linux. boot at you will see it will take a bit and then give you a login screen.
    hope this helps
    good luck



  7. #7
    Kilo Poster
    Join Date
    Jan 2007
    Location
    NY
    Posts
    11

    Default

    Not to look a gift horse in the mouth, but is there a logical explaination as to why this Solaris "trick" seems to work? Just curious



  8. #8

    Default

    I'm guessing Parallels has slightly different CD-ROM emulation to suit different OS types. Though I would have thought just a standard emulation would work across all of them...

    I'm mainly posting to say that switching to Solaris (Other Solaris) gets me past the CD-ROM detection error. I first tried changing to Linux (Other) rather than Linux (2.6 Kernel), but that didn't help.

    Thanks mmika.

    Cheers,
    Paul



  9. #9
    Kilo Poster
    Join Date
    Jan 2007
    Location
    NY
    Posts
    11

    Default

    Thanks mmika and Paul. I can certainly feel confident in giving feisty fawn a go now.



  10. #10
    Kilo Poster
    Join Date
    Jan 2007
    Location
    NY
    Posts
    11

    Default

    I attempted to install Feisty Fawn this evening on four separate occasions, to no avail. As per the instructions above, I created a VM based upon both a Solaris 10 and a Solaris other installation using Parallels build 3188. Initially, I elected to create a custom install using 1 GB of RAM and a 6 GB partition. After booting from the live CD, I got the "Unable to locate RSDP" message that so many others have reported. Nevertheless, the install proceeded without a hitch and I was able to specify all my settings.

    Upon reboot, I once again got the "ACPI: Unable to locate..." message (although it did eventually boot to the desktop). While on the desktop, I noticed the network error indicator in the top right corner of the screen, as well as a volume icon that appeared to show muted volume. When I clicked on the volume, I received a message that no sound card was configured. Once it was enabled via Parallels, I had no problem. Moving on to the networking issue, I confirmed that my ethernet connection was enabled via shared networking through Parallels. Unfortunately, I was still unable to gain internet access. Not quite sure what I'm doing wrong, but I attempted a Typical install as well and ran into the same issues. Perhaps when re-configuring the VM after install, I did not switch the VM to Linux Kernal 2.6 at the proper time? Does this have to be done before Ubuntu requests a re-boot after the initial install? Apologies for the long-winded post. Any help greatly appreciated.

    Joe
    Last edited by oneway23; Apr 21, 2007 at 09:26 PM.



  11. #11
    Bit Poster
    Join Date
    Apr 2007
    Posts
    1

    Default

    Quote Originally Posted by oneway23
    I attempted to install Feisty Fawn this evening on four separate occasions, to no avail. As per the instructions above, I created a VM based upon both a Solaris 10 and a Solaris other installation using Parallels build 3188. Initially, I elected to create a custom install using 1 GB of RAM and a 6 GB partition. After booting from the live CD, I got the "Unable to locate RSDP" message that so many others have reported. Nevertheless, the install proceeded without a hitch and I was able to specify all my settings.

    Upon reboot, I once again got the "ACPI: Unable to locate..." message (although it did eventually boot to the desktop). While on the desktop, I noticed the network error indicator in the top right corner of the screen, as well as a volume icon that appeared to show muted volume. When I clicked on the volume, I received a message that no sound card was configured. Once it was enabled via Parallels, I had no problem. Moving on to the networking issue, I confirmed that my ethernet connection was enabled via shared networking through Parallels. Unfortunately, I was still unable to gain internet access. Not quite sure what I'm doing wrong, but I attempted a Typical install as well and ran into the same issues. Perhaps when re-configuring the VM after install, I did not switch the VM to Linux Kernal 2.6 at the proper time? Does this have to be done before Ubuntu requests a re-boot after the initial install? Apologies for the long-winded post. Any help greatly appreciated.

    Joe
    I got it to work. After the install is complete, don't reboot. Select "continue using Live" (or whatever it says) and then manually shutdown Ubuntu. After it's done, stop the VM, and then change the settings to Linux 2.6 and start the VM. Hopefully that works for you.



  12. #12
    Kilo Poster
    Join Date
    Oct 2006
    Posts
    15

    Default

    I failed to be able to install the cd at all. Errors as reported by others. So, I tried the dvd versions first in VMWare Fusion, of kubuntu and then of ubuntu. [I get free downloads from the mirror on my ISP server, so a 4gb d/l is ok :)] Both worked without a hitch. Then I tried the ubuntu DVD in Parallels. In a straight-out attempt, it failed. So I tried as Solaris, other solaris. This worked, in the sense that when it starts up it still reports that "Unable to locate RSDP" message, but if you ignore that it happily keeps booting [you may sometimes need to reboot]. Changed the name back to Ubuntu and I'm OK.
    iMac 2.1GHz, 2GB RAM, OS X 10.4.8,
    Parallels Workstation for Mac with:
    Win XP and Kubuntu 6.06, Mandriva 2007 Free and SUSE 10



  13. #13

    Default

    I got Fiesty Fawn Server to install on the Mac Book Pro by using Q , the OS X Gui for Qemu. It's slower that Parallels but, gets teh job done until Parallels has a work around.

    The trick of using Solaris 10 as the guest OS doesn't seem to work for Fiesty Fawn Server.



  14. #14

    Default

    Quote Originally Posted by tjkrz
    I got it to work. After the install is complete, don't reboot. Select "continue using Live" (or whatever it says) and then manually shutdown Ubuntu. After it's done, stop the VM, and then change the settings to Linux 2.6 and start the VM. Hopefully that works for you.
    Unfortunately this is not an option when installing off the server ISO ubuntu-7.04-server-i386.iso



  15. #15

    Default Ubuntu Network Adaptor Issue

    Quote Originally Posted by oneway23
    I attempted to install Feisty Fawn this evening on four separate occasions, to no avail. As per the instructions above, I created a VM based upon both a Solaris 10 and a Solaris other installation using Parallels build 3188. Initially, I elected to create a custom install using 1 GB of RAM and a 6 GB partition. After booting from the live CD, I got the "Unable to locate RSDP" message that so many others have reported. Nevertheless, the install proceeded without a hitch and I was able to specify all my settings.

    Upon reboot, I once again got the "ACPI: Unable to locate..." message (although it did eventually boot to the desktop). While on the desktop, I noticed the network error indicator in the top right corner of the screen, as well as a volume icon that appeared to show muted volume. When I clicked on the volume, I received a message that no sound card was configured. Once it was enabled via Parallels, I had no problem. Moving on to the networking issue, I confirmed that my ethernet connection was enabled via shared networking through Parallels. Unfortunately, I was still unable to gain internet access. Not quite sure what I'm doing wrong, but I attempted a Typical install as well and ran into the same issues. Perhaps when re-configuring the VM after install, I did not switch the VM to Linux Kernal 2.6 at the proper time? Does this have to be done before Ubuntu requests a re-boot after the initial install? Apologies for the long-winded post. Any help greatly appreciated.

    Joe
    I found this thread EXTREMELY helpful while I was installing Ubuntu 7.04 through Parallels on my MacBook. I had this same trouble that Joe was having. I fixed the sound card the same way and to fix the networking issue I went into the Parallels Network Adapter and changed it to "Default Adapter", bottom right of the OS window. Then I clicked the "Wired Network Connection" icon in Ubuntu and reselected "Wired Network" and when it refreshed the connection came up perfectly without a problem.

    I could now run updates and get out to the internet.

    Hope this helps and thanks to everyone in this thread that posted what they did to get Ubuntu up and running. :cool:



  16. #16

    Default

    Quote Originally Posted by bozwayed
    here is what I did
    as suggested by the user mmika before me, select solaris as your machine and then boot and install.
    when you are done just click on the configuration of the virtual machine and change it back to linux. boot at you will see it will take a bit and then give you a login screen.
    hope this helps
    good luck
    This worked for me!



  17. #17

    Default Workaround to install Ubuntu Feisty Server

    I've written up a workaround to install Ubuntu 7.04 Feisty Fawn Server on Parallels 3188.
    This covers installing Feisty Server - a different kettle of fish to installing Feisty Desktop, though both make use of the Solaris CDROM emulation.



  18. #18
    Mega Poster
    Join Date
    Jan 2007
    Posts
    230

    Default

    Attaboy Paul Annesley. Good article, I hope it will be helpful for many users.
    But CDROM problems it is Parallels mistake, and it is fixed already .
    Thank you.



  19. #19

    Default

    Good to hear the CDROM emulation issue in Parallels has been fixed - I look forward to the update coming through.



  20. #20

    Default Thank you!

    I followed the advice of mmika (Setting up VM as Solaris 10), then tjkrz (closing down VM and changing it to Linux Kernel 2.6) and then cassidyj (changing to default network then reselecting wired network) and have now successfully installed Ubuntu 7.04 and its working like a charm :)

    Thanks a lot guys, much appreciated!



Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •