Results 1 to 6 of 6

Thread: is PHP support PEAR?

  1. #1

    Default is PHP support PEAR?

    Hi,

    May I know if PHP in Plesk Windows support PEAR? I checked in phpinfo(), i saw this:

    include_path .;./includes;./pear .;./includes;./pear

    But when i enter below code

    <?php
    require_once 'System.php';
    var_dump(class_exists('System'));
    ?>

    It shows:
    Warning: require_once(System.php) [function.require-once]: failed to open stream: No such file or directory in D:\inetpub\vhosts\oxy.com.my\httpdocs\php\mailtest .php on line 2

    Fatal error: require_once() [function.require]: Failed opening required 'System.php' (include_path='.;./includes;./pear') in D:\inetpub\vhosts\oxy.com.my\httpdocs\php\mailtest .php on line 2

    I read from another forum, they advice to change the path in php.ini. My current config in php.ini is:

    ; Windows: "\path1;\path2"
    ;include_path = ".;c:\php\includes"
    include_path = ".;./includes;./pear"

    Please advice.

    Thanks.



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,762



  3. #3

    Default

    other than PEAR, what else can customer use to send out email using PHP script? They tried to use mail() but failed, is it blocked in Plesk?



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,762

    Default

    Quote Originally Posted by Helen Pang View Post
    other than PEAR, what else can customer use to send out email using PHP script? They tried to use mail() but failed, is it blocked in Plesk?
    PHP mail() function should work without any problems. Make sure that php.ini has SMTP host as localhost.
    [Mail Function]
    SMTP = 127.0.0.1
    And test it using the following sample script,

    <?php
    mail("myemail@example.com", "My Subject", "It Works!!");
    ?>



  5. #5

    Default

    I've checked the php.ini, it shows

    [mail function]
    ; For Win32 only.
    SMTP = localhost
    smtp_port = 25

    but when i tested it with the script you given, it shows:

    Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\inetpub\vhosts\domain.com\httpdocs\php\mailtest .php on line 2

    please help.

    Thanks.



  6. #6
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,762

    Default

    Do you have opened port 25 on your Plesk server? Try to check it with

    telnet localhost 25

    If you have SMTP server started outside your Plesk server - specify it in php.ini instead localhost.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •