Results 1 to 4 of 4

Thread: PVA 4.6 - Dependency check failed

  1. #1
    Kilo Poster
    Join Date
    Oct 2009
    Posts
    26

    Default PVA 4.6 - Dependency check failed

    I am trying to migrate from PIM to PVA and follwing the guide for this I first created a new container in on the HN with CentOS 5.5 and then execute the pva-setup-deploy.x86_64 file.

    I get the following errors:
    10/19/10 11:20:00 [ERROR] rpm_error_handler at ../lib/RedHatPackageHelper.cpp:371, Dependency check failed:
    libstdc++.so.5()(64bit) is needed by pva-cc-engine-4.6-211.2.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by pva-cc-engine-4.6-211.2.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by pva-cc-engine-4.6-211.2.x86_64
    pva-cc-httpd is needed by pva-cc-engine-4.6-211.2.x86_64
    libstdc++.so.5()(64bit) is needed by pva-cc-engine-third-4.6-211.2.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by pva-cc-engine-third-4.6-211.2.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by pva-cc-engine-third-4.6-211.2.x86_64
    libstdc++.so.5()(64bit) is needed by pva-mn-4.6-643.1.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by pva-mn-4.6-643.1.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by pva-mn-4.6-643.1.x86_64
    libstdc++.so.5()(64bit) is needed by pva-mn-core-4.6-646.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by pva-mn-core-4.6-646.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by pva-mn-core-4.6-646.x86_64
    libstdc++.so.5(GLIBCPP_3.2.2)(64bit) is needed by pva-mn-core-4.6-646.x86_64
    libstdc++.so.5()(64bit) is needed by pva-mn-core-third-4.6-646.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by pva-mn-core-third-4.6-646.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by pva-mn-core-third-4.6-646.x86_64
    perl(DBI) is needed by MySQL-client-5.0.51a-0.glibc23.x86_64
    perl(DBI) is needed by MySQL-server-5.0.51a-0.glibc23.x86_64
    libstdc++.so.5()(64bit) is needed by ssohelper-4.0.0-7.swsoft.x86_64
    libstdc++.so.5(CXXABI_1.2)(64bit) is needed by ssohelper-4.0.0-7.swsoft.x86_64
    libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by ssohelper-4.0.0-7.swsoft.x86_64
    Checking whether the packages are installed:
    # rpm -qa|grep libstdc
    libstdc++-4.1.2-48.el5
    libstdc++-4.1.2-48.el5
    # rpm -qa|grep perl
    perl-Convert-ASN1-0.20-1.1
    perl-5.8.8-32.el5_5.2
    How to solve this?



  2. #2
    Kilo Poster
    Join Date
    Oct 2009
    Posts
    26

    Default

    Manually installinging the PVA Management Server from the tar package using:
    ./pva-setup --install -c "PVA Management Server"

    solved the problem. The interface is working now.



  3. #3
    Mega Poster
    Join Date
    Mar 2006
    Posts
    111

    Default

    got the same problem and managed to go further by installing compat-libstdc++-33 package inside a container which provides libstdc++.so.5 library

    this can be done from inside a container of from the node using the vzpkg:

    # vzpkg install -p 2 compat-libstdc++-33
    Loaded plugins: rpm2vzrpm
    base0 | 951 B 00:00
    base1 | 951 B 00:00
    base2 | 1.1 kB 00:00
    base3 | 1.9 kB 00:00
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libstdc++-33.i386 0:3.2.3-61 set to be updated
    --> Finished Dependency Resolution

    Dependencies Resolved

    ================================================== ================================================== ========
    Package Arch Version Repository Size
    ================================================== ================================================== ========
    Installing:
    compat-libstdc++-33 i386 3.2.3-61 base2 232 k

    Transaction Summary
    ================================================== ================================================== ========
    Install 1 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)

    Total download size: 232 k
    Downloading Packages:
    compat-libstdc++-33-3.2.3-61.i386.rpm | 232 kB 00:01
    Running rpm_check_debug
    compat-libstdc++-33-3.2.3-61.i386.rpm | 7.2 kB 00:00
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing : compat-libstdc++-33 1/1

    Installed:
    compat-libstdc++-33.i386 0:3.2.3-61

    Complete!
    Installed:
    compat-libstdc++-33 i386 3.2.3-61
    after that it failed with fairly puzzling error, trying to understand what does that mean

    Dependency check failed: │
    │ pva-cc-httpd is needed by pva-cc-engine-4.6-211.2.i386



  4. #4
    Mega Poster
    Join Date
    Mar 2006
    Posts
    111

    Default

    ok that last dependency problem was due to CentOS 5.5 is actually not supported yet. Temporarily setting redhat-release to 5.4 helped, similar as described here - http://kb.parallels.com/en/9628

    # cat /etc/redhat-release
    CentOS release 5.4 (Final)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •