Results 1 to 7 of 7

Thread: Backup Failing after Upgrade from 10.1 to 10.3.1

  1. #1
    Kilo Poster
    Join Date
    Nov 2010
    Posts
    21

    Question Backup Failing after Upgrade from 10.1 to 10.3.1

    Scheduled backup tasks (and manually run ones) are failing with error message:

    <?xml version="1.0" encoding="UTF-8"?>
    <execution-result status="error" log-location="/usr/local/psa/PMM/sessions/2011-08-08-233811.726/migration.result">
    <message id="f620681f-6c53-42ee-881e-21f16e7bcffc" severity="error" code="fatal">
    <description>Runtime error</description>
    </message>
    <message id="eb3bf819-63b8-4280-8291-e413efde589f" severity="error" code="CheckDump">
    <description>Unable to check dump: Could not check dump. Invalid xml response:
    at /usr/local/psa/PMM/agents/PleskX/PmmCli.pm line 177
    PmmCli:arseCheckDumpResult('Error: adjacent parameter is empty in \'dump-file-specificati...') called at /usr/local/psa/admin/bin/plesk_agent_manager line 1126
    main::checkDump('/var/lib/psa/dumps', '', '/usr/local/psa/PMM/sessions/2011-08-08-233811.726') called at /usr/local/psa/admin/bin/plesk_agent_manager line 661
    main::__ANON__() called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 415
    eval {...} called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 407
    Error::subs::try('CODE(0xf65300)', 'HASH(0xf656e0)') called at /usr/local/psa/admin/bin/plesk_agent_manager line 670
    main:erform('verbose', 4, 'owner-type', 'server', 'split-size', 'undef', 'session-path', '/usr/local/psa/PMM/sessions/2011-08-08-233811.726', 'description', ...) called at /usr/local/psa/admin/bin/plesk_agent_manager line 1200
    main::__ANON__() called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 408
    eval {...} called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 407
    Error::subs::try('CODE(0x605170)', 'HASH(0x1de1fd0)') called at /usr/local/psa/admin/bin/plesk_agent_manager line 1209
    main::main() called at /usr/local/psa/admin/bin/plesk_agent_manager line 1211.
    </description>
    </message>
    <message id="06a8156c-b90b-49f5-8914-c2c0a2dc0841" severity="error" code="fatal">
    <description>Unable to create dump</description>
    </message>
    <message id="4db1a3fb-cd75-4c5e-8b7e-2a938a3e9212" severity="error" code="UtilityError">
    <description>Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT.</description>
    </message>
    Can any help with understanding this error, and what actions I could take?

    Regards

    Mike
    </execution-result>



  2. #2

    Default

    You may use http://kb.parallels.com/en/6080 to get information about errors in backup structure and /usr/local/psa/PMM/sessions/<your backup session directory>/psadump.log to get additional information about backup process.



  3. #3
    Kilo Poster
    Join Date
    Nov 2010
    Posts
    21

    Default

    Thanks Sergev for your suggestion.

    Not sure I can find an XML file for the failed backups to verify.

    Beneath the "Current Backup Tasks" in Backup Manager it states:

    Aug 8, 2011 11:38 PM |TestBack | Personal FTP | Failed | Remove
    Clicking 'TestBack' link shows the error I posted earlier.

    Sorry, can't see a link to an XML file for verification.

    Regards

    Mike



  4. #4

    Default

    Hello,

    we got the same error after updating to Plesk 10.3.1

    Because of the error description "Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT: )" and because of the fact we do not use Applications on that server until now - I have deleted the APS applications we uploaded into the Application Vault before.

    After this the backup job was successful. But I donīt know if it will work if we upload APS-Packages again...

    regards,
    Maximilian



  5. #5
    Kilo Poster
    Join Date
    Nov 2010
    Posts
    21

    Default

    Found the relevant psadump.log and last few lines state:

    /bin/tar: Error exit delayed from previous errors
    Runtime error: Cannot export files
    at /usr/local/psa/admin/bin/plesk_agent_manager line 1111
    main::exportFilesTo('/var/lib/psa/dumps', 'ARRAY(0x1bbf820)', '/var/lib/psa/dumps', 'undef', 0, 'undef', 1) called at /usr/local/psa/admin/bin/plesk_agent_manager line 688
    main:erform('verbose', 4, 'owner-type', 'server', 'split-size', 'undef', 'session-path', '/usr/local/psa/PMM/sessions/2011-08-12-014835.987', 'description', ...) called at /usr/local/psa/admin/bin/plesk_agent_manager line 1200
    main::__ANON__() called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 408
    eval {...} called at /usr/lib/perl5/vendor_perl/5.8.8/Error.pm line 407
    Error::subs::try('CODE(0x605170)', 'HASH(0x1de1fd0)') called at /usr/local/psa/admin/bin/plesk_agent_manager line 1209
    main::main() called at /usr/local/psa/admin/bin/plesk_agent_manager line 1211.



  6. #6
    Kilo Poster
    Join Date
    Nov 2010
    Posts
    21

    Default Is backup failure related to connection to APS?

    In part of the backup error it states "Unable to get Global settings for APS Applications "

    I did find I had to comment out "skip-networking" to get my bootstrapper.sh repair to work, as it failed on connecting to APS.

    Could this backup problem be the same? Is there an equivalent, 'skip-networking' for a back-up task?



  7. #7

    Default Same problem resolved

    Unable to get Global settings for APS Applications (ErrorCode: 3, STDOUT.

    Resolved by going: Tools > Application Vault > Clear Cache



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •