Results 1 to 3 of 3

Thread: PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown o

  1. #1
    Bit Poster
    Join Date
    Aug 2011
    Location
    Canada
    Posts
    3

    Default PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown o

    PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0

    PHP Fatal error: require_once(): Failed opening required 'modules/rss_import/magpierss/rss_fetch.inc'
    (include_path='.') in /var/www/vhosts/blogengage.com/httpdocs/modules/rss_import/rss_file.php on line 311

    /*================================================= ======================*\
    Function: _response_to_rss
    Purpose: parse an HTTP response object into an RSS object
    Input: an HTTP response object (see Snoopy)
    Output: parsed RSS object (see rss_parse)
    \*================================================ =======================*/
    function _response_to_rss ($resp) {
    $rss = new MagpieRSS( $resp->results, MAGPIE_OUTPUT_ENCODING, MAGPIE_INPUT_ENCODING, MAGPIE_DETECT_ENCODING );

    // if RSS parsed successfully
    if ( $rss and !$rss->ERROR) {

    // find Etag, and Last-Modified
    foreach($resp->headers as $h) {
    // 2003-03-02 - Nicola Asuni (www.tecnick.com) - fixed bug "Undefined offset: 1"
    if (strpos($h, ": ")) {
    list($field, $val) = explode(": ", $h, 2);
    }
    else {
    $field = $h;
    $val = "";
    }

    if ( $field == 'ETag' ) {
    $rss->etag = $val;
    }

    if ( $field == 'Last-Modified' ) {
    $rss->last_modified = $val;
    }
    }

    return $rss;
    } // else construct error message
    else {
    $errormsg = "Failed to parse RSS file.";

    if ($rss) {
    $errormsg .= " (" . $rss->ERROR . ")";
    }
    error_rss($errormsg);

    return false;
    } // end if ($rss and !$rss->error)
    }
    Any suggestions to what s happening? How to fix it?

    Thanks,

    Brian



  2. #2
    Mega Poster
    Join Date
    Jul 2009
    Posts
    104

    Default

    Hello, for this error

    PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown o

    Remove

    safe_mode = "On/Off" from your php.ini, so you don't have again this error. For the second error, is possible that your software don't like php53?



  3. #3
    Mega Poster
    Join Date
    Apr 2006
    Posts
    249

    Default

    Why is it still used by plesk when installing php 5.3 set so? (safe mode)

    With parallels hasn't removed it in the 5.3 installation?

    Thanks.
    No



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •