Results 1 to 9 of 9

Thread: Can't create Subdomains

  1. #1

    Default Can't create Subdomains

    Panel-Version 10.3.1
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-35squeeze2)

    Hi,
    I cant add a subdomain to my domains and I dont know why

    Plesk added the subdomain to the DNS:
    subdomain.mydomain.com A myIP

    In the panel configuration I tried to point the subdomain to a folder in /var/www/vhosts/mydomain.com/httpdocs/subdomain
    and I tried to point it to the /var/www/vhosts/mydomain.com/subdomains/subdomain

    I tried to to set the domain up with FastCGI and I tried it with Apache Module.

    But when I try to open it in the browser all I get is "Server not found".



  2. #2

    Default

    Searching the failure since Days

    Here the generated httpd.include, seems to be right??

    13170495000.30068600_httpd.include:

    <VirtualHost myIP:80>
    ServerName "myDomain.com:80"
    ServerAlias "www.myDomain.com"
    UseCanonicalName Off

    <IfModule mod_suexec.c>
    SuexecUserGroup "me" "psacln"
    </IfModule>

    ServerAdmin "info@myDomain.com"

    DocumentRoot "/var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1"
    CustomLog /var/www/vhosts/myDomain.com/statistics/logs/access_log plesklog
    ErrorLog "/var/www/vhosts/myDomain.com/statistics/logs/error_log"



    <IfModule mod_userdir.c>
    UserDir "/var/www/vhosts/myDomain.com/web_users"
    </IfModule>

    ScriptAlias "/cgi-bin/" "/var/www/vhosts/myDomain.com/cgi-bin/"



    Alias "/plesk-stat" "/var/www/vhosts/myDomain.com/statistics"
    <Location /plesk-stat/>
    Options +Indexes
    </Location>
    <Location /plesk-stat/logs/>
    Require valid-user
    </Location>
    Alias /webstat /var/www/vhosts/myDomain.com/statistics/webstat
    Alias /webstat-ssl /var/www/vhosts/myDomain.com/statistics/webstat-ssl
    Alias /ftpstat /var/www/vhosts/myDomain.com/statistics/ftpstat
    Alias /anon_ftpstat /var/www/vhosts/myDomain.com/statistics/anon_ftpstat

    Alias /awstats-icon /usr/share/awstats/icon



    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>

    SetEnv PP_CUSTOM_PHP_INI /var/www/vhosts/myDomain.com/etc/php.ini

    <IfModule mod_fcgid.c>
    FcgidInitialEnv PP_CUSTOM_PHP_INI /var/www/vhosts/myDomain.com/etc/php.ini
    </IfModule>

    <Directory /var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1>

    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>
    </IfModule>
    <IfModule mod_python.c>
    <Files ~ (\.py$)>
    SetHandler python-program
    PythonHandler mod_python.cgihandler
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.fcgi)>
    SetHandler fcgid-script
    Options +FollowSymLinks +ExecCGI
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.php)>
    SetHandler fcgid-script
    FCGIWrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
    Options +ExecCGI
    allow from all
    </Files>
    </IfModule>


    Options -Includes +ExecCGI

    </Directory>



    Alias /error_docs /var/www/vhosts/myDomain.com/error_docs
    ErrorDocument 400 /error_docs/bad_request.html
    # all the other ErrorDocuments

    Include "/var/www/vhosts/myDomain.com/conf/vhost.conf"

    </VirtualHost>


    <VirtualHost myIP:80>
    ServerName "admin.myDomain.com:80"
    UseCanonicalName Off

    <IfModule mod_suexec.c>
    SuexecUserGroup "me" "psacln"
    </IfModule>

    ServerAdmin "info@myDomain.com"

    DocumentRoot "/var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1"
    CustomLog /var/www/vhosts/myDomain.com/statistics/logs/access_log plesklog
    ErrorLog "/var/www/vhosts/myDomain.com/statistics/logs/error_log"



    ScriptAlias /cgi-bin/ "/var/www/vhosts/myDomain.com/subdomains/admin/cgi-bin/"


    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>

    <Directory /var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1>

    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>
    </IfModule>
    <IfModule mod_php4.c>
    php_admin_flag engine on
    php_admin_flag safe_mode off
    php_admin_value open_basedir /var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1/:/tmp/
    </IfModule>

    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode off
    php_admin_value open_basedir /var/www/vhosts/myDomain.com/httpdocs/typo3/projekt1/:/tmp/
    </IfModule>
    <IfModule mod_python.c>
    <Files ~ (\.py$)>
    SetHandler python-program
    PythonHandler mod_python.cgihandler
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.fcgi)>
    SetHandler fcgid-script
    Options +FollowSymLinks +ExecCGI
    </Files>
    </IfModule>


    Options -Includes +ExecCGI

    </Directory>

    Alias /error_docs /var/www/vhosts/myDomain.com/error_docs
    ErrorDocument 400 /error_docs/bad_request.html
    # all the other ErrorDocuments


    </VirtualHost>


    <VirtualHost myIP:80>
    ServerName "subdomain1.myDomain.com:80"
    UseCanonicalName Off

    <IfModule mod_suexec.c>
    SuexecUserGroup "me" "psacln"
    </IfModule>

    ServerAdmin "info@myDomain.com"

    DocumentRoot "/var/www/vhosts/myDomain.com/site2"
    CustomLog /var/www/vhosts/myDomain.com/statistics/logs/access_log plesklog
    ErrorLog "/var/www/vhosts/myDomain.com/statistics/logs/error_log"



    ScriptAlias /cgi-bin/ "/var/www/vhosts/myDomain.com/subdomains/subdomain1/cgi-bin/"


    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>

    <Directory /var/www/vhosts/myDomain.com/site2>

    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>
    </IfModule>
    <IfModule mod_python.c>
    <Files ~ (\.py$)>
    SetHandler python-program
    PythonHandler mod_python.cgihandler
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.fcgi)>
    SetHandler fcgid-script
    Options +FollowSymLinks +ExecCGI
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.php)>
    SetHandler fcgid-script
    FCGIWrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
    Options +ExecCGI
    allow from all
    </Files>
    </IfModule>


    Options -Includes +ExecCGI

    </Directory>

    Alias /error_docs /var/www/vhosts/myDomain.com/error_docs
    ErrorDocument 400 /error_docs/bad_request.html
    # all the other ErrorDocuments

    </VirtualHost>


    <VirtualHost myIP:80>
    ServerName "subdomain2.myDomain.com:80"
    UseCanonicalName Off

    <IfModule mod_suexec.c>
    SuexecUserGroup "me" "psacln"
    </IfModule>

    ServerAdmin "info@myDomain.com"

    DocumentRoot "/var/www/vhosts/myDomain.com/httpdocs/typo3/subdomain2"
    CustomLog /var/www/vhosts/myDomain.com/statistics/logs/access_log plesklog
    ErrorLog "/var/www/vhosts/myDomain.com/statistics/logs/error_log"



    ScriptAlias /cgi-bin/ "/var/www/vhosts/myDomain.com/subdomains/subdomain2/cgi-bin/"


    <IfModule mod_ssl.c>
    SSLEngine off
    </IfModule>

    <Directory /var/www/vhosts/myDomain.com/httpdocs/typo3/subdomain2>

    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
    SetHandler perl-script
    PerlHandler ModPerl::Registry
    Options ExecCGI
    allow from all
    PerlSendHeader On
    </Files>
    </IfModule>
    <IfModule mod_php4.c>
    php_admin_flag engine on
    php_admin_flag safe_mode off
    php_admin_value open_basedir /var/www/vhosts/myDomain.com/httpdocs/typo3/subdomain2/:/tmp/
    </IfModule>

    <IfModule mod_php5.c>
    php_admin_flag engine on
    php_admin_flag safe_mode off
    php_admin_value open_basedir /var/www/vhosts/myDomain.com/httpdocs/typo3/subdomain2/:/tmp/
    </IfModule>
    <IfModule mod_python.c>
    <Files ~ (\.py$)>
    SetHandler python-program
    PythonHandler mod_python.cgihandler
    </Files>
    </IfModule>
    <IfModule mod_fcgid.c>
    <Files ~ (\.fcgi)>
    SetHandler fcgid-script
    Options +FollowSymLinks +ExecCGI
    </Files>
    </IfModule>


    Options -Includes +ExecCGI

    </Directory>

    Alias /error_docs /var/www/vhosts/myDomain.com/error_docs
    ErrorDocument 400 /error_docs/bad_request.html
    # all the other ErrorDocuments


    </VirtualHost>



  3. #3

    Default

    Still found no solution

    Could anyone pleas post a xx_httpd.include file with subdomains that works please?

    Plesk makes not much sence if I cant set up subdomains.



  4. #4

    Default

    No idea???



  5. #5

    Default Can't create Subdomains

    Hi, JohannaZ:
    I'm seeing exactly the same problem as you are.

    The subdomains are created fine in Plesk.
    The httpd.include file is created fine and looks about the same as yours.
    The DNS has 'A' entries for subdomain.domain.com pointing to the domain.com IP address.

    So, any gurus here have any idea how to fix this?

    Paul



  6. #6

    Default

    Did you find a solution?



  7. #7
    Kilo Poster
    Join Date
    Apr 2010
    Posts
    33

    Default

    I have the same problem. Is there anybody who has an solution



  8. #8
    Bit Poster
    Join Date
    Mar 2012
    Posts
    2

    Default

    Plesk sucks same is the support,i have same problem !! why shold i pay for this crap ?



  9. #9

    Default

    I solved the Problem and saved me some money
    solution found here >>

    And there are Forums with a good response rate
    www.howtoforge.com



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •