Results 1 to 3 of 3

Thread: "No migration agents found. Data migration is not available."

  1. #1

    Default "No migration agents found. Data migration is not available."

    Hi,

    I'm trying to migrate some sites from Plesk Panel 10.3.1 to Small Business Panel 10.2.0 but get this error.

    I've already checked the Parallels KB, and have checked that both servers have different hostnames, that I can SSH in to the source server from the destination server, that there is no SSH banner etc etc.

    Here's the migration log:

    [00:01:59|INFO: 9463:p.log] Launchpad started : /usr/local/psa/admin/bin/launchpad --send-scout --host=xxxxxxxx --login=root --session-path=/usr/local/psa/PMM/msessions/20111018000159267
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] Socket created
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] Connecting to xxxxxxxx:22
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] Resolving xxxxxxxx
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] xxxxxxxx was resolved to xxxxxxxxx
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] Connected
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Trying to start SSH session
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Selected aes256-cbc encryption method
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] SSH session started successfully
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Requested authorization for user root
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Getting userauth methods for user 'root'
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Got the following allowed userauth methods: publickey,gssapi-with-mic,password
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Trying 'password' authentication
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Authenticated succesfully
    [00:01:59|DEBG: 9463:p.Ssh] Executing sh -c cd\ \;\ perl on the remote host
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] Opening SSH channel for command 'sh -c cd\ \;\ perl'
    [00:01:59|DEBG: 9463:p.Ssh] remote stdout -> <?xml version="1.0"?><scout-result>
    [00:01:59|DEBG: 9463:p.Ssh] remote stdout -> <os-info os="Linux" loadavg="1.72 1.64 1.68"/>
    [00:01:59|DEBG: 9463:p.Ssh] remote stdout -> <remote-fs><fs mountpoint="/" device="/dev/md0" mode="rw" size="113347690496" free="69468540928" type="ext3"/><fs mountpoint="/tmp" device="/dev/md1" mode="rw" size="979820544" free="910077952" type="ext3"/></remote-fs></scout-result>
    [00:01:59|DEBG: 9463:p.Ssh] Execution finished with return code 0
    [00:01:59|DEBG: 9463:p.libssh2pp.Channel] Closed
    [00:01:59|DEBG: 9463:p.libssh2pp.Session] SSH session finished
    [00:01:59|DEBG: 9463:p.libssh2pp.Socket] Connection closed
    [00:01:59|INFO: 9463:p.log] Launchpad finished. Exit code: 0
    Any ideas please?



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,618

    Default

    I have not found any errors in this log. Try to use http://kb.parallels.com/en/9679 for more detailed investigation.



  3. #3

    Default

    Thanks, I'd already seen that link actually, and followed the instructions in it.

    I tried an idea: I have a 3rd Plesk server, running Plesk Panel 10.2. I tried doing a test migration on the Small Business Panel server from this server - it worked.

    I then tried migrating to Plesk Panel 10.2 from the Plesk Panel 10.3.1 server. This failed - it said that migration from 10.3.1 wasn't supported. So I upgraded to 10.3.1. Now the migration between the two 10.3.1 servers works, but migration on SBP from the new 10.3.1 server fails with the "no migration agents fount" error again. So it seems like my SBP can't migrate from any Plesk 10.3.1 server



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •