Results 1 to 5 of 5

Thread: Audio with OS/2

  1. #1

    Default Audio with OS/2

    I am using the latest downloadable version of Parallels for Windows (2.2 build 2112).

    I cannot get audio to work in OS/2 no matter what I do. I am currently using OS/2 4.0 with Fixpak 15 which brings the system version up to 4.52, Revision 14.062. (Before I applied the Fixpak audio didn't work either.)

    I followed the instructions on the Parallels Tools CD. The ALC1$ device driver loads without errors and it even shows up in System Setup -> Hardware Manager. However, none of the multimedia utilities can play any sound.

    It's almost like the ALC.SYS driver is the wrong type of driver. It shows up as a Codec when I run MINSTALL.

    Everything else works fine -- video, network, mouse, etc.

    I am also using a trial key for Parallels, but I don't think that affects anything.



  2. #2

    Default

    I found a partial solution, using UNIAUD from Netlabs. Unfortunately it's still not perfect because it gets the timing wrong. (Basically sounds end abruptly).



  3. #3

    Default

    I'm using eComStation Release Candidate 2 under Parallels, and audio works for me. I installed using the Uniaud driver. System sounds, at least, work for me. I don't use eCS/OS2 for multimedia, so I haven't tried playing any other audio files.

    Quote Originally Posted by MennoJoshua
    I found a partial solution, using UNIAUD from Netlabs. Unfortunately it's still not perfect because it gets the timing wrong. (Basically sounds end abruptly).



  4. #4
    Kilo Poster
    Join Date
    Apr 2006
    Posts
    60

    Default

    Actually, the best driver for eCS or OS/2 (tested with MCP2) guest VM for Linux hosts is the Realtek ALC Codec Audio Device Driver for OS/2 Version 1.30 that comes with Parallels tools for OS/2.

    UNIAUD based on ALSA Project, even the lastest version 1.1.4RC3, is problematic with mp3 files if your host is a Linux.

    ALC is not perfectly too. Some applications like OS/2 Solitaire card game have conflicts with this sound driver.

    Another thing to be considered is the quality of the hardware. For example, the quality of the sound from the VM OS/2 player with my laptop Intel HDA onboard is not so good as with an external Creative Audigy 2 ZS Notebook PCMCIA card.

    You have to consider too if you'll use sound applications from Win-OS2 or not. There is no Windows 3.x diver for this virtual AC97 sound card. You will have to try DTA.

    RS37



  5. #5
    Kilo Poster
    Join Date
    Oct 2007
    Posts
    85

    Default Has anyone had / found a solution to the Linux volume level getting adjusted

    Greetings-

    Possibly can anyone on this thread confirm this problem we are encountering?

    "Parallels audio driver WAY too loud for OS/2 eCS guest"
    http://forum.parallels.com/showthread.php?t=22496

    Thanks!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •