Results 1 to 5 of 5

Thread: Bug: Deploying virtual machine template which has had virtual floppy disabled

  1. #1
    Kilo Poster
    Join Date
    Jan 2008
    Posts
    25

    Default Bug: Deploying virtual machine template which has had virtual floppy disabled

    A bug when deploying a virtual machine, which has been created with a virtual floppy disk file, but since edited and disabled the virtual floppy disk and removed the file configuration.

    It appears removing the virtual device from the template fixes this issue

    The result is in screenshots in the attachments. Picture 1: Template config, Picture 3: The error
    Attached Images Attached Images



  2. #2
    Parallels Developers sandro's Avatar
    Join Date
    Aug 2007
    Posts
    732

    Default

    Hi.

    Sorry but i'm not sure that quite understood the test case. Could you please specify it step by step and show which system behavior is wrong and what it should be.

    With best regards,
    Alexander
    with best regards,
    Alexander



  3. #3
    Kilo Poster
    Join Date
    Jan 2008
    Posts
    25

    Default

    Sandro,

    In terms of priority this would be quite low.. It seems to be more of a cosmetic issue.

    The steps required to reproduce:
    1. Create a virtual machine, and assign a virtual floppy disk to it
    2. Create a template from this virtual machine
    3. Remove the virtual floppy disk file
    4. Deploy the template to another virtual machine
    5. Disable the virtual floppy on the deployed machine

    From here, you cant actually start the deployed virtual machine because it cant find the virtual floppy file (even though you disabled the floppy).



  4. #4
    Parallels Developers sandro's Avatar
    Join Date
    Aug 2007
    Posts
    732

    Default

    OK, now i understood problem, thank you very much
    with best regards,
    Alexander



  5. #5
    Parallels Developers Sergeyt's Avatar
    Join Date
    Mar 2008
    Posts
    14

    Default

    Hello, cammj !

    Server doesn't allow to deploy VM from invalid template.
    You should repair vm-template:
    A) recreate Fdd
    * editVmConfiguration->Fdd
    * type 'my-super-floppy.fdd' in File field.
    * press Recreate
    * press Ok.
    look at attachment for details.

    B) Also You can remove Fdd from configuration.
    Attached Images Attached Images
    Last edited by Sergeyt; Apr 22, 2008 at 06:45 AM.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •