Results 1 to 8 of 8

Thread: Upgrade php to 5.2.4 or higher on Plesk 10.3.1

  1. #1
    Kilo Poster
    Join Date
    Feb 2009
    Posts
    41

    Default Upgrade php to 5.2.4 or higher on Plesk 10.3.1

    Hello, how do i upgrade php on CentOS 5.6 64bits on Plesk 10.3.1

    and on Plesk 9.6 CentOS 32 bits

    Both servers has web sites.

    Thanks
    Jc
    Social media
    www.live380.com



  2. #2

  3. #3
    Mega Poster
    Join Date
    Mar 2007
    Posts
    110

    Default

    Quote Originally Posted by J Cole View Post
    Hello, how do i upgrade php on CentOS 5.6 64bits on Plesk 10.3.1

    and on Plesk 9.6 CentOS 32 bits

    Both servers has web sites.

    Thanks
    Jc
    Php have been including the following message in all PHP releases since 5.3.6:
    All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.x

    There is a discussion of most of the issues here: Need urgent help - PHP 5.2 on Plesk 10.3.1

    So if you're ok with going to PHP 5.3 the quick ways are:

    Plesk 10.3.1
    1. Go to: "Server Management" -> "Tools and Utilities" -> "Panel" -> "Updates" and select "Add Components" (the middle one).

    2. Under "Different PHP interpreter versions" select the option "PHP5.3 support"

    3. Select "Continue"


    Plesk 9.5.4
    1. Go to: "Home" -> "Help & Support" -> "Updates" and select "Parallels Plesk Panel 9.5.4"

    2. Select "PHP5.3 support"

    3. Select "Install" on the bar above the components


    Make sure you have a backup of the whole server (not just plesk) that you can revert to. There are all kinds of dependencies involved that can leave you with a major mess if it goes wrong.


    Cheers,


    Andrew



  4. #4
    Kilo Poster
    Join Date
    Feb 2009
    Posts
    41

    Default Upgrade PHP

    Hello,

    can any tell me which of the best way to upgrade php

    Use from http://www.atomicorp.com/wiki/index.php/PHP

    or below?

    Plesk 10.3.1
    1. Go to: "Server Management" -> "Tools and Utilities" -> "Panel" -> "Updates" and select "Add Components" (the middle one).

    2. Under "Different PHP interpreter versions" select the option "PHP5.3 support"

    3. Select "Continue"


    Plesk 9.5.4
    1. Go to: "Home" -> "Help & Support" -> "Updates" and select "Parallels Plesk Panel 9.5.4"

    2. Select "PHP5.3 support"

    3. Select "Install" on the bar above the components
    Social media
    www.live380.com



  5. #5
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    14,638

    Default

    Use Plesk method.



  6. #6
    Kilo Poster
    Join Date
    Feb 2009
    Posts
    41

    Default

    Thank you, the Plesk method work on 10.31 I will try the 9.6 later

    Regards
    Social media
    www.live380.com



  7. #7
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    14,638

    Default

    Yes, you can run /usr/local/psa/admin/sbin/autoinstaller for Plesk 9.5.4 version for Centos and select PHP5.3 for installation in menu.



  8. #8
    Kilo Poster
    Join Date
    Feb 2009
    Posts
    41

    Default I tryed to upgrade the PHP I got the error below

    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-xml-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    File downloading PSA_9.5.4/update-rpm-CentOS-5-i386/php53-common-5.3.3-1.el5_6.1.i386.rpm: was skipped because of md5 checksum match.
    Starting installation of packages
    Installing the package psa-migration-manager-9.5.4-cos5.build95110630.11.i586, psa-backup-manager-9.5.4-cos5.build95110630.11.i586, psa-api-rpc-9.5.4-cos5.build95110630.11.noarch, psa-api-9.5.4-cos5.build95110630.11.noarch
    error: Failed dependencies:
    psa < 9.5.4 conflicts with psa-api-9.5.4-cos5.build95110630.11.noarch
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    [root@ns2 ~]#
    Social media
    www.live380.com



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •