Page 1 of 2 1 2 LastLast
Results 1 to 20 of 33

Thread: Upgrade to 10.4.4 = ERROR: Service_Agent_Exception

  1. #1

    Default Upgrade to 10.4.4 = ERROR: Service_Agent_Exception

    Our Parallels Plesk Panel software was just upgraded form v. 10.3.1 to the latest version available: v. 10.4.4 and now when visiting the admin login page I am getting the following error message...

    --------------------------------------------------------------------------------------------

    ERROR: Service_Agent_Exception

    Unable to read components configuration from the service node: sh: /usr/local/psa/admin/bin/packagemng: Permission denied

    0: Unix.php:340
    Service_Node_Components_Unix->_syncProperties(NULL null, boolean false)
    1: :
    call_user_func_array(array, array)
    2: Properties.php:142
    Service_Node_Properties->sync(NULL null, boolean false)
    3: Components.php:20
    Service_Node_Components->sync()
    4: Properties.php:31
    Service_Node_Properties->__construct(object of type Db_Table_Row_ServiceNode)
    5: ServiceNode.php:173
    Db_Table_Row_ServiceNode->components()
    6: ServiceNode.php:76
    Db_Table_Row_ServiceNode->refreshProperties()
    7: auth.php3:505

    --------------------------------------------------------------------------------------------

    I found that all of the websites hosted on the server can be accessed and I can FTP files to & from the server, but in no way can I gain access to the actual admin section because of this error. once the page tries to load the admin log-in page.

    Does anyone know how to fix this or have any guidance on what to do? I have reviewed this for hours now and cannot find a solution. I am unfortunately new to this and do not know what to do to fix this error.

    Any help is greatly appreciated!



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,775

    Default

    Any related errors in /var/log/sw-cp-server/error_log
    What is permissions for /usr/local/psa/admin/bin/packagemng ?

    It should be smth like:

    # ll /usr/local/psa/admin/bin/packagemng
    lrwxrwxrwx 1 psaadm psaadm 15 Nov 9 16:50 /usr/local/psa/admin/bin/packagemng -> ../sbin/wrapper

    # ll /usr/local/psa/admin/sbin/packagemng
    -rwxr-x--- 1 root root 79624 Nov 2 18:38 /usr/local/psa/admin/sbin/packagemng



  3. #3

    Default

    Exactly the same error here.

    Here are my errors from /var/log/sw-cp-server/error_log (this repeats when I try to access the admin pages):

    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Node/Components/Unix.php
    line: 340
    code: 0
    trace: #0 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #1 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #2 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #3 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #4 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #5 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #6 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #7 {main}


    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: PleskUtilException: '/opt/psa/admin/bin/packagemng' '--list' failed with code 126.

    stdout:

    stderr:
    sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
    line: 98
    code: 0
    trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
    #1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
    #2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('0a123091d128a1b...', Array, Object(Service_Agent_Log))
    #3 /opt/psa/admin/plib/Service/Node/Components/Unix.php(338): Service_Agent->commit()
    #4 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #5 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #6 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #7 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #8 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #9 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #10 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #11 {main}


    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Node/Components/Unix.php
    line: 340
    code: 0
    trace: #0 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #1 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #2 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #3 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #4 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #5 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #6 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #7 {main}
    The file rights are look correct, too:

    root@ipx:/opt/psa/admin/sbin# ll /usr/local/psa/admin/bin/packagemng
    lrwxrwxrwx 1 root root 15 21. Nov 17:04 /usr/local/psa/admin/bin/packagemng -> ../sbin/wrapper

    root@ipx:/opt/psa/admin/sbin# ll /usr/local/psa/admin/sbin/packagemng
    -rwxr-x--- 1 root root 122960 2. Nov 13:44 /usr/local/psa/admin/sbin/packagemng

    Running without error codes:
    /opt/psa/admin/bin/packagemng' '--list'

    What is happening here?



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,775

    Default

    Please fill template http://forum.parallels.com/showthread.php?t=106113 with all necessary details.



  5. #5

    Default

    Have the exactly same Error at my Server. Informations:

    ---------------------------------------------------------------
    Virtuozzo Plesk, 10.4.4, Linux 2.6.18-028stab092.1, x86_64 GNU/Linux, Ubuntu 10.04.3 LTS

    Upgrade from v. 10.3.1 to v. 10.4.4 via Plesk Updater

    On the Logon screen appears:
    ERROR: Service_Agent_Exception

    Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    0: Unix.php:340
    Service_Node_Components_Unix->_syncProperties(NULL null, boolean false)
    1: :
    call_user_func_array(array, array)
    2: Properties.php:142
    Service_Node_Properties->sync(NULL null, boolean false)
    3: Components.php:20
    Service_Node_Components->sync()
    4: Properties.php:31
    Service_Node_Properties->__construct(object of type Db_Table_Row_ServiceNode)
    5: ServiceNode.php:173
    Db_Table_Row_ServiceNode->components()
    6: ServiceNode.php:76
    Db_Table_Row_ServiceNode->refreshProperties()
    7: auth.php3:505
    And i can't login. httpd, ftpd, mysql, mail are running

    I've got an error at the Installation. Excerpt from the installation log:

    Unpacking replacement sshterm ...
    Errors were encountered while processing:
    /var/cache/apt/archives/psa-proftpd_1.3.3e-ubuntu10.04.build1013111101.14_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Execute command touch /var/lock/parallels-panel-upgrade-failure.flag ; rm -f /var/lock/parallels-panel-maintenance-mode.flag
    Error: An error occurred on attempt to install packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    Fixed this alreade with sudo dpkg --configure -a and the Virtuozzo Updater. But Error still appears.

    root@ip:/var/log# ll /usr/local/psa/admin/bin/packagemng
    lrwxrwxrwx 1 root root 15 2011-11-22 08:19 /usr/local/psa/admin/bin/packagemng -> ../sbin/wrapper*

    root@ip:/var/log# ll /usr/local/psa/admin/sbin/packagemng
    -rwxr-x--- 1 root root 126416 2011-11-02 13:39 /usr/local/psa/admin/sbin/packagemng*



    ---------------------------------------------------------------

    Hope anyone can help me. Greetings from Germany
    Last edited by Mrilabs; Nov 22, 2011 at 02:44 AM.



  6. #6

    Default

    From Plesk error_log:
    ...
    2011-11-22 08:36:27: (mod_fastcgi.c.2588) FastCGI-stderr: PleskUtilException: '/opt/psa/admin/bin/packagemng' '--list' failed with code 126.

    stdout:


    stderr:
    sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
    line: 98
    code: 0
    trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
    #1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
    #2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('b2a6f6ab6050e58...', Array, Object(Service_Agent_Log))
    #3 /opt/psa/admin/plib/Service/Node/Components/Unix.php(338): Service_Agent->commit()
    #4 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #5 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #6 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #7 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #8 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #9 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #10 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #11 {main}


    2011-11-22 08:36:27: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Node/Components/Unix.php
    line: 340
    code: 0
    trace: #0 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #1 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #2 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #3 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #4 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #5 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #6 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #7 {main}


    2011-11-22 08:36:28: (mod_fastcgi.c.2588) FastCGI-stderr: PleskUtilException: '/opt/psa/admin/bin/packagemng' '--list' failed with code 126.

    stdout:


    stderr:
    sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
    line: 98
    code: 0
    trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
    #1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
    #2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('743c81701b33c8a...', Array, Object(Service_Agent_Log))
    #3 /opt/psa/admin/plib/Service/Node/Components/Unix.php(338): Service_Agent->commit()
    #4 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #5 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #6 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #7 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #8 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #9 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #10 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #11 {main}


    2011-11-22 08:36:28: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied


    ...
    hrm Mail/Spamassin is not working at the Moment:
    Nov 22 10:29:49 ip postfix/smtpd[8128]: warning: connect to Milter service inet:localhost:12768: Connection refused
    Last edited by Mrilabs; Nov 22, 2011 at 03:32 AM.



  7. #7

    Default

    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk, 10.3.1/10.4.4, Debian Linux, amd64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    After updating from Plesk 10.3.1 to Plesk 10.4.4 i got the following error when I try to open the admin-interface:
    ERROR: Service_Agent_Exception

    Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    0: Unix.php:340
    Service_Node_Components_Unix->_syncProperties(NULL null, boolean false)
    1: :
    call_user_func_array(array, array)
    2: Properties.php:142
    Service_Node_Properties->sync(NULL null, boolean false)
    3: Components.php:20
    Service_Node_Components->sync()
    4: Properties.php:31
    Service_Node_Properties->__construct(object of type Db_Table_Row_ServiceNode)
    5: ServiceNode.php:173
    Db_Table_Row_ServiceNode->components()
    6: ServiceNode.php:76
    Db_Table_Row_ServiceNode->refreshProperties()
    7: auth.php3:505
    So there is no way to login to the plesk-panel, no matter if as admin or as customer.

    ACTUAL RESULT
    see problem description

    EXPECTED RESULT
    working plesk panel? ;-)

    ANY ADDITIONAL INFORMATION
    the /var/log/sw-cp-server/error_log shows the following information:
    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Node/Components/Unix.php
    line: 340
    code: 0
    trace: #0 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #1 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #2 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #3 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #4 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #5 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #6 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #7 {main}


    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: PleskUtilException: '/opt/psa/admin/bin/packagemng' '--list' failed with code 126.

    stdout:

    stderr:
    sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Agent/Transport/Local/Exec.php
    line: 98
    code: 0
    trace: #0 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(58): Service_Agent_Transport_Local_Exec->process(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Log), Object(Service_Agent_Transport_LocalTransaction))
    #1 /opt/psa/admin/plib/Service/Agent/Transport/Local.php(24): Service_Agent_Transport_Local->_command(0, Object(Service_Agent_Command_Exec), Object(Service_Agent_Transport_LocalTransaction), Object(Service_Agent_Log))
    #2 /opt/psa/admin/plib/Service/Agent.php(133): Service_Agent_Transport_Local->process('0a123091d128a1b...', Array, Object(Service_Agent_Log))
    #3 /opt/psa/admin/plib/Service/Node/Components/Unix.php(338): Service_Agent->commit()
    #4 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #5 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #6 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #7 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #8 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #9 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #10 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #11 {main}


    2011-11-21 18:52:14: (mod_fastcgi.c.2588) FastCGI-stderr: Service_Agent_Exception: Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    file: /opt/psa/admin/plib/Service/Node/Components/Unix.php
    line: 340
    code: 0
    trace: #0 [internal function]: Service_Node_Components_Unix->_syncProperties(NULL, false)
    #1 /opt/psa/admin/plib/Service/Node/Properties.php(142): call_user_func_array(Array, Array)
    #2 /opt/psa/admin/plib/Service/Node/Components.php(20): Service_Node_Properties->sync(NULL, false)
    #3 /opt/psa/admin/plib/Service/Node/Properties.php(31): Service_Node_Components->sync()
    #4 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(173): Service_Node_Properties->__construct(Object(Db_Table_Row_ServiceNode))
    #5 /opt/psa/admin/plib/Db/Table/Row/ServiceNode.php(76): Db_Table_Row_ServiceNode->components()
    #6 /opt/psa/admin/auto_prepend/auth.php3(505): Db_Table_Row_ServiceNode->refreshProperties()
    #7 {main}
    The file rights are look correct:

    root@ipx:/opt/psa/admin/sbin# ll /usr/local/psa/admin/bin/packagemng
    lrwxrwxrwx 1 root root 15 21. Nov 17:04 /usr/local/psa/admin/bin/packagemng -> ../sbin/wrapper

    root@ipx:/opt/psa/admin/sbin# ll /usr/local/psa/admin/sbin/packagemng
    -rwxr-x--- 1 root root 122960 2. Nov 13:44 /usr/local/psa/admin/sbin/packagemng

    Running without error codes:
    /opt/psa/admin/bin/packagemng' '--list'
    --------------------------------------------------------------

    At the moment we are in a rollback-state and moved the whole server one day back. Any help would be really appreciated!



  8. #8
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,775

    Default

    Thank you for reports. I have forwarded it to developers. Let's wait their answer.



  9. #9

    Default

    I confirm the same problem while upgrading the 10.3.1 to 10.4.4 on Debian 2.6.26-2-amd64 #1 x86_64 GNU/Linux

    stat /usr/local/psa/admin/bin/packagemng
    File: `/usr/local/psa/admin/bin/packagemng' -> `../sbin/wrapper'
    Size: 15 Blocks: 0 IO Block: 4096 symbolic link
    Device: 902h/2306d Inode: 88713763 Links: 1
    Access: (0777/lrwxrwxrwx) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: 2011-11-25 22:41:26.000000000 +0100
    Modify: 2011-11-25 22:15:39.000000000 +0100
    Change: 2011-11-25 22:15:39.000000000 +0100
    h04:~# stat /usr/local/psa/admin//sbin/wrapper
    File: `/usr/local/psa/admin//sbin/wrapper'
    Size: 20344 Blocks: 40 IO Block: 4096 regular file
    Device: 902h/2306d Inode: 88711401 Links: 1
    Access: (4510/-r-s--x---) Uid: ( 0/ root) Gid: ( 0/ root)
    Access: 2011-11-25 22:33:38.000000000 +0100
    Modify: 2011-11-02 13:43:44.000000000 +0100
    Change: 2011-11-25 22:15:36.000000000 +0100
    I believe the problem is with wrong group owner in many files.
    I checked the same file in a running 10.3.1 CentOs and the group of /usr/local/psa/admin//sbin/wrapper was psaadm.

    Changing the group on the /usr/local/psa/admin//sbin/wrapper solves the error permission on this file, but now there is someother file with wrong permission access:
    Unable to read components configuration from the service node: failed to open semaphore file /opt/psa/var/utilities.sem: Permission denied
    System error 13: Permission denied

    0: Unix.php:340
    Service_Node_Components_Unix->_syncProperties(NULL null, boolean false)
    1: :
    call_user_func_array(array, array)
    2: Properties.php:142
    Service_Node_Properties->sync(NULL null, boolean false)
    3: Components.php:20
    Service_Node_Components->sync()
    4: Properties.php:31
    Service_Node_Properties->__construct(object of type Db_Table_Row_ServiceNode)
    5: ServiceNode.php:173
    Db_Table_Row_ServiceNode->components()
    6: ServiceNode.php:76
    Db_Table_Row_ServiceNode->refreshProperties()
    7: auth.php3:505
    ... and I am stuck here. Not sure what is calling this file and what owner group does it have.
    Last edited by mandi22; Nov 25, 2011 at 03:54 PM.



  10. #10

    Default

    I hope the developers of Plesk address this issue ASAP as it looks it breaks upgrading from 10.3.1 to 10.4.1



  11. #11

    Default

    I was able to get access on the server by granting mods:
    chmod 4110 /opt/psa/admin/sbin/wrapper

    I am getting another problem which cannot be solved from Bootstrapp repair, but I believe this is different topic now.
    Internal error: Specified column "version" is not in the row
    Message Specified column "version" is not in the row
    File Abstract.php
    Line 179
    Type Zend_Db_Table_Row_Exception



  12. #12

    Default

    Unfortunately our server upgraded himself by the Plesk Autoinstaller on Saturday. And now we have the same problems as before. But there is a new error-message and the plesk panel is only white/blank, there is no text and no error when I try to open the panel in a browser. Restarting sw-cp-server has no effect.

    error-message in /var/log/sw-cp-server/error.log for each try to open the panel:
    (mod_fastcgi.c.2588) FastCGI-stderr: PHP Fatal error: Class 'CommonPanel_Config_NumericKeys' not found in /opt/psa/admin/plib/CommonPanel/Config/Defaults.php on line 517
    As these php-files are encrypted, I cannot debug this on my own.

    ASAP help about this whole updating-problem would be really nice...


    [edit]
    I also think, that a widespread system like plesk which runs on that many systems should have a rollback-system when an update fails! It is absolutely inacceptable, that an update leaves the system in broken state!
    Last edited by JustForSupport; Nov 28, 2011 at 05:50 AM.



  13. #13
    Bit Poster
    Join Date
    Dec 2011
    Posts
    5

    Default

    Hi,
    any news considering this problem? i just did the update and now i have exactly the same problem and log file.

    please i need urgent help.

    thanks
    ray.



  14. #14
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,775

    Default

    Problem still under developer's investigation. I will inform you with results as soon as I receive them.



  15. #15
    Bit Poster
    Join Date
    Dec 2011
    Posts
    4

    Default

    Here is what solved the issue for me:

    chown psaadm.psaadm /opt/psa/admin/sbin/packagemng



  16. #16
    Bit Poster
    Join Date
    Dec 2011
    Posts
    5

    Default

    thanks for trying to help. just tried what xou suggested, this did not help.

    still getting the followng when i try to call plesk admin

    ERROR: Service_Agent_Exception

    Up Level
    Unable to read components configuration from the service node: sh: /opt/psa/admin/bin/packagemng: Permission denied

    0: Unix.php:340
    Service_Node_Components_Unix->_syncProperties(NULL null, boolean false)
    1: :
    call_user_func_array(array, array)
    2: Properties.php:142
    Service_Node_Properties->sync(NULL null, boolean false)
    3: Components.php:20
    Service_Node_Components->sync()
    4: Properties.php:31
    Service_Node_Properties->__construct(object of type Db_Table_Row_ServiceNode)
    5: ServiceNode.php:173
    Db_Table_Row_ServiceNode->components()
    6: ServiceNode.php:76
    Db_Table_Row_ServiceNode->refreshProperties()
    7: auth.php3:505



  17. #17
    Bit Poster
    Join Date
    Dec 2011
    Posts
    4

    Default

    and now do the same for /opt/psa/admin/bin/packagemng (the one in my previous post was in bin and this one in sbin)



  18. #18
    Bit Poster
    Join Date
    Dec 2011
    Posts
    5

    Default

    ok i changed that and after that it told me same error but for /opt/psa/var/utilities.sem, which i changed too.
    now i get no error anymore and i can get to the logon screen, but when i try to login it tells me
    Error: Unable to check password:

    any further files i need to change permission/owner to?

    well, i am really very thankfull for your help, a step forward but to bad i yet can't access the tool



  19. #19
    Bit Poster
    Join Date
    Dec 2011
    Posts
    4

    Default

    I would check if the file /etc/psa/.psa.shadow exists and not empty. Since version 10 the file contains encrypted password however, if I'm not mistaken you still can put a plain text password into it (should be same as the one for mysql 'admin' user). Next time you change the password in CP it should put encrypted version into the file.

    can you execute '/usr/local/psa/bin/admin --show-password' ? Does it show you your Plesk password? If not then put the password into the file mentioned above and try again. If it is still does not work - check that you can login into mysql shell using 'mysql -uadmin -p`cat /etc/psa/.psa.shadow`'. If you can't then admin mysql user either does not exist (need to create it then) or the password does not match (login as root then and change admin's password to the one stored in .psa.shadow file).
    Hope this helps.



  20. #20
    Bit Poster
    Join Date
    Dec 2011
    Posts
    5

    Default

    file /etc/psa/.psa.shadow exists and ist not empty, it contains a plain password!
    should this file contain the password for plesk cp? if yes, then this is not the password.

    ok, next step: i can execute /usr/local/psa/bin/admin --show-password and it shows me the password i saw in the .psa.shadow file.

    next step:
    yes i could login using 'mysql -uadmin -p`cat /etc/psa/.psa.shadow`'

    well all you asked for works for me, but i still can't logon into plesk cp

    i really apreciate you investing your time to help.



Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •