View Poll Results: What was the best 8-bit computer?

Voters
5. You may not vote on this poll
  • Acorn Electron

    0 0%
  • Amstrad CPC

    1 20.00%
  • Apple ][

    0 0%
  • Atari 8 Bit (800, 65XE etc)

    1 20.00%
  • BBC Micro

    0 0%
  • Commodore 64

    2 40.00%
  • Dragon 32/64

    0 0%
  • Sinclair Spectrum

    1 20.00%
  • Other

    0 0%
Results 1 to 9 of 9

Thread: Commodore OS Vision

  1. #1

    Default Commodore OS Vision

    Has anyone tried or had any luck running the latest Commodore OS Vision under Parallels for Mac?

    The Beta 6 is currently available for download from their website.

    http://www.commodoreusa.net/CUSA_OS_Vision.aspx

    The OS is designed to run on the new Commodore 64 and Amiga hardware, but its just a custom Linux distribution, so maybe it will work.

    I'm downloading the Beta 6 now.



  2. #2
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    13

    Default I'm about to try

    I was wondering is anyone has tried. Have you done it yet? If so, what settings did you use? I'm about to give it a try.



  3. #3

    Default

    Sure. I set it up as an "Other Linux" operating system, and dedicated a couple CPUs and 2GB RAM.

    I cannot remember details of the setup, as I did that a while ago, but I do believe it went pretty smooth. I spent more time trying to figure out how to change the icon that appears in the "Parallels Virtual Machine" panel than I did installing the OS.

    As it turns out, there doesn't appear to be a way to replace the Tux (linux penguin) logo with the Commodore logo. I don't think Parallels let's you override those icons, unfortunately. If anyone knows how to do that, please reply.



  4. #4
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    13

    Default

    Thanks!

    I tried it, ran as a straight forward "Other Linux" and it install just fine (I created a 2nd optical drive under the "Hardware" configuration to make the install go faster with the 2 ISOs).

    It was working fine, but when I resume it from being suspended it said it couldn't resume, that it would restart. That was fine the first 1-2 times or so, but one time it restarted, and now it's stuck in single use mode / command line. I'm not sure how to get back into the GUI mode. It may have something to do with updating it to bata 8 or possible when I was trying to activate they're extra interface effects.

    Also, I'll keep looking into changing that icon. I made a cool 3D C logo similar to the default desktop. I'll share if we can get the figure it out.

    I'd like to request Parallels add official support for Commodore OS Vision, it shouldn't take much effort on their part.



  5. #5
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    13

    Default Commodore OS Vision Logo

    Here's the logo. I attached the icns file at a zip, and a jpeg for you to view it. I think the icns would be used to modify the VM icon, if not you can easily save it out as something else using Preview.
    Attached Images Attached Images
    Attached Files Attached Files



  6. #6
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    13

    Default

    I just did all the default settings for a virtual new machine, but in my case I chose 4 cores, and 8GB RAM (I have a Quad i7 that show 8 core because of HyperThreading, and 16GB RAM). I choose "Other Linux" as my OS type.

    Networking worked right away, and I was able to update to Commodore OS Vision (let's call it COSV) Bata 8 with no problems. I haven't tried installing Parallel Tools, my guess is it would screw up the install. I'll get around to taking a snapshot and test Parallel Tools when I get the chance.


    Two things I've noticed so far:

    1: DON'T UPDATE ANYTHING GRAPHIC RELATED, including installing more GUI effects, or COSV's drivers. It caused COSV to boot in Single User (Non-Graphical) mode the next time I restarted. I had to reinstall.

    2: Parallels wont (for me at least) be able to resume after suspending. I can suspend the VM, but when I resume it gives me an error. So I just shut down the VM when I'm done with it.


    Please share your experience!



  7. #7

    Default Visual Effects

    Has anyone had any luck enabling all the bells and whistles when it comes to the visual effects? Whenever I try to fire them up it comes back saying "desktop effects could not be activated." I've got the early 2011 Macbook pro. Haven't dared to try installing Parallels tools (not that I'd know how to anyways; linux noob).



  8. #8
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    13

    Default

    No luck here!

    Anytime I try to do anything graphic related with Commodore OS Vision it screws up the install and I have to start all over again.

    Parallels has been crashing and Kernel Panicking my system since I installed the ATI 5770, so I haven't tried in awhile. I may clone or take a screen shot, then try Parallels Tools sometime this week if I get the chance. I'll report the results.

    We should petition Parallels to add Commodore OS Vision to their list of supported OSes! :)



  9. #9

    Default

    I agree. It should be added to supported Os's



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •