Results 1 to 10 of 10

Thread: Plesk Control Panel Stop Working after Removing psa-atmail from CentOS

  1. #1

    Question Plesk Control Panel Stop Working after Removing psa-atmail from CentOS

    Hi,

    I'm currently using the Plesk 10 and I have problem with atmail so I tried to remove and install it again! So I removed the atmail using the following code:

    yum remove psa-atmail

    Then I Found my self in a bigger problem! my Plesk Control Panel Stop working, it doesn't even load the login page!!

    Also when I'm trying to install it again:

    yum install psa-atmail

    I recieve the following error:

    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package psa-atmail.noarch 1:1.04-3.el5.art set to be updated
    --> Processing Dependency: psa >= 9.0 for package: psa-atmail
    --> Finished Dependency Resolution
    1:psa-atmail-1.04-3.el5.art.noarch from atomic has depsolving problems
    --> Missing Dependency: psa >= 9.0 is needed by package 1:psa-atmail-1.04-3.el5.art.noarch (atomic)
    Error: Missing Dependency: psa >= 9.0 is needed by package 1:psa-atmail-1.04-3.el5.art.noarch (atomic)

    Any idea?



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    You have psa-atmail package from third-party Atomic repository.
    Native Parallels psa-atmail package can be removed with usual:

    # rpm -q psa-atmail
    psa-atmail-1.04-cos5.build1013111101.14
    # rpm -e psa-atmail



  3. #3

    Default

    Tnx for your reply,

    whey I try this:
    # rpm -q psa-atmail
    package psa-atmail is not installed
    I'm just planning to install it again! how do I do that?

    I tried:
    yum install psa-atmail
    but I've got the above error message!!



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    Use Plesk autoinstaller instead of third-party yum!



  5. #5

    Default

    How do I do that? after removing the atmail, Plesk stoped working and now every time I try my Plesk url, my browser doesn't load the page!



  6. #6
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,778

    Default

    Just run /usr/local/psa/admin/sbin/autoinstaller and follow menu.



  7. #7

    Exclamation

    Tnx again!

    I try but it gives me this error:
    Starting installation of packages
    Installing the package psa-atmail-1:1.03-0.285591.noarch
    libgcc_s.so.1 must be installed for pthread_cancel to work
    libgcc_s.so.1 must be installed for pthread_cancel to work
    Trying to start service mysqld... done
    Trying to establish test connection... connected
    done
    Trying to generate random password for atmail Web base mail client... /usr/sbin/httpd: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: Error 23
    get_apache_path: '/usr/sbin/httpd -V' failed
    get_apache_path: '/usr/sbin/httpd -V' failed

    WARNING!
    During the register found some problems(see log file: /tmp/psa-atmail_1.03_0.285591_installing.111219.10.13.log)

    Continue...

    Installing the package ppsmbe-10.2.0-cos5.build102100709.06.x86_64

    ERROR while trying to SMB database not created
    Check the error reason(see log file: /tmp/ppsmbe_10.2.0_cos5.build102100709.06_installing.11 1219.10.13.log), fix and try again

    Aborting...

    error: %post(ppsmbe-10.2.0-cos5.build102100709.06.x86_64) scriptlet failed, exit status 1
    ERROR: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    I check the log file for ppsmbe_10.2.0_cos5.build102100709.06_installing.11 1219.10.13.log:
    START ppsmbe-10.2.0-cos5.build102100709.06 installing AT Mon Dec 19 10:13:40 GMT 2011
    /usr/local/psa/admin/bin/packagemng: error while loading shared libraries: libsepol.so.1: cannot open shared object file: Error 23
    STOP ppsmbe-10.2.0-cos5.build102100709.06 installing AT Mon Dec 19 10:13:40 GMT 2011
    START ppsmbe-10.2.0-cos5.build102100709.06 installing AT Mon Dec 19 10:13:42 GMT 2011
    /usr/bin/sw-engine: error while loading shared libraries: libxml2.so.2: cannot open shared object file: Error 23

    ERROR while trying to SMB database not created

    Aborting...

    packagemng: Unable to getpwnam for user psaadm
    System error 2: No such file or directory
    packagemng: Unable to getpwnam for user psaadm
    System error 2: No such file or directory
    packagemng: Unable to getpwnam for user psaadm
    System error 2: No such file or directory
    packagemng: Unable to getpwnam for user psaadm
    System error 2: No such file or directory
    STOP ppsmbe-10.2.0-cos5.build102100709.06 installing AT Mon Dec 19 10:13:42 GMT 2011
    Here is log file for psa-atmail_1.03_0.285591_installing.111219.10.13.log:
    START psa-atmail-1.03-0.285591 installing AT Mon Dec 19 10:13:31 GMT 2011
    Trying to start service mysqld... mysqld (pid 1765) is running...
    done
    Trying to establish test connection... connected
    done
    Trying to generate random password for atmail Web base mail client... /usr/bin/mysql: error while loading shared libraries: libkrb5.so.3: cannot open shared object file: Error 23
    Mysql exited with non-zero status 32512 at -e line 27.
    ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'innodb status' at line 1
    /usr/bin/mysql: error while loading shared libraries: libk5crypto.so.3: cannot open shared object file: Error 23
    Mysql exited with non-zero status 32512 at -e line 27.
    ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'innodb status' at line 1

    WARNING!
    During the register found some problems
    Continue...

    STOP psa-atmail-1.03-0.285591 installing AT Mon Dec 19 10:13:32 GMT 2011
    Last edited by MortezaM; Dec 19, 2011 at 04:23 AM.



  8. #8

    Default problem atmail plesk sbp centos 5

    I can add mails from the panel no problem but the email adresses don't works !
    server CentOS 5 avec Parallels SB Panel 10 (64 bits)
    PHP Version 5.3.8
    Postfix intalled



    /usr/local/psa/admin/sbin/autoinstaller I get:

    1. [ ] Parallels Plesk Panel

    2.[*] Parallels Small Business Panel
    3. (*) Parallels Small Business Panel 10.2.0 (currently installed)

    4. [ ] Sitebuilder 4.5 and earlier versions (for Plesk 9 and earlier)

    5. [ ] SSO

    N) Go to the next page; P) Go to the previous page; Q) Cancel installing
    To select a version, type the respective number;
    Select an action [N]: N
    File downloading PPSMBE_10.2.0/ppsmbe-10.2.0-cos5-x86_64.inf3: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PPSMBE_10.2.0/ppsmbe-patches-10.2.0-cos5-x86_64.inf3: 16%..42%..63%..84%..100% was finished.
    File downloading SETEMPLATES_1.0.0/setemplates-1.0.0-rhall-all.inf3: 16%..25%..34%..43%..52%..61%..70%..88%..97%..100% was finished.
    Parallels Containers were detected. Trying to connect to VZAgent...Warning! Failed to connect to VZAgent: ioctl: Transport endpoint is not connected
    Detecting installed product components.

    You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.



    # yum install psa-atmail
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * atomic: www7.atomicorp.com
    addons | 1.9 kB 00:00
    atomic | 1.9 kB 00:00
    base | 1.1 kB 00:00
    extras | 2.1 kB 00:00
    mod-pagespeed | 951 B 00:00
    updates | 1.9 kB 00:00
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package psa-atmail.noarch 1:1.04-3.el5.art set to be updated
    --> Processing Dependency: psa >= 9.0 for package: psa-atmail
    --> Finished Dependency Resolution
    1sa-atmail-1.04-3.el5.art.noarch from atomic has depsolving problems
    --> Missing Dependency: psa >= 9.0 is needed by package 1sa-atmail-1.04-3.el5.art.noarch (atomic)
    Error: Missing Dependency: psa >= 9.0 is needed by package 1sa-atmail-1.04-3.el5.art.noarch (atomic)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest


    Any help pls?



  9. #9

    Default Effects of running the Auto-Install

    Hi,

    what are the effects of running the auto install? Will it affect my domains and websites hosted on my Centos server do you know?

    Or will the install just identify any missing / corrupted files and replace them?

    My Control Panel broke and I want to try and fix it without affecting any of my live sites hosted on the Centos Server.

    Any help is greatly appreciated!

    Thanks

    Mario



  10. #10

    Default

    No, autoinstall no affect for your websites, auto install only cleanup the panel and update it.

    Regards



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •