Results 1 to 13 of 13

Thread: @ and " keys are swapped in UK keyboard

  1. #1

    Default @ and " keys are swapped in UK keyboard

    Parrallels

    Can you pleas tell me why the @ and " keys are swapped on the Windows XP (set to use UK keyboard) while using MacBook Pro with a UK keyboard?

    I searched the forum and the only total option I saw was to create a new layout using the MS utility. This is not user's job! You know what is broken hence you should fix what is obviously a bug. No other option is acceptable.

    I am expecting an official response from Parallels support as this is the support forum. If I am posting this at the wrong place please ell me where to post it instead or move it to the relevant secton.

    Thank you

    Riza



  2. #2
    Parallels Team John@Parallels's Avatar
    Join Date
    Apr 2008
    Posts
    6,793

    Default

    Parallels doesn't touch Windows at initial stage, and I am not sure I fully can understand what do you mean
    "I saw was to create a new layout using the MS utility."
    Official response from Parallels Support you will get if you create ticket in support queue
    This is forum, and only good will is round about



  3. #3

    Default

    Parrallels tools are written by you and applied by you at the initial installation stage automatically so your reply "Parallels doesn't touch Windows at initial stage" is not valid! (I imported a VMWare Fusion VM.) You install loads of drivers to make Windows work in your VM. There is nothing to stop you to make sure that the environment your VM is running fits Windows.

    Meanwhile you copied part of a sentence from my post. The whole sentence I believe explains what I mean clearly. It reads: "I searched the forum and the only total option I saw was to create a new layout using the MS utility." MS has a utility that can create keyboard drivers with user generated key layouts. This was mentioned on multiple posts on this forum as the only option available to sort the UK keyboard problem we are experiencing.

    I did ask if this is not the valid place to post this message please let me know where to post instead. Please tell me how to obtain the ticket you mention in your message.
    Last edited by rizanur; Aug 12, 2008 at 07:25 AM. Reason: Typo



  4. #4
    Parallels Team John@Parallels's Avatar
    Join Date
    Apr 2008
    Posts
    6,793

    Default

    http://www.parallels.com/en/support/
    Could you please also mention link to post, meanwhile here are some tips for using specific symbols

    RESOLUTION

    The keystrokes required for typing different special symbols are listed in the table below:

    1) If you have French(France) layout:

    @- "Alt Gr + 0"
    # - "Alt Gr + 3"

    2) If you have German(Germany) layout:
    @- "Alt Gr + q"

    {- "Alt Gr + 7"
    }- "Alt Gr + 0"
    [- "Alt Gr + 8"
    ] - "Alt Gr + 9"

    3) if you have Swedish (Sweden) layout:

    @- "Alt Gr + 2"
    4) If you have Norwegian(Bokmal) layout:

    @- "Alt Gr + 2"
    $- "Alt Gr + 4"
    {- "Alt Gr + 7"
    }- "Alt Gr + 0"
    [- "Alt Gr + 8"
    ] - "Alt Gr + 9"

    5). If you have Dutch (Belgian) layout:

    @- "Alt Gr + 2"

    Press "CTRL + ALT " instead "Alt Gr" on MacBook and MacBook Pro

    Also you can do the following:


    1. In the Mac top bar, click "Parallels Desktop->Preferences", choose "Keyboard" tab. Check "Translate from AltGr to NumEnter" option.

    2. Then try to use the “Enter” key to the left from cursors keys instead of AltGr

    Press FN+ENTER to reproduce INSERT (only for Mac Books and/or Mac Book Pros)


    How to find out the keyboard layout in Mac OS X and Windows:


    * Mac OS X: open Mac -> System Preferences -> International -> Input Menu and find out what layouts you are using.

    * Windows XP: open Control Panel->Regional and Language Options->Languages->Details->Installed Services, where you can find the layout.



  5. #5

    Default

    I have posted my initial message to the support querry form.

    Meanwhile, I read your response to my question but I can't see how that is relevant to my question about the "swapped" keys. As the word swap means I can enter the characters. I don't need a way to enter them. I already have a way. It's just that it is not the right way.

    You mention the "Alt Gr" key. Does that key exists on a MacBook Pro keyboard that I said in my message I am using? I can't see it!



  6. #6
    Parallels Team John@Parallels's Avatar
    Join Date
    Apr 2008
    Posts
    6,793

    Default

    Please see PDFM Parallels Desktop for Mac user guide from http://www.parallels.com/en/download...User_Guide.pdf on page 227, (right Alt)



  7. #7

    Default

    Many thanks for showing me where the Alt Gr key mapping is. As there is no numeric keypad on a MacBook Pro I didn't relaised that the <Enter> key is in fact what you call the Numeric Enter key.



  8. #8
    Kilo Poster
    Join Date
    Mar 2008
    Location
    Doncaster, UK
    Posts
    70

    Default

    To be honest, the " and @ swap around has been apparent from Day 1 on my MBP. I just mentally swap over when in Windows.

    For windows functionality at a great price on a Mac - Get Over It!

    Does it really matter that much?



  9. #9

    Default

    It is cheap hence the quality is low: Is that what you are telling me?

    Parallels do you accept that because your price is low your quality is also low to match it? That, even though this issue was known from day 1 that you didn't bother to correct it because you are not earning enough money to maintain a quality QC team?



  10. #10
    Kilo Poster
    Join Date
    Mar 2008
    Location
    Doncaster, UK
    Posts
    70

    Default

    No, that is NOT what I am telling you. I wrote exactly what I meant.

    To have the functionality of Windows on my Mac, I am willing to make small compromises. My highlighting the price (perhaps I should have been more explicit here) was more a 'swipe' at the price of Microsoft software. Can you imagine what MS would have charged if the situation were reversed.

    As I said earlier 'does it really matter that much', I mean does it really ruin your whole day to have to substitute those two keys? If so, make it a ticket and 'complain' officially. If you re-read your original post, it comes across as quite aggressive, we tend not to do that on this site.

    Your opinion is of course as valid as anybody else's. Your money is as good as anyone else that bought the software and indeed you have a right to expect it to be as good as it can.

    However, in my VM, I have been able to run aviation logbook software, QuarkXPress, Garmin GPS, Adobe CS, etc etc and it has been brilliant. Can you imagine what Mac functionality on Windows would cost? Let alone the fact that Windows applications don't even run faultlessly on Windows platforms!

    Give Parallels a break, you always have the choice to go back to a PC if it's that bad . . .



  11. #11
    Kilo Poster
    Join Date
    Mar 2008
    Location
    Doncaster, UK
    Posts
    70

    Default

    In fact, having re-read my post, I shall desist from further comment on this topic as I'm bordering on being aggressive myself.

    I just happen to think that Parallels is incredible value, but there again, my opinion is just that and no more important than yours.



  12. #12

    Default

    First, I did create a ticket as well pointing them to this thread. What I got was terrible. Parallels position on this issue is:

    "This is the feature of your Mac, because it was made, obviously, in USA, so you can just simply set English (United States) and '@' symbol will be at '2' key and '"' will be at ''' key.
    If you still prefer to use English (United Kingdom) layout, it will be vice versa. i.e. '@' is with ''' and '"' with '2'."

    I.e. according to them I either get my @ and " keys in the correct place or loose my £ (GBP) key. Ridiculous!!!

    You are speculating that such corrections would cost through the roof on Microsoft world. You are wrong. MS not only never makes such errors -- they are a truly global company where respecting local users are paramount instead of offering me how to use my computer using Al Gr combinations! -- they even supplies free tools to customise your environment. I already used such a tool to create a new keyboard driver and corrected the problem I am experiencing. I can send it to you as well if you like.

    I do understand where you are coming from that we have at least a solution with Parralles but why shouldn't we expect that solution to complete and elegant? It's the customers who forces large corporations to deliver and stay at attention. If we, customers are complecant the quality of the software will suffer. Look what happened to Vista. Windows users didn't bothered to update, which is making MS to realise its mistakes and started to act to correct them.



  13. #13
    Bit Poster
    Join Date
    Mar 2013
    Posts
    1

    Default Here's how to do it without using MS Keyboard Layout utility

    Hi Riza,

    Just like you, this annoyed me, and I wasn't prepared to remap my brain to suit! Brianwmay is obviously more accepting than us! :)

    And I'm surprised that Parallel's support haven't responded at all, when these is such an easy way to resolve this. Anyhow, the solution...

    1) Go into Windows in "non coherence mode" (in *my* case, that's Windows 7).
    2) Go to Control Panel, and then choose "Change keyboards or other input methods" under "Clock, Language, and Region"
    3) Go to the "Keyboards and Languages" tab, and click on the "Change keyboards" button
    4) On this screen, if you don't have "United Kingdom (Apple) - Parallels" a a keyboard, you need to click on the "Add" button - if you have, then you need to go to step 5 to select it.
    5) If the keyboard is in the "installed services" section, then you just need to select it in the dropdown above, and click OK
    6) Now, in the bottom right part of the Windows taskbar, you should see an extra icon that looks like a keyboard. This is where you can select between "United Kingdom" and "United Kingdom (Apple) - Parallels" (the latter one is the one we need!

    Now, you should have the @, " and £ where they should be! :)

    I guess the reason it's like this for us is because we've got a US spec machine, but are using a "UK keyboard" as a setting, although why the @ and " should have swapped place I don't know!

    Anyway, hope this helps anyone else in the same boat...



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •