Funny question, I know, but the rather few postings I've found that report a good install have been pretty old. And my experience with Parallels 7 has not been good. Here's the problem:

Parallels Desktop 7 running under Snow Leopard.

Put in the installation DVD and run Parallels, and tell it to make a VM for installing eCS v1.2, all with the default options. Start this, and it reads right through the process of getting and starting the installer. That all works, or almost works.

At this point you'd normally go ahead with Easy Install, which requires your license data. But the problem I've got can be shown even without the license. Instead of Easy Install, select the Maintenance system, and hit Next. Now, in the Disk menu, you can configure the disk with LVM, either text or graphicical version. This will be needed later to provide a formatted HD partition to install in.

But you can't! Or I can't. The LVM simply doesn't see the virtual hard disk you set up at the start. It can see the RAM disk S: just fine, but nothing else. Likewise with the graphical version (like LVMGUI). Also, if you do go ahead with the license and Easy Install, you've got the same problem when it asks for a partition to install in.

I had a terribly clever idea that the problem might be with some kind of Master Boot Record formatting, since Mac normally formats real disks with an incompatible setup. Maybe some such stuff is in the .hdd file as it's created, and the LVM code just can't figure it out?

I managed to attach this .hdd file to a VM that runs MS-DOS 6.22. If this were a physical disk, DOS FDISK and FORMAT would make it into a form that LVM could easily handle. Attaching this to the VM that I'm trying to install in: no luck, LVM still can't see it.

So, is Parallels 7 just broken wrt eCS? In view of how small the eCS 1.2 market must be, this wouldn't be shocking. Or maybe it has been broken since level 5, for that matter.

I've started an inquiry using the free 30-day chat support, but the whole question is probably so obscure that it would help to get any feedback from users who have tried this -- if any.

Thanks for any leads, and sorry about the length of this.