Results 1 to 9 of 9

Thread: Upgrade to PHP 5.3 in Plesk 10.4.4#19

  1. #1

    Default Upgrade to PHP 5.3 in Plesk 10.4.4#19

    I am trying since ever to upgrade to Php 5.3 in Plesk 10.x branch. I saw once the option to upgrade PHP 5.3 and I did not upgrade. Since then I keep looking for that option and it does not show up in the autoinstaller.

    Is there any more generic way of upgrade Php 5.3 with psa packages?
    (Debian )
    Last edited by mandi22; Mar 1, 2012 at 03:08 PM.



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,383



  3. #3

    Default

    Thank you for the reply Igor,

    I have tried it and I still cannot install:

    Get:16 http://autoinstall.plesk.com all/all Packages [686B]
    Get:17 http://autoinstall.plesk.com all/all Packages [605B]
    Fetched 573kB in 2s (236kB/s)
    Reading package lists...
    Detecting installed product components.
    Warning: following component(s) not found: 'php53'
    You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.
    Synchronizing the Debian APT package index files...



  4. #4

    Default

    Downgrading doesn't work either... I had plesk 5.3 installed, it failed somewhere halfway leaving my server in limbo.

    This is so depressing... it's like Plesk somehow sucks the will to live from me... ah... and I now have to wait 66 seconds before I am allowed to post again, don't you just love this service! I really feel like a valued customer!



  5. #5
    Mega Poster
    Join Date
    Nov 2009
    Posts
    203

    Default

    Dear Igor,

    If I run:

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

    In a server with plesk 10.4.4 and php 5.2.6, when I run the command php version will be updated to php 5.3. Is that correct?

    Also I have to more servers one with plesk 9.3 and another with plesk 9.5.4. Can I run a similar command to update php version? (Both have 5.2.6)

    Thanks a lot



  6. #6
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,383

    Default

    Quote Originally Posted by SalvadorS View Post
    Dear Igor,

    If I run:

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

    In a server with plesk 10.4.4 and php 5.2.6, when I run the command php version will be updated to php 5.3. Is that correct?

    Also I have to more servers one with plesk 9.3 and another with plesk 9.5.4. Can I run a similar command to update php version? (Both have 5.2.6)

    Thanks a lot
    Yes, PHP will be upgraded but according to http://kb.parallels.com/en/111711 it is applies only to Plesk 10.x versions.



  7. #7

    Default Problem with installation of php5.3 on 10.4.4

    Hi together,

    I'm not able to intsall php5.3 on my server. All tipps don't work.

    cheers
    franz



  8. #8
    Bit Poster
    Join Date
    Jun 2012
    Posts
    6

    Default

    Quote Originally Posted by IgorG View Post
    2 Install PHP 5.3 from the Parallels Plesk Panel web interface:
    Tools&Utilities > Panel > Updates > Add Components > select PHP5.3 support and continue.

    I'm little bit confused. I don't find "Tools&Utilities" anywhere in Parallels Power Panel nor in Plesk Panel 10.4.4. ??? Can you give me any more detailed instructions?



  9. #9
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,383

    Default

    Tools & Settings in Plesk interface.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •