Results 1 to 2 of 2

Thread: atMail won't execute .php at webmail.<domain>

  1. #1

    Exclamation [Bug & SOLVED] atMail won't execute .php at webmail.<domain>

    Hello Forum,
    after fiddling around I managed to switch on a webmail service that it appears to really be turned on (before that accessing webmail.<domain>.com always lead back tot homepage of that domain).

    Now the problem is: The server doesn't execute the PHP, the .php file wants to be downloaded. I am running plesk 10.4.4 on ubuntu 10.40 lts with Apache2 and FastCGI. All other instances and subdomains where I use .php work fine.

    Another issue is, that the mailman app seems to work, but the webinterface is never found. Accessing lists.<domain>.com/admin/mailman leads to a not found error. Is it my DNS or something wrong with the Plesk setup?

    Cheers
    Last edited by Peter Hase; Apr 4, 2012 at 02:35 PM.



  2. #2

    Default

    I solved it and would consider it a bug. All that was missing was the ifmodule directive for fastcgi:
    <IfModule mod_fcgid.c>
    <Files ~ (\.php)>
    SetHandler fcgid-script
    FCGIWrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
    Options +ExecCGI
    allow from all
    </Files>
    </IfModule>
    I needed to add this to the atmail file in /opt/psa/admin/conf/generated - so it it will be lost after the next plesk mingling. I consider this as a bug. For now.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •