Results 1 to 4 of 4

Thread: No Dynamic Screen Resolution

  1. #1

    Default No Dynamic Screen Resolution

    Hi all,

    I'm running PD 7.0 on a late 2009 13" MBP. I installed Ubuntu 11.04 by choosing Ubuntu from the new VM dialog in Parallels, then upgraded to 11.1 after install.

    I then installed Parallels Tools, no problems were reported and Parallels reports that the Tools are up to date. However, I cannot seem to enable dynamic screen resolution. It seems to be stuck in a small size, maybe 800 x 600 or 1024 x 768. When I expand the guest window or enter full screen, the resolution doesn't change, text and icons become large and fuzzy.

    I dug around and found that the video driver being used is VESA: Parallels video adapter. Any help is much appreciated. Thanks



  2. #2
    Kilo Poster
    Join Date
    Oct 2011
    Posts
    59

    Default

    Have you tried editing your xorg.conf file?



  3. #3

    Default

    Thanks dpickett, what should I edit in the xorg.conf?

    # X.Org server configuration file generated by Parallels Guest Tools.
    #
    # Parallels Video section
    Section "Device"
    Identifier "Parallels Video"
    Driver "prlvideo"
    EndSection

    # Parallels Monitor section
    Section "Monitor"
    Identifier "Parallels Monitor"
    VendorName "Parallels Inc."
    ModelName "Parallels Monitor"
    EndSection

    # Parallels Screen section
    Section "Screen"
    Identifier "Parallels Screen"
    Device "Parallels Video"
    Monitor "Parallels Monitor"
    Option "NoMTRR"
    SubSection "Display"
    Depth 24
    Modes "800x600" "640x480"
    EndSubSection
    EndSection

    # DefaultFlags section
    Section "ServerFlags"
    Option "AllowEmptyInput" "yes"
    Option "AutoAddDevices" "yes"
    EndSection

    # DefaultLayout section
    Section "ServerLayout"
    Identifier "DefaultLayout"
    Screen "Parallels Screen"
    EndSection



  4. #4
    Kilo Poster
    Join Date
    Oct 2011
    Posts
    59

    Default

    Quote Originally Posted by terrapin View Post
    # Parallels Screen section
    Section "Screen"
    Identifier "Parallels Screen"
    Device "Parallels Video"
    Monitor "Parallels Monitor"
    Option "NoMTRR"
    SubSection "Display"
    Depth 24
    Modes "800x600" "640x480"
    EndSubSection
    EndSection
    Try changing the setting in modes to the resolution you want. I run my VM at full screen, so my Modes line is:
    Code:
    Modes      "1920x1080"



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •