Results 1 to 5 of 5

Thread: unable to update plesk - package conflict zend-guard

  1. #1
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    21

    Default unable to update plesk - package conflict zend-guard

    my autoupdate fails, then i started autoinstaller in CLI

    /usr/local/psa/admin/sbin/autoinstaller

    the result is:

    ERROR: Unable to proceed with the installation until the package php-zend-guard-loader-5.5.0-3.el5.art.x86_64 is removed from the system.
    Not all packages were installed.
    Please resolve this issue and try installing the packages again.
    If you cannot resolve the issue on your own, contact product technical support for assistance.
    then i do this:

    yum install php-zend-guard-loader-5.5.0-3.el5.art.x86_64

    and the result is:
    Setting up Install Process
    Package php-zend-guard-loader-5.5.0-3.el5.art.x86_64 already installed and latest version
    Nothing to do
    what must i do?



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    Try to remove php-zend-guard-loader-5.5.0-3.el5.art.x86_64 package with something like

    rpm -e --nodeps --justdb php-zend-guard-loader-5.5.0-3.el5.art.x86_64



  3. #3
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    21

    Default

    but there are some projects using zend-guard...



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    --justdb option will just remove package from rpm database.



  5. #5
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    21

    Default

    sorry, i did not see the parameter.

    and thanks, problem solved...



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •