Results 1 to 2 of 2

Thread: error installing php-bcmath

  1. #1
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    23

    Exclamation error installing php-bcmath [SOLVED]

    Hi, after a parallells update, bcmath it's not installed in my server???

    I'm using 10.4.4 Update #28 (last updated at May 2, 2012 04:14 AM) and when I try to install php-bcmath I get
    [root@s1 logs]# yum install php-bcmath
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-bcmath.x86_64 0:5.1.6-32.el5 set to be updated
    --> Processing Dependency: php-common = 5.1.6-32.el5 for package: php-bcmath
    --> Running transaction check
    ---> Package php-common.x86_64 0:5.1.6-32.el5 set to be updated
    --> Processing Conflict: php53-common conflicts php-common
    --> Finished Dependency Resolution
    php53-common-5.3.3-5.el5.x86_64 from installed has depsolving problems
    --> php53-common conflicts with php-common
    Error: php53-common conflicts with php-common
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    [root@s1 logs]# yum install --skip-broken php-bcmath
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-bcmath.x86_64 0:5.1.6-32.el5 set to be updated
    --> Processing Dependency: php-common = 5.1.6-32.el5 for package: php-bcmath
    --> Running transaction check
    ---> Package php-common.x86_64 0:5.1.6-32.el5 set to be updated
    --> Processing Conflict: php53-common conflicts php-common
    --> Finished Dependency Resolution
    php53-common-5.3.3-5.el5.x86_64 from installed has depsolving problems
    --> php53-common conflicts with php-common
    --> Running transaction check
    ---> Package php-bcmath.x86_64 0:5.1.6-32.el5 set to be updated
    ---> Package php-common.x86_64 0:5.1.6-32.el5 set to be updated
    --> Processing Conflict: php53-common conflicts php-common
    --> Finished Dependency Resolution
    php53-common-5.3.3-5.el5.x86_64 from installed has depsolving problems
    --> php53-common conflicts with php-common
    Skip-broken could not solve problems
    Error: php53-common conflicts with php-common
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest

    [root@s1 logs]# package-cleanup --problems
    Setting up yum
    Reading local RPM database
    Processing all local requires
    Missing dependencies:
    Package glibc requires glibc-common = 2.5-42
    Package glibc requires glibc-common = 2.5-24.el5_2.2
    Package glibc requires glibc-common = 2.5-42.el5_4.2
    Package glibc requires glibc-common = 2.5-49.el5_5.4
    Package glibc requires glibc-common = 2.5-34
    Package glibc requires glibc-common = 2.5-42.el5_4.3
    Package glibc requires glibc-common = 2.5-34.el5_3.1
    Package glibc requires glibc-common = 2.5-49
    Package glibc requires glibc-common = 2.5-49.el5_5.2

    [root@s1 logs]# package-cleanup --dupes
    Setting up yum
    glibc-2.5-34.el5_3.1.i686
    glibc-2.5-42.i686
    glibc-2.5-42.el5_4.2.i686
    glibc-2.5-49.el5_5.7.i686
    glibc-2.5-24.el5_2.2.i686
    glibc-2.5-42.el5_4.3.i686
    glibc-2.5-49.i686
    glibc-2.5-49.el5_5.2.i686
    glibc-2.5-49.el5_5.4.i686
    glibc-2.5-34.i686

    [root@s1 logs]# rpm -Va --nofiles --nodigest
    Dependències no satisfetes per a glibc-2.5-34.el5_3.1.i686: glibc-common = 2.5-34.el5_3.1
    Dependències no satisfetes per a glibc-2.5-42.i686: glibc-common = 2.5-42
    Dependències no satisfetes per a glibc-2.5-42.el5_4.2.i686: glibc-common = 2.5-42.el5_4.2
    Dependències no satisfetes per a glibc-2.5-24.el5_2.2.i686: glibc-common = 2.5-24.el5_2.2
    Dependències no satisfetes per a glibc-2.5-42.el5_4.3.i686: glibc-common = 2.5-42.el5_4.3
    Dependències no satisfetes per a glibc-2.5-49.i686: glibc-common = 2.5-49
    Dependències no satisfetes per a glibc-2.5-49.el5_5.2.i686: glibc-common = 2.5-49.el5_5.2
    Dependències no satisfetes per a glibc-2.5-49.el5_5.4.i686: glibc-common = 2.5-49.el5_5.4
    Dependències no satisfetes per a glibc-2.5-34.i686: glibc-common = 2.5-34
    What can I do?

    thank's!
    Last edited by MarcSerra; May 7, 2012 at 03:58 PM. Reason: SOLVED



  2. #2
    Kilo Poster
    Join Date
    Feb 2012
    Posts
    23

    Default

    Solved.

    yum install php53-bcmath
    I close the thread.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •