Results 1 to 4 of 4

Thread: Error: specified logon session does not exist. It may already have been terminated.

  1. #1

    Default Error: specified logon session does not exist. It may already have been terminated.

    I'm running into an issue for the second time where domain aliases become suspended and can't be un-suspended/enabled/activated.

    PRODUCT, VERSION, VERSION OF MICROUPDATE, OPERATING SYSTEM, ARCHITECTURE
    --------------------------------------------------
    Plesk 10.4, Plesk 11.0
    Windows Server 2008 R2 SP1
    Virtual dedicated server


    PROBLEM DESCRIPTION
    --------------------------------------------------
    Initial problem: 51 domain aliases are "suspended" yet parent domain/subscription is active. No way to activate aliases. Each alias shows all services are enabled, but inactive because "target domain is suspended." How to activate target domain for alias?

    After attempting to suspend parent domain/subscription and re-activate, it can't be activated.


    STEPS TO REPRODUCE
    --------------------------------------------------
    Select Domain Alias, Services, Attempt to Enable
    Select Subscription (parent domain), Attempt to Activate


    ACTUAL RESULT
    --------------------------------------------------
    Error shown in UI and event log: ...failed with error code 1: A specified logon session does not exist. It may already have been terminated.


    EXPECTED RESULT
    --------------------------------------------------
    Domain alias or Subscription Activated/Un-suspended


    ANY ADDITIONAL INFORMATION
    --------------------------------------------------

    I have tried http://kb.parallels.com/en/113669 and it did not appear to fix the issue.

    It seems that Plesk/(DB?) is somehow corrupted (what caused?)

    I have verified sites do exist and function - starting directly in IIS allows viewing, however Plesk panel does recognize.


    The following processes are shown in the event log with the error.
    websrvmng.exe
    domainmng.exe

    A specified logon session does not exist. It may already have been terminated.

    Error: Execute websrvmng --add-alias "--domain-name=Domain.com" "--alias-name=Alias.com" --web failed with error code 1: A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520) In Microsoft.Web.Administration module Exception type: System.Runtime.InteropServices.COMException at Microsoft.Web.Administration.Interop.IAppHostMetho dInstance.Execute() at Microsoft.Web.Administration.Binding.AddSslCertifi cate(Byte[] certificateHash, String certificateStoreName) at Microsoft.Web.Administration.BindingManager.Bindin gTransaction.Commit() at Microsoft.Web.Administration.BindingManager.Save() at Microsoft.Web.Administration.ServerManager.CommitC hanges() at ServerManagerFactory.commit() at IIS7ServerManager.commit(IIS7ServerManager* )



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,420

    Default

    Thank you for detailed report. I have forwarded it to developers. I will update thread with results as soon as I receive them.



  3. #3
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,420

    Default

    Developers can't reproduce this issue. Could you please provide us with output of following commands:

    C:\Users\Administrator>"%plesk_bin%\dbclient.exe" --direct-sql --sql="select * from domain_aliases"
    C:\Users\Administrator>"%plesk_bin%\dbclient.exe" --direct-sql --sql="select * from domains"
    C:\Users\Administrator>"%plesk_bin%\dbclient.exe" --direct-sql --sql="select * from clients"
    -
    Plesk Service Team || Twitter Facebook RSS



  4. #4

    Default Creating subdomains

    Hmm I am having the same problem in a different way of how I do it to create subdomains.

    Error: A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520) In Microsoft.Web.Administration module Exception type: System.Runtime.InteropServices.COMException at Microsoft.Web.Administration.Interop.IAppHostMetho dInstance.Execute() at Microsoft.Web.Administration.Binding.AddSslCertifi cate(Byte[] certificateHash, String certificateStoreName) at Microsoft.Web.Administration.BindingManager.Bindin gTransaction.Commit() at Microsoft.Web.Administration.BindingManager.Save() at Microsoft.Web.Administration.ServerManager.CommitC hanges() at ServerManagerFactory.commit() at IISServerManager.commit(IISServerManager* ) at configHosting(slawncare.nukermusic.com)(WebServerA dapter::configHosting line 484) at configHosting(slawncare.nukermusic.com)(WebServerM anager::configHosting line 2944) at execute console command --install-vhost(vconsoleapp::start line 97) at execute "C:\Program Files (x86)\Parallels\Plesk\admin\bin\websrvmng.exe" --install-vhost "--vhost-config=tmp29B0.tmp"(vconsoleapp::run line 107) (Error code 1)

    How to fix? Plesk 11.5.30 with update #5 on Windows 2012
    Last edited by Ryan11433; Jul 15, 2013 at 01:52 PM.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •