Results 1 to 7 of 7

Thread: Alphanumeric username

  1. #1
    Bit Poster
    Join Date
    Jan 2011
    Posts
    4

    Default Alphanumeric username

    Hello,

    We are currently evaluating Parallels Plesk Panel 11, and we run into a problem.

    For one of our customers we have to implement a hosting control panel, and they require the use of only alphanumeric usernames.

    While trying to add a Subscription, we received the following error;

    "You can use lowercase alphanumeric, dash, and underscore symbols in the username. The username should start with a lowercase alphabetic character and should be between 1 and 16 characters in length."

    We are wondering why the policy of not being able to use alphanumeric usernames is active, and is there a way to change the configuration of this policy?

    Hopefully it's possible to change the behavior, otherwise we have to evaluate other products in the market as well. Thank you for your answer in advance.

    Regards,
    Oscar.



  2. #2

    Default

    Oscar, was your username starting with a "digit" / "number"? If yes, then that is the problem, yes you can use an alphanumeric username but the numbers can ONLY be after the first character being an alphabet.
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $20/Per Ticket
    ==> http://www.jolis.net/packages.php?spt=47 <==



  3. #3
    Bit Poster
    Join Date
    Jan 2011
    Posts
    4

    Default

    Hi Abdi,

    I understand, but I explicitly need usernames like '00200' etc. So my question is; why isn't this possible with Plesk, and are there options to overrule this policy.



  4. #4

    Default

    Those limits are hard coded, they cannot be changed in configuration of Parallels Plesk Panel. Remember that system limits have higher priority than limits configured in Parallels Plesk Panel.

    Details here : http://kb.parallels.com/en/1027

    NB: This is not tested, but I think if you use API and create users through the same it can work ...
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $20/Per Ticket
    ==> http://www.jolis.net/packages.php?spt=47 <==



  5. #5
    Bit Poster
    Join Date
    Jan 2011
    Posts
    4

    Default

    Hi Abdi,

    I tried, but also through the API it doesn't seem to work;

    An error occurred during changing of hosting settings: Some fields are empty or contain an improper value.
    ('login' = '00200')



  6. #6

    Default

    Oscar that is unfortunate, perhaps if you must have that format of usernames, then you probably should be looking at manually editing those usernames from the psa database...
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $20/Per Ticket
    ==> http://www.jolis.net/packages.php?spt=47 <==



  7. #7
    Bit Poster
    Join Date
    Jan 2011
    Posts
    4

    Default

    Hi Abdi,

    Thank you for the suggestion. This would be a last resort solution. Hopefully someone from Parallels could give an update on my question as well.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •