Results 1 to 16 of 16

Thread: Parallels Premium Outgoing Antispam - counting problem again

  1. #1
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default Parallels Premium Outgoing Antispam - counting problem again

    Hi everyone,

    the OA has problems to count outgoing messages or rather does not count messages at all.

    I already follow the suggestions from http://kb.parallels.com/de/115257 and in fact something like
    Code:
    egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog | grep SenderID | egrep "Spam: NonSpam|Spam: Unknown|sClass: NonSpam|sClass: Unknown" | wc -l
    shows up
    Code:
    63
    .

    But in the backend there are only zero this day - so counting can only be exercised over the console and not the backend.

    I think the problem is ctoblogs.php around line 283 - because when i took an echo after the the if-Statement, the debug.log has no entry - but it should.

    Could you from parallels or the guys from commtouch take a look and maybe also provide a workaround for this.

    Thank you in advance

    derde0



  2. #2
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi,

    no change until now. after checking all the proposals from here, i still get no correct numbers of -emails sending from the server. the counting processing in ctoblogs.php seems not working - because inspecting the logs (for today)i found this
    Code:
    [root@s2013]#  egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog | grep SenderID | egrep "Spam: NonSpam|Spam: Unknown|sClass: NonSpam|sClass: Unknown" | wc -l
    9
    [root@s2013]# egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog | grep SenderID | egrep "Spam: Confirmed|Spam: Bulk|sClass: Confirmed|sClass: Bulk" | wc -l 
    1
    and for the rest of the time:

    Code:
    root@s2013#  egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog.processed | grep SenderID | egrep "Spam: NonSpam|Spam: Unknown|sClass: NonSpam|sClass: Unknown" | wc -l
    1792
    
    root@s2013# egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog.processed | grep SenderID | egrep "Spam: Confirmed|Spam: Bulk|sClass: Confirmed|sClass: Bulk" | wc -l 
    20
    and this is the output in the backend:
    Bildschirmfoto vom 2013-04-18 11:04:42.png

    so please, dear support, igorG, ruslanT or sergeyL or who ever read this - please give me a hint or something else i can work with.

    Regards derde0



  3. #3
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi folks,

    it could become a kind of game, posting facts about a bug that is not evil at all but annoying in every day business. still no changes - ctoblogs.php gibes false results or nothing and comandline-tools count mails correctly:

    Code:
    [root@*********]#  egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog.processed | grep SenderID | egrep "Spam: NonSpam|Spam: Unknown|sClass: NonSpam|sClass: Unknown" | wc -l
    180
    and
    Code:
    [root@***********]# egrep "ctasd|ASVOD" /usr/local/psa/var/log/maillog.processed | grep SenderID | egrep "Spam: Confirmed|Spam: Bulk|sClass: Confirmed|sClass: Bulk" | wc -l 
    16
    so, here we go again: could you please give it a try and help me with this not working statistic-tool.

    thank you derde0
    Last edited by derde0; Apr 22, 2013 at 04:19 AM.



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,422

    Default

    If troubleshooting from http://kb.parallels.com/115257 did not help, please collect all necessary information, steps-to-reproduce, logs and other useful information and fill template http://forum.parallels.com/showthread.php?t=106113 with it. After that I will forward your detailed report to developers.
    -
    Plesk Service Team || Twitter Facebook RSS



  5. #5
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi Igor,

    tanks for your reply. Here we go:

    ---------------------------------------------------------------
    PRODUCT, VERSION, MICROUPDATE, OPERATING SYSTEM, ARCHITECTURE

    Plesk Panel 11.09; #47, CentOS 6.4, 64-bit

    PROBLEM DESCRIPTION

    The Counting/Statistics of Parallels Premium Outgoing Spam does work. As you can see on the screenshot, there is no counting today and for the last week there are only a few mails counted.
    Bildschirmfoto vom 2013-04-22 12:02:40.png

    STEPS TO REPRODUCE
    If i use the comandline-tools mentioned in http://kb.parallels.com/115257, i get the following numbers:

    for maillog (today) and Spam (confirmed) - 3
    for maillog (today) and no Spam (NonSpam) - 41

    If go into the maillog 'maillog.processed' i get for NonSpam: 180
    and for 'maillog.processed' and Spam: 16

    I i followed the steps on recalculating stats the result on the plesk panel is equal.

    debug.log says:

    Code:
    22-04-2013 12:01:02: Processing maillog
    22-04-2013 12:01:02: Aggregating daily statistics
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042211
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042210
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042209
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042208
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042207
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042206
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042205
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042204
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042203
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042202
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042201
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042200
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042123
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042122
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042121
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042120
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042119
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042118
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042117
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042116
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042115
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042114
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042113
    22-04-2013 12:01:02: Aggregating file /var/log/ctchob/2013/h2013042112
    22-04-2013 12:01:02: Log parsing ended.
    ACTUAL RESULT

    Is as described in the Problem Description

    EXPECTED RESULT

    Parallels Premium Outgoing Spam should show in its stats in minimum 3 Spam-Mails and 41 NonSpam-Mails. Forthermore it should show 180 NonSpam-Mails and 16 Spam-Mails for the week.

    ANY ADDITIONAL INFORMATION

    I did some debuging of ctoblogs.php - because the service is working (ctasd)

    Code:
    Apr 22 12:04:54 servant ct-milter[6202]: [ASVOD] OUT IP: 127.0.0.1, Sender(Auth): mail@mail.com(null)), Spam: Unknown, VOD: Unknown, RefID: str=0001.0A0C0204.51750B32.0043:SCFSTAT3921977,ss=1,re=-4.000,recu=0.000,reip=0.000,vtr=str,vl=0,cl=1,cld=1,fgs=0, Action: tag, QueueId: 765431781011, SenderID: 127.0.0.1, Flags: 0, TMsg: 1, TSpam: 0, TSus: 0, TVirus: 0
    Apr 22 12:06:31 servant ct-milter[6202]: [ASVOD] OUT IP: 127.0.0.1, Sender(Auth): mail@mail.com((null)), Spam: Unknown, VOD: Unknown, RefID: str=0001.0A0C0205.51750B93.0085:SCFSTAT20563094,ss=1,re=-4.000,recu=0.000,reip=0.000,cl=1,cld=1,fgs=0, Action: tag, QueueId: A4D5117810B9, SenderID: 127.0.0.1, Flags: 0, TMsg: 2, TSpam: 0, TSus: 0, TVirus: 0
    Apr 22 12:18:13 servant ct-milter[6202]: [ASVOD] OUT IP: 127.0.0.1, Sender(Auth): mail@mail.com((null)), Spam: Unknown, VOD: Unknown, RefID: str=0001.0A0C0207.51750E50.0149,ss=1,re=0.000,recu=0.000,reip=0.000,cl=1,cld=1,fgs=0, Action: tag, QueueId: EDD711781010, SenderID: 127.0.0.1, Flags: 0, TMsg: 1, TSpam: 0, TSus: 0, TVirus: 0
    Apr 22 12:18:36 servant ct-milter[6202]: [ASVOD] OUT IP: 127.0.0.1, Sender(Auth): mail@mail.com((null)), Spam: Suspect, VOD: Unknown, RefID: str=0001.0A0C0201.51750E68.002F,ss=2,re=0.000,recu=0.000,reip=0.000,cl=2,cld=1,fgs=0, Action: tag, QueueId: 81877178109C, SenderID: 127.0.0.1, Flags: 0, TMsg: 2, TSpam: 0, TSus: 0, TVirus: 0
    i put some comments around line 283 and i get in debug.log - nothing, especially inside of the if-statements.
    --------------------------------------------------------------

    So hope that helps for any additional informations - i am glad to hear from you.

    cio derde0



  6. #6
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,422

    Default

    Could you please post here output of commands:

    # ls -la /var/log/ctchob/last*
    # cat /var/log/ctchob/lastday.stats
    -
    Plesk Service Team || Twitter Facebook RSS



  7. #7
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Quote Originally Posted by IgorG View Post
    Could you please post here output of commands:

    # ls -la /var/log/ctchob/last*

    lrwxrwxrwx 1 root root 32 22. Apr 13:01 /var/log/ctchob/lastday.stats -> /var/log/ctchob/2013/d2013042212
    -rw-r--r-- 1 root root 10 22. Apr 13:01 /var/log/ctchob/lastepoch
    lrwxrwxrwx 1 psaadm psaadm 30 22. Apr 01:01 /var/log/ctchob/lastweek.stats -> /var/log/ctchob/2013/w20130422

    # cat /var/log/ctchob/lastday.stats
    [root@************]# ls -la /var/log/ctchob/last*
    lrwxrwxrwx 1 root root 32 22. Apr 13:01 /var/log/ctchob/lastday.stats -> /var/log/ctchob/2013/d2013042212
    -rw-r--r-- 1 root root 10 22. Apr 13:01 /var/log/ctchob/lastepoch
    lrwxrwxrwx 1 psaadm psaadm 30 22. Apr 01:01 /var/log/ctchob/lastweek.stats -> /var/log/ctchob/2013/w20130422

    [root@*******************]# cat /var/log/ctchob/lastday.stats
    Spam,0,0,0,0,0
    Virus,0,0,0,0,0



  8. #8
    Parallels Developers RuslanT's Avatar
    Join Date
    Apr 2010
    Posts
    53

    Default

    Hello, derde0.
    Did you try to apply workaround from this post - point 3.2?
    Could you post output of:
    # grep '$prevdateh=date("YmdH",$lastepoch);' /opt/ctch/ctoblogs.php
    -
    Plesk Service Team || Twitter Facebook RSS



  9. #9
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi Ruslan,

    yes, i did all the stuff (wait about 1 day and check the results continuously. No change.

    [root@****************]# grep '$prevdateh=date("YmdH",$lastepoch);' /opt/ctch/ctoblogs.php
    $prevdateh=date("YmdH",$lastepoch);

    cio derde0



  10. #10
    Parallels Developers RuslanT's Avatar
    Join Date
    Apr 2010
    Posts
    53

    Default

    Please comment-out this line:
    [root@****************]# grep '$prevdateh=date("YmdH",$lastepoch);' /opt/ctch/ctoblogs.php
    //$prevdateh=date("YmdH",$lastepoch);
    it should help.
    -
    Plesk Service Team || Twitter Facebook RSS



  11. #11
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi Ruslan,

    i do it and will report tomorrow, if this works for me.

    cio derde0



  12. #12
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi Ruslan,

    here we go again.
    Bildschirmfoto vom 2013-04-23 09:50:28.png
    This is the statistic from today with //$prevdateh=date("YmdH",$lastepoch); as you recommended.

    So nothing really new.

    What's next?

    Cio derde0



  13. #13
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,422

    Default

    Quote Originally Posted by derde0 View Post
    What's next?
    I think that this issue should be investigated directly on your server. Therefore I suggest you contact Support Team. Experienced supporters will check it and report a bug if necessary.
    -
    Plesk Service Team || Twitter Facebook RSS



  14. #14
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi Igor,

    contacting the support-team. You mean https://www.parallels.com/support/request/? Well Parallels Premium Outgoing Spam is not mentioned in the list - but it is a product of Parallels, isn't it?

    Maybe you could open a ticket for me, because all the problems i described so far are all in all located on a installation with no modification to plesk panel or Parallels Premium Outgoing Spam. So, it is a bug. Or is there a customer with no problems on Parallels Premium Outgoing Spam? Maybe i can duplicate his configuration. I would because my only aim is that this modul will work as expected.

    Thank derde0



  15. #15
    Kilo Poster
    Join Date
    Mar 2013
    Posts
    31

    Default

    Hi everybody and especially the supporters from Parallels,

    after investigating the Support-Request-Form and recognize that i have to pay for reporting a bug, i think Parallels should clearly state out that customers have to pay for reporting a bug. In Germany we would say "Das würde ich gern schriftlich haben." (I would like to get this in written form.).

    Well, i like the Plesk Panel but in my opinion it is a bit beside of the track that the reports of some customers about the malfunction of a particular product are ignored in way that if these customers won't pay for support there is no support whether he is paying for the product or not (and the costs for the panel are lower than for the Outgoing Spam Module).

    So maybe you can think about and there is a better way for both than closing the contract.

    cio derde0



  16. #16
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,422

    Default

    I see that you are registered on the forum recently. I think the only this can explain what you write above.
    I write it here many-many times, but I'll write again. If support confirm that your report is really describes bug in our product - you will be refunded for your ticket. If it is misconfiguration or something else on your server - you pay for the work to fix your problem.
    -
    Plesk Service Team || Twitter Facebook RSS



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •