Results 1 to 8 of 8

Thread: Task Scheduled and i am getting error Module 'mcrypt' already loaded

  1. #1

    Default Task Scheduled and i am getting error Module 'mcrypt' already loaded

    Hi.

    I have setup a task to run daily by specific hour.
    The task is to run PHP file on the server.

    I am getting error message:
    PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 Could not open input file: var/www/vhosts/mydomain/modules/followup/cron.php

    What can be the cause and how can i check it?



  2. #2
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    14,638

    Default

    That error suggests that multiple PHP config files have been setup to load the mcrypt extension. Check it.
    -
    Plesk Service Team || Twitter Facebook RSS



  3. #3

    Default

    I read it already in other places, but i really didn't understand how and where to check it, can someone give me a clue?
    Also, is this error means that the execution didn't run or it did run but with this error?



  4. #4
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    14,638

    Default

    There are two php.ini - global and php.ini for vhost. Read Plesk documentation about it.
    Also it is just warning (PHP Warning) but not error.
    -
    Plesk Service Team || Twitter Facebook RSS



  5. #5

    Default

    I found 3 php.ini files:
    /var/www/vhosts/ip-xxx/etc/php.ini
    /etc/php.ini
    /var/www/vhosts/xxx.com/etc/php.ini

    And i deleted all of them and i restarted the server.
    I got the same exact warnings as before.

    Is there more files to look into in order to solve this issue?



  6. #6
    Mega Poster
    Join Date
    Mar 2013
    Location
    Truckee, CA
    Posts
    157

    Default

    Quote Originally Posted by IgorG View Post
    There are two php.ini - global and php.ini for vhost. Read Plesk documentation about it.
    I think that this is the documentation that Igor is talking about.

    HTH,
    Eric Pretorious
    Rocket-Powered.com


    1 out of 1 members found this post helpful.

  7. #7

    Default

    Hi fellas,
    i have the same issue,
    i open my php.ini and i dont find any reference to mcrypt
    could you help us to identify this issue?

    thanks!



  8. #8
    Mega Poster
    Join Date
    Mar 2013
    Location
    Truckee, CA
    Posts
    157

    Default

    Quote Originally Posted by hardbrasil View Post
    Hi fellas,
    i have the same issue,
    i open my php.ini and i dont find any reference to mcrypt
    could you help us to identify this issue?
    Did you read the manual?
    Eric Pretorious
    Rocket-Powered.com



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •