Results 1 to 20 of 20

Thread: Can not find registry resource for Application ID

  1. #1
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default Can not find registry resource for Application ID

    New configuration files for the Apache web server were not created due to the errors in configuration templates:
    Template processing failed: file = /usr/local/psa/admin/conf/templates/default/domainVhost.php, error = Template_Exception: Can not find registry resource for Application ID 8f27b0c0-b80f-4d77-8164-26f5886dbb37 file: /usr/local/psa/admin/plib/Template/Processor.php line: 27 code: 0 Previous error: Template_Exception: Can not find registry resource for Application ID 8f27b0c0-b80f-4d77-8164-26f5886dbb37 file: /usr/local/psa/admin/plib/Template/Processor.php line: 27 code: 0 Previous error: Apspp_Exception: Can not find registry resource for Application ID 8f27b0c0-b80f-4d77-8164-26f5886dbb37 file: /usr/local/psa/admin/plib/Apspp/Registry.php line: 147 code: 0. The error message containing the detailed error descriptions was sent to you by e-mail. Please resolve the issues and click here to generate broken configuration files once again or here to generate all configuration files.


    Does anyone knows what this is about?



  2. #2

    Default

    Have you already been here:

    http://kb.parallels.com/en/112733
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $50/Per Month
    ==> PM for details <==



  3. #3
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default

    Thank you Abdi, yes i have already check that. Not worked
    Last edited by scool; Sep 9, 2013 at 12:50 PM.



  4. #4
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Exclamation

    The owner of the website said to me that for some reason installed twice the wordpress package via application vault.
    Then he tried to unistall both installation, and then the plesk crashed with the error above.

    Screenshot_1.jpg
    Screenshot_2.png

    Now, on the menu left, the attached error appeared, and i haven't found any kb article to help me.
    Can you please assist? i suppose i have to manually login to mysql and remove several entries.

    Ofcourse i cannot remove client account and re-created it, neither via ssh. The same error appears again.
    [root@ns1 ~]# /usr/local/psa/bin/subscription -r domain.tld
    Can not find registry resource for Application ID 8f27b0c0-b80f-4d77-8164-26f5886dbb37
    Last edited by scool; Sep 9, 2013 at 05:42 PM.



  5. #5
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    It appears that this application was broken and the only solution is removing it. Try to do following:

    mysql> select * from apsContextsApplications where registryApplicationId="8f27b0c0-b80f-4d77-8164-26f5886dbb37";
    mysql> delete from apsContextsApplications where id=XXX;

    XXX is id from first select.
    -
    Plesk Service Team || Twitter Facebook RSS



  6. #6
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default

    Thank you for your reply.
    query executed, but plesk still not working.



  7. #7
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    Quote Originally Posted by scool View Post
    Thank you for your reply.
    query executed, but plesk still not working.
    What exactly was done and what exactly not working?
    -
    Plesk Service Team || Twitter Facebook RSS



  8. #8
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default

    As i said, the customer just tried to unistall wordpress app, from application vault. I have no idea what is supposed to go wrong on such an action. this is very weird.
    I tried to have explained from the customer exactly what he did, but he only said that by mistake he installed twice wordpress app, and on unistall the subscription crached.

    At this time, every customer logging in on my panel, see the menu error on the left menu. (white screenshot).
    Current customer , cannot login, and on login action the following error appears

    Screenshot_1.png



  9. #9
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    It is database inconsistency. Try to search related KB articles and fix it in database by yourself or contact Support Team if you can't.
    -
    Plesk Service Team || Twitter Facebook RSS



  10. #10
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default

    Unfortunatly i cannot afford this time (per incident support $75) , and only related kb article i found is this, but not helped
    http://kb.parallels.com/en/112733

    How is possible a wrong action by a customer to destroy the psa records? isn't a bit risky?



  11. #11

    Default

    Would you then afford a $20 per incident support I check it out for you? See URL below for level 3 details

    http://www.jolis.net/packages.php?spt=47
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $50/Per Month
    ==> PM for details <==



  12. #12
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    Quote Originally Posted by scool View Post
    How is possible a wrong action by a customer to destroy the psa records? isn't a bit risky?
    It is difficult to say without detailed investigation directly on customer's server. Therefore I suggest contact Support Team.
    -
    Plesk Service Team || Twitter Facebook RSS



  13. #13
    Kilo Poster
    Join Date
    Aug 2008
    Posts
    41

    Default

    Quote Originally Posted by IgorG View Post
    It is difficult to say without detailed investigation directly on customer's server. Therefore I suggest contact Support Team.
    The only available support is the "per incident support" for $75 ?



  14. #14
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    If you have Unlimited 11.5 license - support is free.
    -
    Plesk Service Team || Twitter Facebook RSS



  15. #15
    Abdi Joseph

    Level 3 Hands-On Premium Support @ $50/Per Month
    ==> PM for details <==



  16. #16
    Product Expert StéphanS's Avatar
    Join Date
    Jan 2011
    Posts
    136

    Default

    I had a similar issue.
    A customer had clicked the install app button several times in a row (it wasn't going fast enough for them..).

    They then tried to delete it multiple times again.


    I did the dumps as described in http://kb.parallels.com/en/112733
    And then grepped both .sql's for the Application ID.

    Only the psa dump had the entry.


    I managed to fix the error by running:



    Code:
    mysql> SELECT * FROM psa.apsContextsApplications WHERE psa.apsContextsApplications.registryApplicationId = 'x6d3x1ds-6dz5-s5xq-d956-5x5fg5sjl564';
    +----+--------------+--------------------------------------+
    | id | apsContextId | registryApplicationId                |
    +----+--------------+--------------------------------------+
    | 89 |           56 | x6d3x1ds-6dz5-s5xq-d956-5x5fg5sjl564 |
    +----+--------------+--------------------------------------+
    1 row in set (0.00 sec)
    
    mysql> SELECT * FROM psa.apsContexts WHERE psa.apsContexts.id IN (SELECT psa.apsContextsApplications.apsContextId FROM psa.apsContextsApplications WHERE psa.apsContextsApplications.registryApplicationId = 'x6d3x1ds-6dz5-s5xq-d956-5x5fg5sjl564');
    +----+-----------+---------+-------+----------------+
    | id | pleskType | pleskId | ssl   | subscriptionId |
    +----+-----------+---------+-------+----------------+
    | 56 | hosting   |     304 | false |            259 |
    +----+-----------+---------+-------+----------------+
    1 row in set (0.00 sec)
    
    
    mysql> DELETE FROM psa.apsContexts WHERE psa.apsContexts.id IN (SELECT psa.apsContextsApplications.apsContextId FROM psa.apsContextsApplications WHERE psa.apsContextsApplications.registryApplicationId = 'x6d3x1ds-6dz5-s5xq-d956-5x5fg5sjl564');
    Query OK, 1 row affected (0.01 sec)
    
    mysql> DELETE FROM psa.apsContextsApplications WHERE psa.apsContextsApplications.registryApplicationId = 'x6d3x1ds-6dz5-s5xq-d956-5x5fg5sjl564';
    Query OK, 1 row affected (0.00 sec)

    Hope this helps someone out!


    (The numbers and id's have been replaced, but the logic has been kept)



  17. #17
    Product Expert StéphanS's Avatar
    Join Date
    Jan 2011
    Posts
    136

    Default

    This has now been put into a KB article it seems.
    The SQL used is different (and easier for SQL beginners), but the result is exactly the same.

    http://kb.parallels.com/en/118260



  18. #18
    Product Expert StéphanS's Avatar
    Join Date
    Jan 2011
    Posts
    136

    Default

    It seems that the logic has been changes since some recent micro update:


    Code:
    mysql> select * from apsContextsApplications;
    ERROR 1146 (42S02): Table 'apsc.apsContextsApplications' doesn't exist



  19. #19
    Parallels Team IgorG's Avatar
    Join Date
    Oct 2009
    Location
    Novosibirsk, Russia
    Posts
    15,528

    Default

    [root@ppu11-5 ~]# grep 'patch version' /root/.autoinstaller/microupdates.xml
    <patch version="30" timestamp="" installed-at="20140129T165405" />

    [root@ppu11-5 ~]# plesk db

    mysql> select * from apsContextsApplications;
    Empty set (0.00 sec)

    mysql> desc apsContextsApplications;
    +-----------------------+------------------+------+-----+---------+----------------+
    | Field | Type | Null | Key | Default | Extra |
    +-----------------------+------------------+------+-----+---------+----------------+
    | id | int(10) unsigned | NO | PRI | NULL | auto_increment |
    | apsContextId | int(10) unsigned | NO | | NULL | |
    | registryApplicationId | varchar(36) | NO | | NULL | |
    +-----------------------+------------------+------+-----+---------+----------------+
    3 rows in set (0.00 sec)
    -
    Plesk Service Team || Twitter Facebook RSS



  20. #20
    Product Expert StéphanS's Avatar
    Join Date
    Jan 2011
    Posts
    136

    Default

    My bad indeed.

    These tables reside in psa not in apsc.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •