Results 1 to 6 of 6

Thread: Change screen resolution in Ubuntu

  1. #1

    Default Change screen resolution in Ubuntu

    I have a windows XP host and Ubuntu 6.06 guest under parallels. Ubuntu works (good!) but screen resolution is limited to 1024x768. My monitor is a Dell 2407 that can go up to 1920x1200

    Can anyone advise me how to up the screen resolution?

    Is it as simple as sudo gedit /etc/X11/xorg.config and insering the new resolution? I have tried this this twice, but it destroyed X or corrupted the screen, requiring a fresh install. Is it necessary to create a custom resolution within parallels itself?

    As I am a Linux Noob, some step by step guidance would be a real help.

    Cheers,

    David



  2. #2
    Kilo Poster
    Join Date
    Sep 2006
    Location
    Nashville, TN USA
    Posts
    28

    Default

    I use Parallels for Mac (as host) rather than Windows - with Ubuntu guest. If the the Mac and Windows versions are similar, you need to create a custom resolution in Parallels for the 1920x1200. Then in Ubuntu, although you can edit xorg.conf directly, the more reliable route is to run 'sudo dpkg-reconfigure xserver-xorg'. Let it auto-detect monitor and video and accept all defaults (especially when you don't understand the question). It will then create your xorg.conf with working sync and refresh values as well as mode lines for screen resolution.



  3. #3

    Default

    I was having this problem in all distros, with SUSE locked at 800x600 and ubuntu flavors at 1024x768.

    What I actually did was follow this thread:

    http://www.ubuntuforums.org/showthre...ing+parameters

    and go make the change in grub. It seems that grub was locking the resolution. At any rate, this got me going at 1280x1024. Hopefully it will help you as well...



  4. #4

    Default

    I am also unable to change my resolution. My native Windows XP host resolution is 1600x1200. I created a 1600x1200 custom resolution in 2.2RC1. I then followed the directions above to edit grub, trying both "vga=0x31f" and "vga=0x31e".

    Now, at boot time, the window changes to a 1600x1200 window, but if I try to make it full screen, I'm told that the guest resolution is too high. The text ttys I get with CTRL-ALT-F1 through F6 are garbled version of the character bitmaps.

    Anyone have any ideas?



  5. #5
    Kilo Poster
    Join Date
    Sep 2006
    Location
    Nashville, TN USA
    Posts
    28

    Default

    I also followed the Ubuntu Forums grub how-to, but note what it says here:

    "If grub does not pass a vga parameter to the kernel, it assumes vga=normal, which is 640x480 resolution. From then on, everything running will be at that basic vga resolution, except for the xserver."

    So, as I understand it, grub impacts the boot splash screen and the Ctrl-Alt consoles, but not X. I was able to use the grub vga parameter to be able to see the boot splash in Edgy, but my Edgy Ctrl-Alt consoles are still garbled (like Jay Lavitt). The procedure I described above for xorg fixed X in full screen (for me).



  6. #6

    Default Same Problem (I think) But Backwards

    I'm having the opposite problem. I'm on a MacBook, with a maximum resolution of 1280x800. With the OS X menu bar, the Parallels window title bar and status bar at the bottom, the remaining screen height for the guest OS is significantly less than 768. This works fine in full-screen mode, but usually I'd rather work in a window.

    So, I'd like to change the resolution to 800x600. However, in Ubuntu (6.06.1-desktop), although those options are available in the "Screen Resolution" control panel, changing it there doesn't actually change the resolution. Usually doing so causes X to crash (I think), bringing me back to the login screen.

    Ideas?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •