Results 1 to 10 of 10

Thread: Cannot connect to SMTP server (Outgoing Mail)

  1. #1
    Mega Poster
    Join Date
    May 2005
    Posts
    156

    Default Cannot connect to SMTP server (Outgoing Mail)

    I am having trouble connecting to the outgoing mail server (SMTP) on my plesk 7.5.4 server. In outlook I get this:
    Outlook is unable to connect to your outgoing (SMTP) e-mail server.
    Then if I try to telnet to the server, I get this:

    421 Cannot connect to SMTP server xx.xx.xx.xx (xx.xx.xx.xx:25), connect error 10060
    I Opened port 587 in my firewall to try to send mail through an alternate port SMTP will not recognize it. When I try to telnet, I get the following:

    Connecting To mail.mydomain.com...Could not open connection to the host, on port 587: Connect failed
    Also, there are no errors or connection failures in /usr/local/psa/var/log/maillog

    Does anyone know why this is happening and how to fix it?



  2. #2
    Tera Poster jamesyeeoc's Avatar
    Join Date
    Nov 2003
    Posts
    2,620

    Default

    I Opened port 587 in my firewall to try to send mail through an alternate port SMTP will not recognize it.
    Other than just opening the port, what configurations did you do to tell SMTP to listen/accept on that port?

    Was the Outlook error code one of the following:
    0x800ccc15
    0x80042108
    0x800ccc0e
    0x8004210b
    0x800CCC0B
    0x800CCC79
    0x800ccc67
    0x80040900
    (all these indicate no response from mail server)

    Try telnet'ing to your server on port 25 and 587 to see if you get any response. Post results here.

    From a SSH root login, see if Qmail and/or IMAP are running in memory:

    ps -ax |grep 'qmail'

    ps -ax |grep 'imap'
    [COLOR=darkblue][size=1]
    [b]I hate upgrading! I'd rather build a new box.[/b] ;)
    Sleep? Who needs sleep? There are only half as many hours in a day as there need to be!
    A bullet sounds the same in any language, so stick a sock in it you cow! - Stewie Griffin[/size]
    Please use [COLOR=red][B]SEARCH[/B][/COLOR] before posting, many times the answer to your question is already posted![/COLOR]
    [COLOR=green][size=2]"We judge ourselves by what we feel capable of doing, while others judge us by what we have already done." -- Henry Wadsworth Longfellow
    Your theory is crazy, but it's not crazy enough to be true. - Niels Bohr
    Microsoft isn't evil, they just make really crappy operating systems. - Linus Torvalds
    They have computers, and they may have other weapons of mass destruction. - Janet Reno[/size][/COLOR]



  3. #3
    Mega Poster
    Join Date
    May 2005
    Posts
    156

    Default

    Thanks for the reply. If you look at my first post, you will see the results of the telnet attempt. The error is quoted above.

    The outlook code was 0x80042109.

    i did a ps on the qmail:

    28574 ? S 0:00 /usr/bin/spamd --username=popuser --daemonize --helper-home-dir=/var/qmail --max-children 20 --create-prefs --nouser-config --virtual-config-dir=/var/qmail/mailnames/%d/%l --pidfile=/var/run/spamd/spamd_full.pid --socketpath=/tmp/spamd_full.sock
    28576 ? S 0:00 /usr/bin/spamd --username=popuser --daemonize --helper-home-dir=/var/qmail --max-children 20 --create-prefs --nouser-config --virtual-config-dir=/var/qmail/mailnames/%d/%l --pidfile=/var/run/spamd/spamd_light.pid --socketpath=/tmp/spamd_light.sock --siteconfigpath=/dev/null
    5076 ? S 0:00 qmail-send
    5077 ? S 0:00 splogger qmail
    5078 ? S 0:00 qmail-lspawn ./Maildir/
    5080 ? S 0:00 qmail-rspawn
    5081 ? S 0:00 qmail-clean
    14775 pts/1 S 0:00 grep qmail
    and a ps on the imap:

    28834 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=imapd -maxprocs=40 -maxperip=4 -pid=/var/run/imapd.pid -nodnslookup -noidentlookup 143 /usr/sbin/imaplogin /usr/lib/courier-imap/authlib/authpsa /usr/bin/imapd Maildir
    28836 ? S 0:00 /usr/sbin/courierlogger imapd
    28846 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=imapd-ssl -maxprocs=40 -maxperip=4 -pid=/var/run/imapd-ssl.pid -nodnslookup -noidentlookup 993 /usr/bin/couriertls -server -tcpd /usr/sbin/imaplogin /usr/lib/courier-imap/authlib/authpsa /usr/
    28848 ? S 0:00 /usr/sbin/courierlogger imapd-ssl
    28856 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=pop3d -maxprocs=40 -maxperip=4 -pid=/var/run/pop3d.pid -nodnslookup -noidentlookup 110 /usr/sbin/pop3login /usr/lib/courier-imap/authlib/authpsa /usr/bin/pop3d Maildir
    28867 ? S 0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=pop3d-ssl -maxprocs=40 -maxperip=4 -pid=/var/run/pop3d-ssl.pid -nodnslookup -noidentlookup 995 /usr/bin/couriertls -server -tcpd /usr/sbin/pop3login /usr/lib/courier-imap/authlib/authpsa /usr/
    14779 pts/1 S 0:00 grep imap



  4. #4
    Tera Poster jamesyeeoc's Avatar
    Join Date
    Nov 2003
    Posts
    2,620

    Default

    Sorry, brain malfunction, thought that was still part of the outlook error.

    Ok, looks like the services are all running in memory.

    Have you tried from any other ISP? If you PM me with the IP / domain name I can try from my side.

    Some ISP's do not only blocking or 'filtering' of port 25, but sometimes also use a transparent proxy mechanism for reducing spam transmission. (just a possibility)

    Another obscure reference I found (probably not applicable, but thought I'd mention it) concerns the use of LinkSys routers

    http://www1.linksys.com/support/support.asp?spid=87

    and you didn't reply to:
    Other than just opening the port, what configurations did you do to tell SMTP to listen/accept on that port? (587)
    [COLOR=darkblue][size=1]
    [b]I hate upgrading! I'd rather build a new box.[/b] ;)
    Sleep? Who needs sleep? There are only half as many hours in a day as there need to be!
    A bullet sounds the same in any language, so stick a sock in it you cow! - Stewie Griffin[/size]
    Please use [COLOR=red][B]SEARCH[/B][/COLOR] before posting, many times the answer to your question is already posted![/COLOR]
    [COLOR=green][size=2]"We judge ourselves by what we feel capable of doing, while others judge us by what we have already done." -- Henry Wadsworth Longfellow
    Your theory is crazy, but it's not crazy enough to be true. - Niels Bohr
    Microsoft isn't evil, they just make really crappy operating systems. - Linus Torvalds
    They have computers, and they may have other weapons of mass destruction. - Janet Reno[/size][/COLOR]



  5. #5
    Mega Poster
    Join Date
    May 2005
    Posts
    156

    Default

    Originally posted by jamesyeeoc
    Sorry, brain malfunction, thought that was still part of the outlook error.

    Ok, looks like the services are all running in memory.

    Have you tried from any other ISP? If you PM me with the IP / domain name I can try from my side.

    Some ISP's do not only blocking or 'filtering' of port 25, but sometimes also use a transparent proxy mechanism for reducing spam transmission. (just a possibility)

    Another obscure reference I found (probably not applicable, but thought I'd mention it) concerns the use of LinkSys routers

    http://www1.linksys.com/support/support.asp?spid=87

    and you didn't reply to:
    Other than just opening the port, what configurations did you do to tell SMTP to listen/accept on that port? (587)
    I don't have a LinkSys, however I do have BellSouth and I think they do block port 25. The only thing I did to allow incoming mail from port 587 was open the port, I am not sure how to tell plesk to look for SMTP on that port. That may be a good place to start. Know how to do that?

    I'll also send you a PM. Thanks. (Trying to make the migration from Ensim and it's not going well lol)



  6. #6
    Mega Poster
    Join Date
    May 2005
    Posts
    156

    Default

    I found your article on the issue here: http://forum.sw-soft.com/showthread....ange+smtp+port

    It seems to work ok. I'll keep you posted if I have any issues with it. Now on to bigger and better issues

    Thanks again!



  7. #7
    Tera Poster jamesyeeoc's Avatar
    Join Date
    Nov 2003
    Posts
    2,620

    Default

    Ok, I have verified that I can telnet to both your port 25 and 587, however you are suffering from the SMTP delay issue.

    You need to add the -Rt0 option in your smtp_psa and smtp_additional files.
    Run /etc/rc.d/init.d/xinetd stop

    Edit the file /etc/xinetd.d/smtp_psa

    server_args = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true

    Check that you have -Rt0 added to the server_args

    Then run /etc/rc.d/init.d/xinetd restart
    [COLOR=darkblue][size=1]
    [b]I hate upgrading! I'd rather build a new box.[/b] ;)
    Sleep? Who needs sleep? There are only half as many hours in a day as there need to be!
    A bullet sounds the same in any language, so stick a sock in it you cow! - Stewie Griffin[/size]
    Please use [COLOR=red][B]SEARCH[/B][/COLOR] before posting, many times the answer to your question is already posted![/COLOR]
    [COLOR=green][size=2]"We judge ourselves by what we feel capable of doing, while others judge us by what we have already done." -- Henry Wadsworth Longfellow
    Your theory is crazy, but it's not crazy enough to be true. - Niels Bohr
    Microsoft isn't evil, they just make really crappy operating systems. - Linus Torvalds
    They have computers, and they may have other weapons of mass destruction. - Janet Reno[/size][/COLOR]



  8. #8
    Mega Poster
    Join Date
    May 2005
    Posts
    156

    Default

    Looks like that worked great. Thanks again for all your help.



  9. #9

    Default smtp error

    Hy guys.

    I'm totaly new in lynux but i get a preconfigured email server. My problem is that i can't send emails, but i can get them. My outlook client gives me the following error message:
    An unknown error has occurred. Account: 'ns2.itteam.ro', Server: 'ns2.itteam.ro', Protocol: SMTP, Server Response: '421 Cannot connect to SMTP server 86.125.35.24 (86.125.35.24:25), connect error 10060', Port: 25, Secure(SSL): No, Server Error: 421, Error Number: 0x800CCC67

    Can anybody help me?

    Thanks a lot



  10. #10

    Default

    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •