Add Mac-Home folder to Library

Discussion in 'Windows Guest OS Discussion' started by FelixP, Nov 8, 2009.

  1. Hi there. I just installed Windows 7 with Bootcamp on my Mac Pro (early 2008) and added this Bootcamp partition to Parallels Desktop 5.
    Now I have the Network drive Z for my home folder and I would like to add folders from there to the libraries in Windows 7. But it's telling me that I have to make them available offline in order to do that but the necessary option is not showing up in my context menu.
    I am only sharing my home folder and I don't want to use my mac profile stuff for windows 7.
    Is there any way to achieve what I'm trying?
    Thanks.
  2. alexg

    alexg Parallels Team

    Yes, you can do that. Just open VM configuration settings and disable Shared profile option.
  3. I'm sorry that does not resolve my problem. The shared profile option was deactivated from the beginning.
    The problem is that I cannot add my home folder to the Libraries in Windows 7 because I cannot make the folder available offline which is necessary in order to add a network folder to the Library.
  4. vasilyz

    vasilyz Parallels Team

    Making a shared folder available offline is not a good idea. This actually makes sharing useless since the "offline files" feature copies the shared files to your VM.
    I suggest you to do the following.
    1. Create a folder anywhere, say, C:\Users\Home
    2. Add this folder to your library
    3. Delete the folder
    4. Using the mklink command in an elevated command prompt, make a symbolic link to \\.psf\Home. The link should be named as the folder you created above:
    mklink /d c:\Users\Home \\.psf\Home
    5. Done
    Last edited: Nov 12, 2009
  5. Thank you very much. That works perfectly.
    The reason why I wanted to make the folder availabe offline is that I wanted to be able to use my files also when using Windows natively via Bootcamp on startup and not only when using Parallels. So I guess there is no possible way to do that. But the solution with the symbolic link works really good. Thanks.
  6. Thanks Vasilyz, that worked perfectly!

Share This Page