Opening attachments to Outlook email

Discussion in 'Windows Guest OS Discussion' started by Old Marine, Nov 29, 2007.

  1. Thread was moved from "General Discussions > User Solutions and Workarounds".
    Stacey M


    Since upgrading my MacBook Pro to Leopard running Parallels Desktop build 5160 I have been receiving an error message when trying to open any attachment to an Outlook email message telling me that:

    "Parallels Desktop cannot open file C:\Documents and Settings\Administrator\Local Settings\Temporary Internet Files\OLKF5\DOCSSEA.DOC from the guest OS. You can open only files located on Windows drives (volumes) which have drive letters assigned or in Parallels Shared Folders"

    This problems exists for all file types I have tested including PDF, XLS, PPT, etc. All of these file types opened successfully prior to upgrading to Leopard.

    All of my Mac applications show up in Parallels Shared Applications in the Windows start menu, but even opening them from this location still does not allow me to get an appropriately suffixed attached file to an Outlook message opened.

    I have the "Share Windows Applications" and "Share Mac Applications" selected in the configuration editor as well as "Smart Select" checked (as they were when this worked correctly prior to Leopard update) The Shared Windows, Shared Mac, and Smart Select choices under Applications are grayed out and not selectable, although options under each are available - selecting populate under Shared Mac did not result in seeing a list of applications.

    The only application I run on the Windows XP SP 2 VM is Outlook for Mail, Calendar, and Contacts.

    Any ideas on what configuration option I need to tweak or change?
     
    Last edited by a moderator: Dec 4, 2007
  2. Just a stab in the dark, but the problem may relate to the "special" nature of the Outlook temp directory (it is a specially hidden directory in Windows). I would recommend changing the Outlook Temp directory to a regular (i.e. visible) folder.

    Open Regedit (or Regedt32) and navigate to:

    HKCU\Software\Microsoft\Office\[your version of OL, e.g., OL2003 = 11.0]\Outlook\Security

    Then change the value of "OutlookSecureTempFolder" to a path to a different folder.

    I always change this setting by default, so I have not tested it the other way, but I have no problems opening attachments from Outlook.
     
  3. Xenos

    Xenos Parallels Team

    Hello,

    Old Marine, please uninstall Parallels Tools, then reinstall them in Custom mode. Exclude Shared Applications and Shared Internet Applications from the Tools list when installing.

    Best regards,
    Xenos
     
  4. Thanks Xenos

    I have followed your steps as provided by uninstalling via Start>Settings>Control Panel>Add or Remove Applications.

    When I restarted the VM it came up with the Parallels Desktop>Applications only containing the first four selections on the pulldown menu (Start Menu, Hide Windows Task Bar, Show Windows Desktop, and Show Windows Recycle Bin). None of the Shared Windows Applications, Shared Mac Applications or Smart Select options were available.

    Reinstalled Parallel tools again on top of this installation (standard install) and all of the above options were now visible, but when selecting "Populate" (under "Shared Mac Applications" which is grayed out) It does not populate the Mac Applications.

    What have I done incorrectly? What did I not understand about the steps you outlined?
     
  5. Xenos

    Xenos Parallels Team

    Hello Old Marine,

    The Populate button is not supposed to be working since you have installed Parallels Tools without Shared Applications and Shared Internet Applications.

    This step was intended to restore Windows associations correctly, without Mac interfering.

    Did you try to open attached files in Outlook now?

    By the way, why don't you update to 5582?

    Best regards,
    Xenos
     
    Last edited: Dec 29, 2007
  6. Hi Xenos,

    Thanks for the quick response. Think I need to restate not only the problem but the environment so I am clear on what I am dealing with.

    Environment - MacBook Pro - 2.16/120GB/2GB running 10.5.1 with Office for Mac 2004 (both OS and Office current on updates) - Parallels desktop 5582 - Windoze XP SP2 (also current on updates)

    Problem - when trying to open Outlook attachments using Office for Mac applications I get various error messages (depends on attachment type) essentially telling me that I cannot open the attachment. Problem started with installation of Leopard and since doing that upgrade I have tried various configuration changes, and updating to 5582 in an attempt to resolve the issue, including the most recent suggestion that you made in your mail message yesterday.

    When I performed the steps that you outlined in your message I did attempt to open both an Excel and Word attachment and got the same results as I have been getting. This test performed under the conditions that you outlined.

    Shared Mac applications (Parallels Desktop>Applications>Shared Applications remains grayed out and no Mac applications are listed. This was not the case prior to my update to Leopard. Configuration Editor shows all the same selections made as what was in place prior to Leopard install.

    For what it is worth (but not to confuse this issue) clipboard sharing between Mac and Windows also went away at the same time that application association did.

    Hope that this helps clarify what I am dealing with. Also hope that you have some ideas on how to resolve the problems

    Thanks for your help

    Old Marine
     
  7. Xenos

    Xenos Parallels Team

    Hello Old Marine,

    Please try uninstalling Parallels Desktop in the following manner:

    Go to Finder - Applications - Utilities - Terminal.

    Type and run the following commands:

    • sudo rm /System/Library/Extensions/vmmain.kext
    • sudo rm /System/Library/Extensions/hypervisor.kext
    • sudo rm /System/Library/Extensions/Pvsvnic.kext
    • sudo rm /System/Library/Extensions/ConnectUSB.kext
    • sudo rm /System/Library/Extensions/Pvsnet.kext
    • sudo rm -rf /Library/Parallels/
    • sudo rm ~/Library/Preferences/com.parallels.*

    Before you run these commands, please make sure that your VM hdd and pvs files are NOT stored in ~/Library/Parallels.

    Reboot your Mac and reinstall Parallels, build 5582.

    I hope the new install will bring no issues with e-mail attachments.

    With best wishes for a Happy New Year,
    Xenos
     
  8. Thanks Automandc

    Gave this a shot and unfortunately it had no impact on the problem. Appreciate you providing he input.

    Old Marine
     
  9. Xenos,

    Through some additional diagnostic steps I determined that part of the issue I was dealing with (corrupted user account data) required reinstallation of Leopard.

    Once I completed that reinstall some of the issues I was previously dealing with were resolved, and I was now able to open PowerPoint and Adobe attachments successfully. Word and Excel attachments still failed to open correctly

    I went through the steps you provided in your last email and when completed with command line entries, rebooted and reinstalled Parallels as noted. Installation was successful, dialog box asked for my registration number, and when entered everything came up correctly. Unfortunately the same problem with Excel and Word documents is still occurring. I still do not have any Shared Mac applications present in the Parallels tools bar, and it will not populate a list.

    I am still unable to open Excel or Word attachments (only). I get an "invalid formula" message for Excel attachments (application opens and provides that error message), and a dialog box from Word (application opens and provides the error message) asking me what kind of document I am trying to open, with no choice for a Word document provided.

    Both of these applications work correctly when not being used with Outlook attachments (I can save attachments to another location and open successfully), so it appears that the problem is isolated to the Parallels configuration in some way.

    Any additional thoughts on this issue?

    Thanks

    Old Marine
     
  10. Xenos

    Xenos Parallels Team

    Hello Old Marine,

    I have delivered your report to Parallels developers. Thank you very much for all the details. I will let you know as soon as they provide me with any information.

    Best regards,
    Xenos
     
  11. Thanks Xenos

    Thank You Xenos - safe to assume that the developers will post any feedback to this thread when they have that to provide? - Old Marine
     
  12. Xenos

    Xenos Parallels Team

    Old Marine, I will post all the information that the developers will give me.

    BTW there is a question from them: did you try to copy the files from Outlook to Mac and open them there? Just to make sure these files have the right format and can be opened by Mac applications.

    Best regards,
    Xenos
     
  13. Xenos,

    "BTW there is a question from them: did you try to copy the files from Outlook to Mac and open them there? Just to make sure these files have the right format and can be opened by Mac applications"

    All of the files that I am unable to open while still Outlook attachments (only Word and Excel files now) when saved to a shared folder or a Mac only folder open properly with Mac Word or Mac Excel application software.

    Old Marine
     
  14. Hi Xenos.

    Upgraded to the just released Parallels Desktop 5584 today and wanted to let you know that there was no change in symptoms nor does the upgrade fix for the problem that I am experiencing (as described in my previous post) with my Parallels installation.

    Old Marine
     
  15. Xenos

    Xenos Parallels Team

    Hello Old Marine,

    We have not managed to replicate the issue yet. Could you please tell, did you change something in Guest OS before or after installing Leopard?

    Best regards,
    Xenos
     
  16. Hi Xenos,

    I do not believe that I made changes to the guest system prior to updating to Leopard originally as my typical approach is to limit other changes when performing system updates of any kind so that I don't introduce additional variables into that process.

    As noted in this thread I did have to reinstall Leopard on 1.5.08 to address some corrupted user permission issues, and since that install have made the changes to the guest system noted in our exchanges in this thread, and recommended by you.

    Thanks

    Old Marine
     
  17. Xenos

    Xenos Parallels Team

    Old Marine, I am sorry to say we could not reproduce the issue you are describing. So we hesitate to determinate why you can't open attachments to Outlook email. And we do not have an idea for now how this can be fixed. Our apologies.

    If you can remember any other details that could give us a clue, please let me know.

    Best regards,
    Xenos
     
  18. Xenos,

    Thanks for update.I will try and provide more information as I continue to deal with this frustrating problem. I will be updating my Mac Office configuration from 2004 to the 2008 version in the next few weeks and will see if that has any bearing on the problem.

    I am curious as to what root cause the developers can attribute my inability to populate the "Shared Mac Applications" under "Parallels Desktop>Applications" to? Seems to me that is a more clearly defined problem attributable to a Parallels issue than the specific Outlook attachment opening issue might be.

    Thoughts?

    Old Marine
     
  19. Xenos

    Xenos Parallels Team

    Hello Old Marine,

    You can not always see all Shared Mac Applications under Parallels Desktop -> Applications. However you are supposed to be able to see them in Windows Start menu -> All Programs. Can you see them there?

    Best regards,
    Xenos
     
  20. Hi Xenos,

    Yes I can see all shared Mac applications under Windows>Start>Programs>Parallels Shared Applications.

    At one point in my use of Parallels (before my Leopard update) I was able to see a list of Mac Applications under Parallels Desktop>Applications>Shared Mac Applications and when I double clicked an attachment they opened correctly.

    Not sure what would the upgrade would have done to cause the change that I am experiencing.
     

Share This Page