Parallels is not seeing my CD/DVD Drive

Discussion in 'Installation and Configuration' started by AndyCarolan, Jul 30, 2012.

  1. Hi guys

    I'm really hoping that somebody can help me with this.

    I am trying to set up a Windows 7 Ultimate 64 bit installation (via DVD) in Parallels Desktop 7 but im hitting a major snag. The virtual machine is simply not seeing the CD/DVD drive. Each time I attempt an install, its giving me an "Unable to connect CD/DVD 1." Error

    I have downloaded the latest version of PD7 and made sure that the drive is 'connected' for the virtual machine.

    My Mac is the 2011 3.1Ghz 27" iMac running Mountain Lion.

    Thanks in Advance!
    Last edited: Jul 30, 2012
  2. YanaYana

    YanaYana Parallels Support

    How are you trying to create the virtual machine? You do not need manually connect the dvd drive to it - there is an option to pick the installation source during the creation. Please refer to the kb http://kb.parallels.com/en/4729
    step 2.1
  3. Hi YanaYana,

    Thanks for the reply.

    I am trying to create the Virtual Machine via a DVD. I first of all tried it without changing any settings, but it gave me that "Unable to connect CD/DVD 1." Error

    Since then, Ive tried ticking the "customise settings before installation" control and making the sure drive is 'connected'. Ive also tried it without it being 'connected' - Whatever I'm doing, its simply not even attempting to read the disc.
  4. Just an update

    Ive tried an Ubuntu CD and have found exactly the same problem. Parallels Desktop 7 recognises it as an Ubuntu Disk, but as soon as it launches the Virtual machine and rolls through the boot sequence, I get the following message.

    "Unable to connect CD/DVD 1.

    A file or device required for the operation of CD/DVD 1 does not exist or is used by another process, or you have no permission to access it. The virtual machine will continue running, but the device will be disconnected."

    Really have no idea where to turn with this now... I've tried all the suggestions and have got nowhere with it.
  5. Just an update... I managed to solve the issue by removing then reinstalling Parallels. It works fine now.

    Thanks for the suggestions and help :)
  6. I have exactly the same problem: today, I tried to install Windows 7 (x64) from an original DVD, and had the same symptoms.

    Here are some relevant lines of what appears in the VM window at first boot time:

    Trying to boot from SATA drive 1... failed.
    Trying to boot from SATA optical drive 2... SATA optical drive 2 failed.

    [...]

    No boot device is available, press Enter to continue.


    Some time after, a sheet appears on the window, saying that it's impossible to connect to CD/DVD 1 (0801 etc. etc.).

    The CD/DVD drive is on SATA 0:2 (and the HD of course on SATA 0:1).

    Looks like some kind of bug in the latest Parallels Desktop 7 (7.0.15104.778994) version; BTW, I have just upgraded from OS X 10.7.4 to 10.8...

    Is removing and reinstalling Parallels Desktop really necessary? Will this maybe be solved in the next version?
    Last edited: Aug 10, 2012
  7. OK, so I, too, uninstalled and reinstalled the latest version of Parallels Desktop 7, and now everything is working: so, probably, all this has something to do with the upgrade process (from the previous version of PD7 and/or from Lion to Mountain Lion)...
  8. Uninstalling and reinstalling Parallels 7 did not resolve the CD/DVD Drive issue on my MacBook Pro running 10.8.
  9. In the uninstaller, did you select the option to remove also the preferences? And did you reboot before reinstalling PD7?
  10. So, there could also be something in the previous preferences, that gets cleaned up after a complete uninstall (also deleting the prefs) - who knows...
  11. Well, I uninstalled and reinstalled again, and made sure to select to remove the application settings.

    The way it worked before, is that if I already had a CD/DVD mounted in the Finder, and selected to connect to the CD/DVD Drive in Windows XP via Parallels; the CD/DVD would unmount and then it would be accessible in Parallels. That still doesn't work, so I ejected the CD and then selected to attach to the device in Parallels, then pushed the CD in, and it worked.

    Still not as seamless as before, but it's working at least, where it didn't before.

    Thanks!
  12. YanaYana

    YanaYana Parallels Support

    that's weird behaviour - just keep in mind - if you have Vm with no OS installed - you need to change the boot order first in the configuration in order to boot from CD/DVD
  13. Same problem also for the newest Parallels Desktop 7 (version 7.0.15106.786747): a complete uninstall and reinstall is still necessary, in order to boot a VM from a physical CD or DVD, after upgrading to Mountain Lion (I tried this with another Mac, which had just been upgraded from Lion, and already had the newest PD7 version installed).

    Very strange, indeed...
    Last edited: Aug 7, 2012
  14. ... BTW, and FYI, there is no need to manually change the boot order in the VM settings: if there is no hard disk to boot from (as it usually is when you install a new OS), the next boot choice is the CD/DVD, which then is selected automatically - "it just works".
    Last edited: Aug 7, 2012
  15. YanaYana

    YanaYana Parallels Support

    Guys can you send the Problem report from Help --> Report a problem and post the ID here?
  16. My observation:

    ONLY user ROOT can access the optical drive as boot drive.
    You know the one account you should never ever use for your daily work.
    If you need to circumvent the restriction activate this user root, install the VM to /Users/Shared. Disable root after install and do further use of the created VM with a regular account.

    Usual accounts can access ODD while running VM with any filemanager like Windows Explorer OK.

    It's a problem with rigths and permission. Shurely.

    Pls, tell us, which permission for PD-files needs to be rectified.
    Has it to deal with users belonging to a group like "cdrom" or "disk" in Linux?
    Or is it related to sandboxing in ML? Does PD do announce its access to ODD right; don't it?
    Last edited: Aug 8, 2012
  17. YanaYana

    YanaYana Parallels Support

    Thanks for detailed description? any Problem Reports?
  18. Issue reported with No. 17098119

    2.nd way to circumvent the nonaccessable optical drive.
    Store a copy of your setup-disk as ISO-file with any burning programm( Burn, Toast, etc) or use OSX harddiskutility and store it as dmg-file.
    Set up this file (ISO or DMG) as boot-drive.
    Last edited: Aug 9, 2012
  19. YanaYana

    YanaYana Parallels Support

    Thanks you, i have forwarded this report to our product management team.
  20. I have same problem too.

    Among other things the need to boot the CD / DVD from VM I would start to repair your copy of Windows, which as you say, would cause a system reboot, not always, when I start PD.

    In practice, I turn on my Mac, start PD with Windows 7 and ... Restarting the machine crashes! Then back to work.

    I have said, in support, to repair my copy of Windows, but inserting the CD / DVD I have the same risulato (or problem?) Of SVEN_G to post # 6.

    My original problem is: http://forum.parallels.com/showthread.php?t=261969

Share This Page