Parallels Tools Installs, Restarts, Installs...

Discussion in 'Windows Guest OS Discussion' started by LynnO, Apr 7, 2012.

  1. Windows XP guest. I reverted to a snapshot from a few months ago, so when I started the guest Parallels automatically started updating the tools. After it restarts the guest, posts the message:
    "Parallels Tools are outdated. Wait for automatic upgrade to complete or upgrade manually." and the Parallels Tools Installation Agent runs. It restarts the guest again, displays the same message, and continues in a loop.

    I can interrupt it if I abort at the start of the installation or defer the restart, but it starts the process again whenever the guest is resumed or rebooted.

    I tried uninstalling the tools and then letting it install instead upgrading (although it looks the same when running).

    Any ideas as to how this could be resolved?
    Last edited: Apr 8, 2012
  2. YanaYana

    YanaYana Parallels Support

    go to add/remove programs in control panel and remove old parallels tools. Than install new tool fron virtual machine menu > install parallels tools
  3. I did that already and it didn't help.
  4. I got this problem too. Windows 7 x86.
    Uninstalled tools but files are left in Program Files dir, that I'm unable to delete. Clould be why new install fails...
  5. YanaYana

    YanaYana Parallels Support

  6. Parallels Tools looping or update issue

    Below steps could be sure shot resolution for Parallels Tools looping after latest build update or Parallels Tools updation issues:-

    1. Launch Parallels, do not start the Windows Virtual Machine.

    2. Go to 'Window' menu of Parallels from top menu bar (in Window view mode)-->Virtual Machine List-->do right click(Ctrl + Click using Apple mouse)on Windows Virtual Machine-->Configure.

    3. Select Options tab-->Security-->check the check box 'Isolate Mac from Windows'.

    4. Start the Windows Virtual Machine(If Parallels Tools installation starts automatically then click on 'Devices'(in Window view mode) menu of Parallels from top menu bar-->Keyboard-->Ctrl+Alt+Del-->launch the Task Manager and end Parallels Tools installation).

    5. Click on Start->Control Panel->Add\Remove Programs or Programs and Features->Uninstall Parallels Tools from here and antivirus if any(recommended antivirus : http://kb.parallels.com/113236 ).

    6. Go to "My Computer or Computer in case of Windows Vista or 7" - "C" Drive - "Program Files" - "Parallels" folder and delete the "Parallels Tools" folder.

    7. Click the Windows "Start" menu -> "Run" and type "regedit". Hit OK.

    8. In Registry Editor, go to "My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Parallels" and delete the "Parallels Tools" entry.

    9. Shut down the Windows.

    10. Download and install latest build of Parallels Desktop 7 by referring below link to update Parallels Tools file:
    http://kb.parallels.com/en/112852

    11. Relaunch Parallels install Parallels Tools by referring below steps:
    --> click on Devices menu from top menubar=>Connect Image =>Locate the Parallels Tools iso file (prl-tools-Win.iso). Default location of the Prl-tools-Win.iso is ' Mac HD\Library\Parallels\Tools\ ' --> a pop Window will appear for the permission to install Parallels Tools-->Yes-->select Install Parallels Tools from Autoplay pop up Window-->go ahead to complete Parallels Tools installation.

    12. After installing Parallels Tools go to Virtual Machine menu from top menu bar-->Configure-->Options tab-->Security-->UN-check the check box 'Isolate Mac from Windows'.

    4. Re-start the Windows Virtual Machine and check status of the issue.

    In-case issue still persist then please perform steps provided in below link:
    http://kb.parallels.com/111730



    Regards,
    ====
    Om Prakash
    Technical Support Engineer
    || Parallels
  7. Still Having Problems

    I also updated to the new version of Parallels and had problems with Parallel Tools (the last few days have not been pretty). I'm definitely glad for any help I can get...but I'm still having problems. I tried the suggested instructions up to Step 5. I could not find Parallels Tools listed under "Remove Programs...", so assumed Parallels Tools was not running and went to Step 6. On trying to delete the "Parallels Tools" folder I was told "The action can't be completed because the folder or file in it is open in another program". Did I miss stopping Parallels Tools in Step 5, or is there another program I should also be stopping? Thanks for any suggestions.
  8. Try using revo uninstaller to uninstall Parallel Tools before re-installing it. Even if parallel Tools is not listed, you should be able to force uninstall it by using the forced uninstall mode.
  9. Thanks so much for the redo uninstaller suggestion. I did not mention one serious problem. When my problems with installing Parallels Tools started I found that my connection to the internet also was no longer working. If I figure out a way to get redo uninstaller to my machine I will definitely give it a try, and thanks again for your reply.
  10. I was able to port redo uninstaller over from another PC and ran it. It seemed to get rid of all references to Parallels Tools, but when I tried to install the new tools it stilled failed.
  11. YanaYana

    YanaYana Parallels Support

    This is why i suggested to consult tech support.

    I used to be tech support engineer - and i should say Parallels Tools issues are easier to resolve via remote session. It is essential to check not only obvious traces you have after previous installation (Program Files and Registry) but also take a look into old drivers repository and cache files. Tech support usually do this and check all the necessary files

Share This Page