1 Step Forward 3 Steps Backwards - 3.0 is alpha at best

Discussion in 'Installation and Configuration' started by cmayaud, Jun 19, 2007.

  1. cmayaud

    cmayaud

    Messages:
    12
    1.0 Step Forward 3.0 Steps Backwards - 3.0 is alpha at best

    Has anyone actually gotten the 3.0 upgrade to work?

    I have been using previous versions of Parallels on a MacBook Pro Core Duo to run Vista Enterprise without any problem ... or at least minor inconvenient problems which could be tweaked ...

    Overall I had given Parrallels high marks so when they offered the upgrade I didn't hesitate to buy it and when it was released I went ahead and upgraded ... upgraded? Quite the misnomer ...

    What a sucker I was ... first there is a new VM format ... so you can't go back unless you revert to one of your previous VMs (which we have all painfully learned to back up often)

    Next there was getting the resolution straighten out -- that turned out to be an improper default checked in the Preferences ... okay, that's forgivable but should be immediately fixed so others don't have to suffer through searching these forums just to find out that there is a check box that needs to be unchecked ...

    FINALLY, Parallels Tools are UNINSTALLABLE ... no matter what order you try to install the tools -- they NEVER install ... and I don't see ANYONE reporting a solution that is replicateable -- seems to be potluck if it installs at all and even those who finally got it to installed aren't really sure why it finally installed ...

    Windows keeps requesting drivers that don't exist (that's your only evidence that Parallels is even trying to install TOOLs)

    You can't uninstall Parallels Tools from the VM side or you get a stupid message that says you can't uninstall unless you are running in VM (which, of course, you are or you wouldn't be able to read that worthless message)

    And, of course, without the TOOLs -- all of the new feature lauded in the marketing materials aren't available and you are left running a VM which is crippled and is not even half as functional as the previous version ...

    AND YOU GET THE PLEASURE OF CONSIDERING BUYING SUPPORT TO FIX THE DEFECTIVE UPGRADE

    Why do you need to buy support?

    Because literally NO PARALLELS EMPLOYEE ever frequent their own support board to let us know how to fix their crappy release ...

    This has got to be an incredibly embarrassing release for the company -- but it doesn't help if they just IGNORE their users who are having problems ...

    Even if they just said they know there is a problem and they are working on it, at least we could have SOME Sympathy

    Instead we feel like we were HAD -- especially if we got lulled into to thinking that this was a real release that had been properly beta tested ... even a beta release would have been OKAY ... but this isn't even an Alpha grade release ...

    Does anyone else feel this way or am I the ONLY ONE who can't get this crappy release to work properly and can't believe anyone would even consider for a moment putting this code into general release -- much less charging existing paying users an additional charge for the privilege of getting hosed in this pseudo-upgrade fiasco? :confused:
     
    Last edited: Jun 20, 2007
  2. paulj

    paulj

    Messages:
    12
    you are entirely right - it's a complete disaster. As a technology writer, I can tell you this is exactly what happens to companies before the rug comes out from under them. They have rushed a revision / upgrade to pocket cash, as they are probably aware that the product's days are numbered.

    The upgrade is a disaster start to finish, and the company so far isn't behaving any better. Their "tech support" doesn't even exist.

    Disgusting, but all too common.
     
  3. Purplish

    Purplish Kilo Poster

    Messages:
    528
    Works fine for me.
     
  4. dkp

    dkp

    Messages:
    1,384

    Yes - of course (snipped the rant). Did you contact Parallels via their support email address and request help for your problem? This is not a support BBS - it is a discussion board and a place they can make announcements. But it's a common mistake so you're forgiven.

    Not to hijack your rant, but if you don't communicate your issues in the correct channel you won't get much support. This is your second post since March so you haven't even tapped the self-help community here. We can't help if you don't ask. You have not described your system so we can't offer even well-known suggestions.

    How about to take a deep breath, start a new thread, calmly list your system, problems, expectations, things you've tried, and we'll see if we can help. Copy the message to support@parallels.com so they can also be working the problem(s).
     
  5. brkirch

    brkirch Kilo Poster

    Messages:
    418
    Try opening your VM up without starting it and selecting "Prepare Parallels Tools Upgrade..." from the "Actions" menu. Then start up the VM and see if Parallels Tools will install correctly.
     
  6. DaveyP

    DaveyP

    Messages:
    5
    I had experienced similar problems untill I realised that "Install Parallels Tools..." sets "Parallels Tools setup disk" in the CD/D: drive, from where installation of Parallels Tools can be run and has worked fine for me all the times I've run it.
     
  7. AlanH

    AlanH

    Messages:
    317
    The forum is called "Parallels Support Forum" :)
     
  8. kb27973

    kb27973

    Messages:
    8
    Well, I'll chime in with my experience since I'm waiting on the UNIX guys to fix the severs at work so I can start Oracle back up... Gotta love AIX clustering.

    After some initial problems getting Linux running under 2.5 I had no problems. I then tried the upgrade in a SuperDuper sandbox. Everything went fine. Converted a Linux and Windows XP virtual machine without a hitch. Now I am by no means an experienced user nor a hard core gamer but I've got to say that to me it seems 3.0 is much faster.

    Personally I think they have done a good job.

    Ken
     
  9. buzzdat

    buzzdat

    Messages:
    39
    The Apple support forums are similarly named. I believe that DKP is simply trying to remind folks that this is not the official channel for support from SWSoft. This community is more than willing to help people out with their problems, but only if they clearly state what their problems are <g>.

    Based upon recent forum usage, it should probably be renamed to "Parallels Rant Forums" or "bash anyone who has anything good to say about Parallels 3.0 forums" :)
     
  10. cmayaud

    cmayaud

    Messages:
    12
    YES this a a RANT ... but really a SUMMARY RANT

    1) YES I sent a SUPPORT EMAIL and NO they haven't responded (other than automation)

    2) Parallels call this a SUPPORT FORUM and links USERS to it ... which makes total sense to me since "actively managed forums" are a great way for a company to fine tune their products and identify problem and clarify useability issues , etc. etc ... however, "abandoned forums" almost always degenerate with frustration and reverse and good will that might have been had through "active forum management"

    3) I try not to post unless there is a reason ... ie If I haved a solution to a Problem or I have a specific problem ... my lack of Posts shows that prior to 3.0 things were pretty good ... solutions to problems were readily available on these foum so there was no need to post problems which had solutions ...

    4) I was noticing that there were problems being reported on this board that looked more like they belong on a BETA FORUM -- not a release candidate forum -- and certainly not a current release ...
     
  11. cmayaud

    cmayaud

    Messages:
    12

    yes but what if you downloaded your upgrade software ... is the solution to burn a CD with the Installer and then reinstall from scratch? ... I haven't tried that yet ... has anyone had success with that approach?
     
    Last edited: Jun 20, 2007
  12. cmayaud

    cmayaud

    Messages:
    12

    The "Actions" Menu selection "Install Tools" doesn't work ... it seems to set up a process which, when you start the VM, make Vista think there is a driver to install ... but the process never completes ...

    several peopple have report that you just keep restarting and that eventually it installs ... I've been restarting for a week now and it have never installed (we are talking about Parallels Tools install within the Quest OS .. not the Parallels software in the Host Mac OS which APPEARS to install correctly)

    Several reinstalls in the Host os and repeated "reactivations" with license keys appear to proceed normally but still don't properly install the Parallels Tools in the Guest OS (Vista Enterprise)
     
    Last edited: Jun 20, 2007
  13. fbronner

    fbronner

    Messages:
    385
    Works fine for me also
     
  14. dkp

    dkp

    Messages:
    1,384
    Yup. It's a community support forum. It's where to go to get support for Parallels but not *from* Parallels, necessarily. They are quite consistent about directing support requests to Support@Parallels.com because that is actually funded and staffed.

    It always sounds like one is making excuses for them to mention this but the simple truth is the support requirements outstrip the available manpower. It is a bad business decision to staff up to support peak loads because it drives up costs on the back end and does nothing to improve the product. And peak loads will swamp the most overbuilt call center. A humorous example of what can happen when a large segment of the population acts at once. Years ago on the Johnny Carson show he made a joke about low supplies of toilet paper. It was during the gas shortage in the 1970's and was a tie-in joke. Anyway, viewers took it seriously and went to the stores and started buying and stockpiling toilet paper. This actually caused a tp shortage that lasted a very long time, fulfilling the object of the joke. Some stores actually asked customers to return their unused stock which is kind of gross if you think too hard about it.

    Fixed resources, dynamic demand, new (buggy) product release, unskilled user base == short fuses, hot tempers, frustrated customers. Ever was it so.

    The solution is to encourage, not discourage, volunteers to help out here. When this experience ceases to be rewarding I assure you all it will stop, one disenchanted volunteer at a time. Another useful effort is to try hard to improve the mood of the forum from anger, rage, and frustration to a more positive, "We're all in this together" mood where we actually help each other. There's a reason there are homilies about bad apples spoiling the basket.

    First one who says "Kum by ya" gets a whack!
     
  15. eriqthegeek

    eriqthegeek

    Messages:
    22
    FWIW, the upgrade and functioning of 3.0 has been flawless for me. Other than being a little disappointed at the over-hyped promises of 3D support, I have no complaints. But for day to day use of standards Windows apps, it works great. And I love the SmartSelect feature.
     
  16. twoods

    twoods

    Messages:
    33
    Same Here, upgraded no problem. So-far-so-good... Parallels tools installed fine. I am running XP pro and not vista enterprise however as it pertains to the orginal post.

    Tim
     
  17. DaveyP

    DaveyP

    Messages:
    5
    Hi cmayaud

    I think you've misunderstood my explanation: With the VM running, select "Install Parallels Tools..." from the Parallels menu, then open Windows Explorer (or whatever it is in Vista, I'm an XP boy) and browse the CD/D: drive which should now show the installation "CD" for the Parallels Tools. You run the EXE direct from there (no need to burn a CD - I haven't burnt anything Parallels related in the couple of months I've been using it to get anything to work).

    I downloaded the upgrade and experienced the exact same hanging when selecting "Install Parallels Tools...", but it would appear this mounts a virtual CD. It would just have been useful to have known this in advance.

    DaveyP
     
  18. paulj

    paulj

    Messages:
    12
    Just got off a 2 hour call with Tech Support, and they can't resolve the problem. There is a flaw with the build that is affecting both network sharing and some printing elements.

    SO - They encouraged me to uninstall 3.0 and reinstall the previous version. This, as many of you already know, requires me to ALSO re-install windows, as 3.0 messes with the virtual machine.

    About 9 hours down the toilet, and the guys in Moscow (who are the actual programmers) admit that there's a serious flaw.

    So for those of you who can use 3.0, well done. For the rest of us, tough luck.

    Thanks for everyone's help though!
     
  19. Rachel Faith

    Rachel Faith

    Messages:
    236
    First a couple of points:

    All you so-called-self-appointed-experts.... Please. Do not talk DOWN to frustrated people. Treat this like a hostage situation and DO NOT make it worse with smug haughty conceit. Really now! If your replies are solid let that and that alone stand for your credibility without actually typing out how great YOU are or how AWESOME your install went. These folks are having real problems and stroking your ego at their expense, unless you WANT them to ask for a refund and go away, serves NO purpose.

    Second: Never start with the assumption that the person having the problem is STUPID. Let that be the last resort. Post your first post as if you were talking to someone you are SURE is just as smart and wonderful as you think you are. If they then don't understand what you suggested, THEN.... then you can turn it down a technical notch or two and see how it goes.

    Third: If all you have to say is "Ha Ha Mine works, I don't know what yer F'n Problem is Loser".... STFU !! No one needs to hear that s***. OK?

    I am appalled at the number of threads I read when a handful of you smugger than thou types jump in and CRUCIFY some poor SOB who's near his wits end after hours or days of frustration.

    There are 18 post on this thread and 3.. THREE of them are helpful. And one of them went a little too harsh on the guy IMNSHO.

    That should NOT BE the norm.
     
  20. cmayaud

    cmayaud

    Messages:
    12
    don't worry Rachael ... I didn't take any of the comments as smug ... the reality is this is a crappy release with poor support and lot's of frustrated users -- I didn't see anyone denying that in this thread ...

    Truth is I'm open to any suggestion since it's clear no one - smart or dumb - has posted a good solution for the problem anywhere in these forums - YET

    Also, BEING SMART is irrelevant in SOFTWARE development ... EVEN A DUMMY should be able to install software, when they can't -- THAT'S A PROBLEM FOR THE COMPANY - not the user ...

    The fact that even a DUMMY has to resort to support Forums, MERELY TO INSTALL the software in question, is a pretty good sign the that software version should not have been released in the first place -- even to "smart" beta testers ...
     

Share This Page