10.4.10 USB Fix from Parallels

Discussion in 'Installation and Configuration' started by dkp, Jun 22, 2007.

  1. wueand

    wueand

    Messages:
    3
    via the parallels update function help menu/search for upgrades
     
  2. blacks

    blacks Bit Poster

    Messages:
    9
    Thanks for everybody's support.
    It works again.
    Just updated via the parallels window

    BUT could somebody explain what exactly happened with the USB device after the osx upgrade and parallels?
    I want to understand...is there another way (workaround) when this happens again in the next OSX upgrade?

    Hans
     
  3. dkp

    dkp

    Messages:
    1,367
    Apple made some significant changes to the USB code in OS X 10.4.10 that Parallels and VMWare's Fusion depend on. My recollection is it had to do with with new Santa Rosa chipset in the new MacPro. It required a rewrite of that part of Parallels
     
  4. largo84

    largo84

    Messages:
    4
    I have the latest 3214 build and the latest Mac OSX update and I still can't get my USB thumb drives to show up in the Windows file browser. They show up and are correctly named in the Devices>USB list but are not assigned a drive letter.
     
  5. dkp

    dkp

    Messages:
    1,367
    When it shows up in the devices usb list do you then click your mouse to select it? That list shows you what Parallels can see but unless there is a check mark next to it, Parallels has not presented it to Windows.
     
  6. largo84

    largo84

    Messages:
    4
    It's already checked, if I click it it becomes unchecked.
     
  7. dkp

    dkp

    Messages:
    1,367
    Ok - you definitely have an issue for Parallels to correct. I don't see an obvious solution. Never hurts to go through this drill one last time:

    Validate Parallels Tools version is correct for your version of Parallels
    Reboot your system after installing Parallels
    Ensure the device has been ejected from OS X
    Disable autoconnect for USB devices in Parallels

    Did you ever hear the Windows chime indicating removable hardware was found when attempting to attach the device?
     
  8. largo84

    largo84

    Messages:
    4
    Steps 1-4 already done
    No, never heard or saw any indication from Windows that anything new has been attached to the USB port (either port by 3 different thumb drives).
     
  9. davetroup

    davetroup

    Messages:
    4
    Work-Around to USB problem?

    I spent hours yesterday struggling with the same USB problem others are reporting, using Parallels 3.0. Every time I plugged in my device, I'd get the message that the device was being used by another application (even though it wasn't.) I tried plugging it into one of the USB ports on my keyboard, as well as directly into the Mac. Same problem.

    I was about to give up, when, on a whim, I tried plugging it into the OTHER USB port on my keyboard. To my surprise, it worked!

    So for some reason, when I plug it into the left-hand keyboard socket, it doesn't work, but the right-hand socket, it does. It seems completely reproduceable. I can't explain it, and it's clearly a bug somewhere - but at least I got things to work. Maybe this will help somebody else.

    David
     
  10. largo84

    largo84

    Messages:
    4
    Unfortunately, I can't get mine to work on either the right or left side socket (I've tried 3 different thumb drives made by 3 different companies, all of which work fine under the Mac OS).

    Rob..............
     
  11. dkp

    dkp

    Messages:
    1,367
    The keyboard sockets have some notoriety for poor reliability. On my 15" MBP the right-hand socket doesn't work well but the left-hand socket always does. That's the one I keep my cooling fan plugged into, though, so I unplug it to use the thumb drive.
     
  12. summitscout

    summitscout

    Messages:
    118
    Have USB promblem on 10.4.9

    FWIW, I discovered that I am unable to connect to USB devices with the same error messages already mentioned here.

    BUT, I am running 10.4.9 not 10.4.10. I am also using build 4128.

    Any suggestions?
     
  13. summitscout

    summitscout

    Messages:
    118
    After restarting everything, the problem went away. Maybe it is a latent problem in < 10.4.9 but a killer in 10.4.10?
     
  14. ankle

    ankle

    Messages:
    2
    it might be a dumb question but i have down loaded this patch and it has started up as a full install of parallels is this right???
     
  15. pchris

    pchris

    Messages:
    6
    I'm running a Windows XP VM under Parallels build 4560 and Mac OS 10.4.10 (which was pre-installed on my new MacBook Pro). The control key only functions as right-click, not as a selection extender. I've tried to various solutions posted here and elsewhere with no luck. Is there any news?

    Pat
     
  16. bick4d

    bick4d

    Messages:
    14
    Please tell me how to initiate a post or thread on this sight ?
     
  17. spot the blip

    spot the blip

    Messages:
    19
    Well, I have Ver 3.0 (5160) and OSX 10.4.10 and I still get the pesky error message when trying to connect a Garmin GPS. Infuriating as it used to work in earlier examples of Parallels/OSX. Just for my gratification, does anyone have a surefire routine (ie loading drivers, tools etc) that I can try. Message sent to Tech Support but I'm not holding my breath.
     
  18. Bert

    Bert

    Messages:
    1
    Other way around

    Never had any problems with USB devices in Windows XP.
    When I am running Parallels (2.5 - build 3214), the Mac-side (OS 10.4.10) doesn't recognise USB devices anymore. Can't print from the Mac-side, Windows seems to claim all rights, even when I (thought I) set everything on 'share'... Have to shut down the VM to be able to print again.

    Does this fix help, or is this some different problem?

    I don't use Windows very much, only to check how HTML-files look in Outlook express and IE, and sometimes MS Office-files for work.
     
  19. spot the blip

    spot the blip

    Messages:
    19
    No, everything points to an application in OS X using the USB device. Has anyone got an idea how to capture details of devices being used in OS X?
     
  20. spot the blip

    spot the blip

    Messages:
    19
    Tech support can't help. I was talked through a couple of scenarios but after that I was thanked for the information and told that the issue would be passed to 'QA' - did I want to revert to an earlier version? I guess that means they don't know what is going on and I should wait for a new build.

    Marvellous. I now have a USB device that used to talk to my VM and now doesn't. :(
     

Share This Page