10.5.6 and Parallels 3.0

Discussion in 'Installation and Configuration' started by David_P, Dec 16, 2008.

  1. David_P


    I am wondering if anyone has successfully upgraded from 10.5.5 to 10.5.6 while still using Parallels 3.0 (5608).

    There's no way I'm touching Parallels 4.0 at this point, and I don't particularly want to be confronted with a VMFusion/Parallels 4.0 choice by doing an OS upgrade.

    Anyone willing to fess up?

    Last edited: Dec 16, 2008
  2. Barry D

    Barry D

    I upgraded to 10.5.6. I have a MacBook Pro and am running Parallels 4.0 (Nov 22nd build). So far, I believe the 4.0 is running better under 10.5.6. It appears to be more stable and Word and Excel are running smoother. When I installed 10.5.6, I did it from the "safe mode" and then repaired Permissions and zapped the PRAM before starting Parallels. In general, I have had a "okay" experience with the 4.0 version and 10.5.6 has made Parallels better. One man's experience!
  3. Specimen

    Specimen Product Expert

    Permissions repair should be BEFORE upgrading OS X, this is to avoid the case where the installer can't replace some files because of the wrong permissions. Repairing permissions after shouldn't make any difference as the installer should be able to apply the correct permissions. Also, zapping the PRAM is unneeded and overkill.
  4. John@Parallels


  5. Old Marine

    Old Marine

    10.5.6 and build 5608


    I would also like to hear feedback before upgrading to 10.5.6 with build 5608. Hoping that you get some comments back from someone who has taken the plunge.

  6. Kris G

    Kris G

    I simply installed 10.5.6 update without doing anything with Parallels (have installed ver 4.0 latest built). I had no problem to start Parallels. Indeed run faster under new OS X updated version.

  7. hmolen


    I installed (upgraded) to 10.5.6 without resetting anything, no problems.
    Running P3 (too scared to upgrade to P4 yet, I did buy it though but it is my workPC and cannot affort downtime) version 5608, no problems....
    Then I got the update notice from P3 to upgrade to 5626 and I did (no resets or other fancy stuff).
    When it successfully upgraded to 5626 it asked me if it was ok to re-install PTOOLS, I clicked YES but it told me:
    Parallels Tools cannot be installed. You must have administrator rights to install Parallels Tools.Login to the computer as administrator and try again..................
    << sigh >>
    Which computer are we taking about ? The Mac or the 'machine' in Parallels??
    On both I am administrator with full rights to everything, so my question is: what is PTools checking for that gives it the reason to crash with aforementioned errormessage ?
    Anyone else have the same problem ?
    Or someone from Parallels who has an answer ?
    I am posting here in stead of creating a case so others can benefit from the knowledge.
    If I have to open a case with Parallels anyway, let me know and I will copy/paste this message in your casetool.
  8. John@Parallels


    Please scan Vm for Viruses, and also do you have administrative rights in Windows
  9. Azbuckeyeracer


    I took no special precautions, I just updated to OS X 10.5.6 while the VM and the Parallels app 3.0 build 5608 was shutdown. After a restart, I logged into my regular account (i.e. not root). My VM started normally and appears to be running as before, nothing unusual at all.
  10. rabraham



    I am in the same trouble here as well .

    I installed (upgraded) to 10.5.6 without resetting anything, no problems.
    Running P3 version 5608, no problems....
    Then I got the update notice from P3 to upgrade to 5626 and I did (no resets or other fancy stuff).
    When it successfully upgraded to 5626.

    I did not get the notice to re-install PTOOLS as Hans did

    But now when I try to open my Vista VM I just get the spinning color wheel of death.

    I saw the online doc about the possible Smart mount problem but I did not find the smart mount tab in my VM configuration menu . The article said it applied to 3.0 but maybe its only a 4.0 feature and problem .

    The only way to stop it is to force quit. And then I can not launch Parallels again without a reboot.

    The upgrade box said something about Parallel tools but I have not done anything with this yet
    Could this be the problem

    Hopefully there is a quick fix I am at work and need to get stuff done before the holiday


  11. rabraham


  12. rbh


    I'm on build 5604, but did an upgrade on my main machine to 10.5.6. Everything was ok - the system runs fine and the VM boots and runs as before...


    When I now try to clone the VM to an external HDD - the dialogue where you "Choose" where to place the VM comes up, lasts about 2 seconds as the window with focus, which then jumps back to the dialogue. This means if the location you want to clone to is the same as the dialogue choice allows, hit "return" really fast and it'll work... Otherwise you are stuck at the Wizard and cannot get focus back to the location selection dialogue.

    I did de-install and re-install of the Parallels Desktop v3.0 b 5604 software - but the behaviour remains.

    I'm about to try and go to build 5626 - and will post here if that fixes the issue.

    edit: updating to build 5626 did not change the behaviour. The dialogue for cloning to another location is still broken - so something has changed as a result of the 10.5.6 update (I used the combo update).
    Last edited: Dec 23, 2008
  13. Old Marine

    Old Marine

    Thanks for that info. Was the problem with cloning to an external HDD the only problem you experienced with the 10.5.6 upgrade? Did you experience any other problems when you installed 5626?

  14. rbh


    Hi Old Marine :)

    That was the sum total of my bad experiences. That was on a 17" MBP that had been "upgraded" in-situ from 10.4.11 to 10.5.4, then 10.5.5, then 10.5.6 (all combo updaters).

    I tried it on a MacBook that shipped with 10.5.2 that is also on 10.5.6 - and the problem with the dialogue did not appear. I can only assume it is some quirk or remnant of the Tiger -> Leopard upgrade, that the latest update dragged into the light.

    I'm VERY happy with v3.0 of Parallels in general (now running build 5626) and do not have any reason to jump to v4.0, as I mainly need Windows for work for Outlook/Exchange access, a bit of Visio, and some Intranet sites that drip with ActiveX code (bleh!)...

    I hope that gives you some encouragement!

    Happy New Year!
  15. kion


    Running PD 3 build 5608 on 10.5.6 on a MBP late 2008 (aluminium brick case) without problems. On the 17" early 2008 MBP I tried to upgrade to 4, but failed miserably. Found my Apple 30" to be the guilty party, for some strange reason it works if the display is not connected (see respective thread in this forum on this).
  16. chicago63


    No problems

    I'm running 10.5.6 Mac OS and Parallels 3 build 5626. I didn't do anything special for the 10.5.6 update. Let it do its thing. I think I updated to build 5626 on Parallels 3 BEFORE the 10.5.6 update. Everything works fine. I'm using XP Home SP3.

    I'm in no hurry to update to Parallels 4. I'm somewhat nervous about doing it because of the problems I've read on here. I can't afford to have my VM down.

    As far as installing Parallels Tools, I've done this method with all the updates. Boot the VM in safe mode and install Parallels Tools that way, then reboot the VM. It's worked fine every time.
  17. mydanes


    I am on PD 4 and upgraded to 10.5.6 without incident!

    PD 4 running like a top.
  18. mopsmom1


    Just when one thing seems to work....

    I'm running 10.5.6 on my early 2008 MBP and Parallels 3.0 build 5626. I've had so many problems that I hardly ever use my machine.

    I've had extreme kernel panic to the point that my machine wouldn't turn on any longer. Took it to the Apple store and they determined a RAM module had gone bad. Parallels worked for 4 hours after they replaced the module and then the problems started all over again. During the 4 hours of operation, Parallels upgraded itself from build 5600 to build 5626...an update that I had tried to perform unsuccessfully before the machine crashed apparently kicked in. It also installed Parallels Tools. When one post indicated that Tools was causing glitches, I tried to uninstall Tools, but the only option was to install Tools. So, I deleted the Tools folder from My Computer and deleted the registry keys. I thought it fixed it, but after the next reboot I got BSOD.

    Running either machine (virtual or physical) in safe mode seemed to allow the other to at least boot successfully. However, running 10.5.6 in safe mode didn't load any of my audio or video drivers so iTunes wouldn't play, couldn't see any video clips. When 10.5.6 is not in safe mode, Windows does not boot in Parallels. I have to "reset" and then the "Windows was not shut down properly....boot in safe mode?" screen comes up. If I don't choose safe mode, the system hangs.

    I hope Parallels fixes these glitches. What good is a VM that you can use on the fly if you have to keep rebooting to use all the other stuff on the machine?
  19. rbh


    mopsmom1 - when you let the virtual PC boot into safe mode, what happens if you do a proper shutdown once it is running, then restart it?

    Now the Mac part of the question - what OS X update method did you use?

    There was a well known problem just using software update to download and run a "delta" upgrade (some had 170MB, some about 350MB for the download) which actually only downloaded something like 45MB then tried to run...

    Have you tried the following?

    1. Remove Parallels Tools from the PC - use the add/remove control panel in Windows.
    2. Download the 10.5.6 COMBO update (a whopping 660MB+ download).
    3. use the disc or .dmg file you installed Parallels from to uninstall it.
    4. reboot.
    5. log in, use disc utility to repair permissions, and then run the 10.5.6 combo updater.
    6. let it run and reboot (possibly twice).
    7. if paranoid (like me) - run repair permissions again when it reboots for the last time.
    8. use the disc or .dmg file you have to re-install Parallels.
    9. reboot.
    10. log in and run up Parallels and your VM.

    if that is all working, then it is up to you whether you re-install Parallels Tools on the virtual PC (you don't have to)

    Good Luck! Let us know if this has helped at all. :)

    P.S. I assume you went and grabbed the "proper" copy of Parallels build 5626 off the URL pointers in this forum - and used that to do a complete de-install/re-install.
  20. mopsmom1


    I hope your fix works. To answer a couple of your questions...

    When I reboot from Windows safe mode Windows boots regularly...except I can't expand the window. I'll put Parallels into full screen mode and Windows remains a small window in the center. It seems to function OK, but I haven't over taxed it with apps lately.

    My MBP shipped with 10.5.2 and the automatic updater updated to 10.5.6. I guess I authorized these updates.

    Please forgive my mac ignorance, I've been a hardcore PC user since I built my own 8088. The idea of a guest and host OS is also new to me. Before I uninstall Parallels, do I need to back up my Windows stuff? Are there any precautions I should take? I've already uninstalled Tools and downloaded the 10.5.6 combo.

    Does Leopard log the update installs? I was trying to find a history to check the 10.5.6 download file size, since you indicted there was a discrepency, but I can't find a download history file (there are no Leopard downloads in my user download folder).

    And...since I rebooting over & over again, is there a quick way to tell if Leopard booted in safe mode (Windows pastes it on the 4 corners of the screen)? I'm confusing myself with iterations.

    Thanks for the tips.

Share This Page