100% CPU all the time in Win 98

Discussion in 'Windows Guest OS Discussion' started by Mr. Protocol, Jul 23, 2007.

  1. Mr. Protocol

    Mr. Protocol

    Messages:
    7
    I'm running Windows 98 under Parallels Desktop 3.0 for Mac build 4560. This is not for masochistic reasons; I have an app that refuses to run under XP (probably due to the "improved" file security model).

    It runs fine, really. Well, as "fine" as Win 98 ever gets, with the hangs and the random crashes, but the app runs and responsiveness is...ok. However, the CPU pegs at 100% as soon as Win 98 starts to boot, and stays there until the VM is halted. If anyone else is running Win 98, please tell us: is this what you see? Does Win 98 just peg the CPU as a matter of course? I'm willing to believe that this is how this ancient OS actually does business, but I'd like to know there's nothing actually wrong here.
     
  2. Relan

    Relan Parallels Developers

    Messages:
    78
    Hallo.

    Yes, this is Windows 9x problem. When it's idle it runs infinite loop that eats processor time instead of halting CPU like most modern OS do. But we have made a workarond especially for this situation. Please, make sure that you have set guest OS type to "Windows 98".
     
  3. Mr. Protocol

    Mr. Protocol

    Messages:
    7
    I checked, and under the "General" tab of "Options", it says "OS Type: Windows" and "OS Version: Windows 98". That's what you meant, right?
     
  4. Relan

    Relan Parallels Developers

    Messages:
    78
    Yes, it is. Do you have Windows 98 or Windows 98 SE? We will investigate this issue.
     
  5. Mr. Protocol

    Mr. Protocol

    Messages:
    7
    Windows 98 SE, patched up to the last patch available before Microsoft quit supporting patching for Win 98.
     
  6. Juggernart

    Juggernart

    Messages:
    22
    I can confirm this.
    CPU shows about 103% usage when idle. Win 98 SE. || build 4560.
     
  7. Relan

    Relan Parallels Developers

    Messages:
    78
    OK, thank you for your feedback. We will investigate this issue.
     
  8. Relan

    Relan Parallels Developers

    Messages:
    78
    We have resolved this issue, the fix will be available in the next free update. If you need a solution immediately you can just disable VT-x in your VM properties. Thank you for your reports.
     

Share This Page