2.5 Build 3186 /german/EXC_BAD_ACCESS

Discussion in 'Parallels Desktop for Mac' started by AltGr, Mar 18, 2007.

  1. AltGr

    AltGr

    Messages:
    7
    Hi there,

    since I update to the newest German Version, Windows XP is always crashing after a time. The boxversion (1980) is working fine. Perhaps someone can give me a hint how to get the new (german) version stable. Thanks a lot! Here ist the log:

    Command: Parallels
    Path: /Applications/Parallels/Parallels Desktop.app/Contents/MacOS/Parallels
    Parent: WindowServer [65]

    Version: 2.5 (2.5 Build 3186.0)

    PID: 306
    Thread: 9

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x17fb6000


    Thread 9 Crashed:
    0 0xffff0d9d __memcpy + 1533 (cpu_capabilities.h:228)
    1 com.parallels.desktop 0x00675748 0x1000 + 6768456
    2 com.parallels.desktop 0x0058b805 0x1000 + 5810181
    3 com.parallels.desktop 0x0058bfe3 0x1000 + 5812195
    4 com.parallels.desktop 0x0083df64 QList::append(TGDev const&) + 212
    5 com.parallels.desktop 0x0064a5f1 0x1000 + 6591985
    6 libSystem.B.dylib 0x90024147 _pthread_body + 84

    Thread 9 crashed with X86 Thread State (32-bit):
    eax: 0xffff0d5f ebx: 0x90024104 ecx: 0x0000003a edx: 0xffff8a00
    edi: 0x17fbd600 esi: 0x0e7fe11d ebp: 0xb0526e78 esp: 0xb0526e70
    ss: 0x0000001f efl: 0x00010286 eip: 0xffff0d9d cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x0000001f gs: 0x00000037
     
  2. AltGr

    AltGr

    Messages:
    7
    Nobody any idea? Installed the final version (2.5 Build 3188.0) and got the same problem. XP crashes and I don`t know how to fix. Please help! Thanks a lot!

    AltGr
     
  3. hyperact

    hyperact

    Messages:
    12
    I get the same error in the US version. XP crashes all the time, often in thread 9, sometimes in other threads. I sent in four error reports, and you should too. There is nothing we can do until they fix the program.
     
  4. AltGr

    AltGr

    Messages:
    7
    Thanks for answering. I sent all the information to the german support for parallels, got no answer yet. I spoke to the support via phone too, they told me, that is a problem in windows. Not a bug in Parallels. I don't think so, cause I worked with the older versions without having one crash!

    Bye,
    AltGr
     
  5. hyperact

    hyperact

    Messages:
    12
    If it were a problem in Windows, only the OS should crash. It shouldn't cause Parallels to quit without warning.
     
  6. AltGr

    AltGr

    Messages:
    7
    Just waiting for an answer, but the supportteam didn't give me any solution. I can't work with windows, after a half hour or less XP shutdown! I reinstalled Parallels and the tools, installed the software again and again... Please help! THANKS!

    Date/Time: 2007-03-27 22:13:50.861 +0200
    OS Version: 10.4.9 (Build 8P2137)
    Report Version: 4

    Command: Parallels
    Path: /Applications/Parallels/Parallels Desktop.app/Contents/MacOS/Parallels
    Parent: WindowServer [54]

    Version: 2.5 (2.5 Build 3188.0)

    PID: 232
    Thread: 9

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x01b35000

    Thread 9 Crashed:
    0 <<00000000>> 0xffff0d9d __memcpy + 1533 (cpu_capabilities.h:228)
    1 com.parallels.desktop 0x00675748 0x1000 + 6768456
    2 com.parallels.desktop 0x0058b805 0x1000 + 5810181
    3 com.parallels.desktop 0x0058bfe3 0x1000 + 5812195
    4 com.parallels.desktop 0x0083df64 QList<TGDev>::append(TGDev const&) + 212
    5 com.parallels.desktop 0x0064a5f1 0x1000 + 6591985
    6 libSystem.B.dylib 0x90024147 _pthread_body + 84

    Thread 9 crashed with X86 Thread State (32-bit):
    eax: 0xffff0d5f ebx: 0x90024104 ecx: 0x0000003a edx: 0xffff7a00
    edi: 0x01b3d600 esi: 0x0e30511d ebp: 0xb0526e78 esp: 0xb0526e70
    ss: 0x0000001f efl: 0x00010286 eip: 0xffff0d9d cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x0000001f gs: 0x00000037

    Model: MacBookPro2,1, BootROM MBP21.00A5.B01, 2 processors, Intel Core 2 Duo, 2.33 GHz, 2 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 1 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: AirPort Extreme, 1.0.47
    Bluetooth: Version 1.7.14f14, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Network Service: Parallels Host-Guest, Ethernet, en2
    Network Service: Parallels NAT, Ethernet, en3
    Serial ATA Device: Hitachi HTS541616J9SA00, 149.05 GB
    Parallel ATA Device: MATSHITADVD-R UJ-85J
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth HCI, Up to 12 Mb/sec, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
     
  7. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Did you try...

    Have you tried uninstalling Parallels tools, gracefully shutting down, backing up, un-installing Parallels completely, restarting OS X, drop your old .hdd file back on, install Parallels with the latest build, restart OS X again, then installing the tools again?
     
    Last edited: Mar 28, 2007
  8. AltGr

    AltGr

    Messages:
    7
    Thanks for your answer!

    First I unistalled ParallelTools, closed XP, shutdown and booted. Then I uninstalled Parallels and rebooted again. Then I installed the software again, first Parallels and afterwards the tools. I didn't removed the folder "user/libary/paralles/" before reinstalling the packages and didnt`t made a backup. Perhaps that was the mistake?

    Thanks,
    AltGr
     
  9. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    High chance it wouldn't make a difference... Not making a back-up is always an error if you want the blunt truth. You never know what happens when you start fooling around with things...

    I don't know how to de-bug your log, so hopefully somone from Parallels will come and look at this.
     
  10. AltGr

    AltGr

    Messages:
    7
    I just did it as you wrote. After 15 minutes XP crashed again. :(

    I think, I give up and use my old windowsmachine.

    I bought this packages but didn`t get any support by the parallels-support yet. Perhaps someone reading this can give me the right solution. I HOPE! ;-)

    The same error: Date/Time: 2007-03-29 20:24:51.948 +0200
    OS Version: 10.4.9 (Build 8P2137)
    Report Version: 4

    Command: Parallels
    Path: /Applications/Parallels/Parallels Desktop.app/Contents/MacOS/Parallels
    Parent: WindowServer [59]

    Version: 2.5 (2.5 Build 3188.0)

    PID: 222
    Thread: 10

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x169fb000



    Thread 10 Crashed:
    0 <<00000000>> 0xffff0d9d __memcpy + 1533 (cpu_capabilities.h:228)
    1 com.parallels.desktop 0x00675748 0x1000 + 6768456
    2 com.parallels.desktop 0x0058b805 0x1000 + 5810181
    3 com.parallels.desktop 0x0058bfe3 0x1000 + 5812195
    4 com.parallels.desktop 0x0083df64 QList<TGDev>::append(TGDev const&) + 212
    5 com.parallels.desktop 0x0064a5f1 0x1000 + 6591985
    6 libSystem.B.dylib 0x90024147 _pthread_body + 84



    Thread 10 crashed with X86 Thread State (32-bit):
    eax: 0xffff0d5f ebx: 0x90024104 ecx: 0x0000003a edx: 0xffff0a00
    edi: 0x16a0a600 esi: 0x0d32a11d ebp: 0xb05a7e78 esp: 0xb05a7e70
    ss: 0x0000001f efl: 0x00010286 eip: 0xffff0d9d cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x0000001f gs: 0x00000037
     
  11. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    I highly doubt it is bad memory... But, have you run a memtest? (I'm just fishing now)
     
  12. AltGr

    AltGr

    Messages:
    7
    I will check my memory, thnks for the hint. Some more informations out of the parallels-fault-xxxx.logs:

    -------------------------------------------------------------------------------
    Parallels Desktop 2.5 for Mac OS X version 2.5 Build 3188.0 from 2007-03-14
    -------------------------------------------------------------------------------
    Received SIGBUS: Bus error
    Access to fault address: 0x1bb1000
    unknown signal sender: 2
    -------------------------------------------------------------------------------

    -------------------------------------------------------------------------------
    Parallels Desktop 2.5 for Mac OS X version 2.5 Build 3188.0 from 2007-03-14
    -------------------------------------------------------------------------------
    Received SIGSEGV: Segmentation fault
    Access to fault address: 0x1b4c000
    unknown signal sender: 1
    -------------------------------------------------------------------------------
     
  13. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Almost as if it cannot access certain sectors... But don't listen to me, I don't know THAT much.
     
  14. Catemaco

    Catemaco

    Messages:
    1
    English version also crashes

    I'm having a nightmare of a time with the English version, build 3188, as well. I can't get through the Windows install without the virtual machine crashing and taking the Mac (MacBook Pro) with it.

    If I restart the virtual machine, it goes right back to the beginning of the graphical portion of Windows setup.

    The one time I got through the installation, it crashed after saying it was installing Parallels tools. Parallels support told me to go into safe mode and uninstall tools, but I wasn't able to even get to the screen where you press f8 to get into safe mode. The next time I started it, it said a key file was corrupted.

    This is my first experience with Parallels. I'm not impressed. I'm going to recommend that we return it for a refund.

    Catemaco
     
  15. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Strange. I think it has been over two weeks since my last Parallels crash. Maybe everyone's jokes about me having 'the knack' like Baby Dilbert is true... Plus I homeschooled, so I MUST be even more socially inept and adept at fixing things...

    Joking aside...

    Have you tried zeroing EVERYTHING, including OS X and just seeing what happens if you start fresh? Sometimes something can go wrong with OS X that screws things up.
     
  16. Resolver

    Resolver

    Messages:
    37
    Windows + Parallels crash

    Hello Guys !

    I assume problems might arise from the very beginning of guest OS installation.

    Things begin from the process of reading DATA from windows installation CD. That means some bits are lost and that is why windows is installed , but missing some important bits. Also this ususally happens from direct installation of windows from CD. So installation from image file is more reliable in this case. Also after installation many users stop VM by clicking red cross box. It is not very good , because OS does not like it . Please shut down windows properly. To fix crashes. Usually we use repair options at installation CD , but make a backup first , just in case. Also if no success, just install a new instance of windows os and mount old virtual drive to it...
     

Share This Page