2015 rMBP 13" + Parallels 10 + Win8 + Office 2013 Very Slow

Discussion in 'Windows Guest OS Discussion' started by PhilS1, Apr 10, 2015.

  1. PhilS1

    PhilS1 Bit Poster

    Messages:
    3
    Problem: Word 2013 (in particular but Excel is not great either at least) spikes the processor usage and is really sluggish. There is a noticeable lag when typing or navigating the cursor around to select text with the keyboard shortcuts. Scrolling seems to be hard to control too going too far, too fast.

    RAM looks fine (currently 1.6Gb/6Gb used) but CPU spikes to at least 65%+ when just typing in Word and it's noticeably slow. Prolonged use even starts to get the MBP fan going a little. Anyone got any bright ideas or seen this before too? Thanks.

    (I haven't tried changing the processors in the VM as I already had to activate Windows in Bootcamp once, then once again in Parallels with the current setup and I fear it will trigger a change that requires more hassle with MS).

    Setup:
    I have a new 2015 13" rMBP - top spec processor and 16Gb RAM with a 512Gb SSD. Put on Windows 8 Pro (6.3.9600) 64-Bit in Bootcamp and then installed Office 2013 (via Office 365). Latest updates to both applied and all working OK in Bootcamp mode for a day or two.

    Installed Parallels 10.2.0 (28956) on Yosemite 10.10.2 and set 2 CPUs and 6Gb of RAM for the Bootcamp VM (enable nested/PMU not ticked), 512mb of video memory (tried 1Gb too though to no avail) with Enable Retina ticked (DirectX10 set, 'Enable vertical sync' ticked). Mac is set to 'More Space' resolution. Windows sets the resolution to 3360x2100 under Parallels (2560x1600 under Bootcamp I think) and I have the 'Make text smaller or larger' set to one below 'Larger' which gets Windows (mostly) to what it looks like in Bootcamp mode before. I use Parallels in Full Screen and don't share apps/use Coherence.

    Per various threads I've looked at, 'enable smooth scrolling' under Mouse & Keyboard is now turned off (both devices set to don't optimise for games). In Office I've used the Advanced settings to turn on 'disable hardware graphics acceleration' and turn off 'update document content while dragging' and 'use subpixel positioning to smooth fonts'.

    Edit: Upgrade to 10.10.3 hasn't made a different either way.
     
    Last edited: Apr 11, 2015
  2. PhilS1

    PhilS1 Bit Poster

    Messages:
    3
    Here is one compromise improvement - I turned off 'Enable Retina' in the VM config and set Windows to 1680x1050 (the 'looks like' resolution on OS X for the 'More Space' setting), with 'Smallest' for the make text bigger/smaller setting. This does seem to work better performance-wise (still not amazing though) and is a tolerable 'look' for now.
     
  3. asafk1

    asafk1 Bit Poster

    Messages:
    2
    Hi,

    I have the exact same problem.
    It's really annoying because working on word docs is the main reason I buy parallels 10.

    Is there any way to work "naturally" (without sluggish keyboard and mouse track) on word docs without compromising on working in retina resolution?

    Thanks,
    Asaf
     
  4. asafk1

    asafk1 Bit Poster

    Messages:
    2
    Update:
    Working on Win 8 with office 2016 preview (free for now) dramatically increases performance.
     

Share This Page