3.0 can't record sound - kills NaturallySpeaking

Discussion in 'Parallels Desktop for Mac' started by ukko, Jun 8, 2007.

  1. ukko



    In a fit of misplaced early adopter hopefulness I upgraded to 3.0 which is nice but Dragon Naturally Speaking no longer works. I spent a while trouble shooting it this morning and it looks like the volume on the mic is set incredibly low and cannot be changed.

    * I reran Dragon's volume setting tools and they failed saying the input was too quite.

    * I then tried to get Sound Recorder to work. It would only record the faintest of a whisper on full volume.

    * I tried all combinations of the mixer/volume/mute settings and nothing worked.

    * Meanwhile on the Mac side I can record loud and clear with Quicktime so the hardware is working.

    * I have a Plantronics USB headset so I let Parallels pass it off to the VM. XP Pro recognized it fine and could record. However, the quality is atrocious the sound is crackly and choppy and will not work for dictation, or anything else for that matter. This option also basically doubled the system load on my machine.

    So are there any known bugs in the audio driver and does anyone have any idea of how to fix them? Honestly this all worked fine before I upgraded yesterday.

  2. dkwehe


    Thanks for the warning. I'll pass on the upgrade until this gets fixed.

  3. dan

    dan Bit Poster

    I've had exactly the same problem with my Logitech USB headset, except that in my case the problem has always been there and version 3 simply has failed to correct the problem. If I go through some rather odd steps that I've posted here before, I can get the mic and headphones to work properly in the VM. But one of those steps is rebooting the VM, which is inconvenient.
  4. dkwehe


    I'm a bit worried about that some are finding 3.0 slower in application response, in addition to NaturallySpeaking functionality. Any updates from adventurous souls?
  5. VTMac


  6. dan

    dan Bit Poster

    I read Pogue's blog on that topic, as well. It could be a hardware issue in my case--one from which the Nuance-supplied headset does not suffer. Maybe I'll have to buy Dragon just to get the headset. :) Of course, I'm assuming Pogue uses the Nuance-supplied headset. He might not.
    Last edited: Jun 9, 2007
  7. mikechadwick


    USB Headsets

    I've been waiting for at least 6 months to see if a fix would ever be done to get my Plantronics CS 50 headset to work. Everytime a new version of Parallels comes out i cross my fingers and......still nothing.
    we use an internet phone system at work which only operates with usb handsets / headsets OR built in internal mic & speakers in a laptop (not convenient in the office however). Parallels works fine with the built in mic & speakers on my macbook pro but has never worked with the CS 50 headset. Reading other posts it seems this is a fairly common problem but it's one that has meant me switching to Fusion where everything works perfectly.
    i still prefer Parallels though so please let's try and get this issue resolved - it can't be THAT diffficult?
  8. unused_user_name



    This keeps coming up...


    How to make parallels work with DNS. This has worked since 2.0RC.... (and still works with 3.0)
    1) Connect Mic to Mac before starting Parallels
    2) Goto Mac Prefrences->Sound->Input
    3) Select your mic
    do *not* unplug your mic while the VM is running!
    4) Start Parallels (resuming your VM from standby is OK)
    5) In Dragon, make sure your user is set to use "Mic In" as the input
    do *not* connect your mic as a USB device to Parallels!
    6) Dictate!
    7) when done: shutdown (or standby VM) then unplug mic

    I know this works with DNS8 professional and DNS9 preferred.
  9. leesl



    So, why isn't there a sticky?

    Agree with 1-6 but not 7 entirely. I cannot resume the VM from standby after unplugging the mic. For some reason, the mic is no longer recognized. The only way to re-recognize the mic is to restart after shutting down, which is a real pain when transporting the computer. I have to shut down and restart windows every time I put the notebook to sleep or unplug the mic.
  10. KeithT


    Speed Improved when I Manually designated the Memory

    I too run Dragon... same issue with speed for other apps as well.

    To resolve it, turn off 'Automatic Memory Allocation".

    I went to the Preferences "Parallels Desktop ... Preferences (command & comma)"
    - clicked on "Memory",
    - Selected "Manual" (I am running dedicated 1256 KB of memory for Parallels) and
    - checked ON "Enable Virtual Memory Allocation".

    Restart is required... since then, my speed is back. Dragon works great.

    Only issue I ran into since with Vs 3.0 ... if Dragon is active when I 'suspend'... the VHD does not resume. I have to Force Quite, launch parallels again from the Dock (does not work with HD shortcut on MAC desktop; See FYI below), select the VHD and the then click on HD 1 or another option to modify the settings. This forces the VM to Quit. Then I can launch the VHD once again. Fresh boot begins.

    FYI when I clicked on the short cut after having carried out a 'Forced Quit', Parallels tried to resume the session.
  11. numa


    These directions for using dns with Parallels are very useful. I've relied on this way of doing things for months, but it's a workaround and not a full solution.

    In his review of Parallels Desktop 3 David Pogue says he has DNS working using a usb mic selected in Parallels and switched over to Windows XP. The new Parallels user guide says we can switch a usb mic over to Parallels. We should be able to do that and get it to work.

    Unfortunately, I can't get this work myself. Apparently, I'm not the only one. I'd appreciate assistance on setting up a usb mic in Parallels/XP. Forget dns. Right now I can't even get decent sound out of XP's voice recorder with a usb mic.

    My guess is that this is a usb mic driver issue. Could we have more info on active drivers from people who have a usb mic working within Windows? Any other clues?

    How about some help from Parallels on this long standing problem and major source of frustration? Please say something. The v3 manual isn't useful on this issue.

    VMWare Fusion does not have this problem. Parallels should be able to resolve this in short order.

    Last edited: Jun 12, 2007
  12. unused_user_name


    I'm not sure why it isn't sticky... There used to be a sticky form me called "No more robot sound" but they unstickyed it a while ago....

    As for the standby problem: make sure DNS has the Mic off (i.e. red icon) when you standby and it should work next time (assuming that you have the mic plugged in before starting the VM next time).

    The only time I have to reboot the VM is when I accidentally leave something accessing the sound device while standbying. You can also look at the sound icon (when in windowed mode) and make sure it is not blinking green when you go into standby.

    Yup. Back before 2.5 a bunch of musicians tried to use Parallels with their windows-only fancy audio equipment. They said that the USB driver was not low-latency enough for audio to work correctly. I guess they still have to optimize their code to make it faster....

    @KeithT: good suggestion. I was already using non-auto memory allocation, but I didn't try pre-allocation.
  13. dkwehe


    DNS 9.5 works fine with PD3 on powermac

    Took the plunge and gave it a try. Works as before, perhaps a tad slower. I'll give the memory allocation idea a try. Great idea.


Share This Page