3094 and networking - no suggested solutions work

Discussion in 'Parallels Desktop for Mac' started by ghoetker, Dec 26, 2006.

  1. ghoetker

    ghoetker

    Messages:
    6
    Like many others, I've been unable to get anything but bridged networking to work in 3094 beta 2. I've tried every solution I've been able to find in the forums, including the official suggestions:

    1. Reboot
    2. The System preferences-> networking recommendation in the official FAQ
    3. Resetting PRAM.

    Before and between these, I've totally uninstalled Parallels (including receipts, preferences, etc.)

    Is there ANYTHING else that anyone can suggest. Because of the networking situation at my work, Parallels is basically worthless until I can fix this.

    Is there any information I could provide to the Parallels team that would help them unravel this apparently not-rare problem?

    G.
     
  2. serv

    serv Parallels Developers

    Messages:
    807
    ghoetker,

    can you please post the output of these commands (executed in Mac Terminal):
    1. ifconfig
    2. sudo kextstat | grep parallels
    3. ps axuww | grep pvsnatd
     
  3. b117sat

    b117sat

    Messages:
    3
    I am having the same issue

    Currently working with Bridged Networking but shared does not work. My output for the following commands are as follows:

    ifconfig:
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:16:cb:9d:74:a8
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::217:f2ff:fe4c:5aff%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:17:f2:4c:5a:ff
    media: autoselect status: active
    supported media: autoselect
    wlt1: flags=41<UP,RUNNING> mtu 1500
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:16:cb:ff:fe:68:67:f8
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::201:23ff:fe45:6789%en2 prefixlen 64 scopeid 0x8
    inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
    ether 00:01:23:45:67:89
    media: autoselect status: active
    supported media: autoselect
    en3: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::210:32ff:fe54:7698%en3 prefixlen 64 scopeid 0x9
    inet 10.211.55.2 netmask 0xffffff00 broadcast 10.211.55.255
    ether 00:10:32:54:76:98
    media: autoselect status: active
    supported media: autoselect

    Sudo kexstat:

    82 0 0x8ca000 0x4000 0x3000 com.parallels.kext.ConnectUSB (2.5.0) <37 11 6 5 4 3>
    93 0 0x8c4000 0x6000 0x5000 com.parallels.kext.Pvsnet (2.2) <5 4 3 2>
    102 0 0x6f7000 0x14000 0x13000 com.parallels.kext.hypervisor (2.2) <11 6 5 4 3 2>
    103 0 0x93b000 0xa000 0x9000 com.parallels.kext.vmmain (2.2) <11 6 5 4 3 2>
    104 0 0x52274000 0x3000 0x2000 com.parallels.kext.Pvsvnic (2.2) <36 4 3>

    ps axuww | grep pvsnatd:

    stabbey 1413 0.6 -0.0 27368 420 p1 S+ 6:59PM 0:00.00 grep pvsnatd
    root 223 0.0 -0.0 29844 900 ?? S Mon01AM 0:04.40 /Library/StartupItems/Parallels/pvsnatd
     
  4. ghoetker

    ghoetker

    Messages:
    6
    Thanks. Here is the requested output.

    glenn-hoetkers-computer:~ ghoetker$ ifconfig
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:17:f2:29:72:0b
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1356
    inet6 fe80::217:f2ff:fe47:dbff%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:17:f2:47:db:ff
    media: autoselect status: active
    supported media: autoselect
    wlt1: flags=41<UP,RUNNING> mtu 1500
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:17:f2:ff:fe:5b:44:1e
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:01:23:45:67:89
    media: <unknown type>
    supported media: autoselect
    en3: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:10:32:54:76:98
    media: <unknown type>
    supported media: autoselect
    glenn-hoetkers-computer:~ ghoetker$ sudo kextstat | grep parallels
    Password:
    81 0 0x900000 0x4000 0x3000 com.parallels.kext.ConnectUSB (2.5.0) <37 11 6 5 4 3>
    94 0 0x8fa000 0x6000 0x5000 com.parallels.kext.Pvsnet (2.2) <5 4 3 2>
    99 0 0x70b000 0x14000 0x13000 com.parallels.kext.hypervisor (2.2) <11 6 5 4 3 2>
    101 0 0x95b000 0xa000 0x9000 com.parallels.kext.vmmain (2.2) <11 6 5 4 3 2>
    103 0 0x5442a000 0x3000 0x2000 com.parallels.kext.Pvsvnic (2.2) <34 4 3>
    glenn-hoetkers-computer:~ ghoetker$ ps axuww | grep pvsnatd
    root 195 0.0 -0.0 28808 560 ?? S 8:52AM 0:00.03 /Library/StartupItems/Parallels/pvsnatd
    ghoetker 314 0.0 -0.0 27724 276 p2 R+ 8:56AM 0:00.00 grep pvsnatd
    glenn-hoetkers-computer:~ ghoetker$
    glenn-hoetkers-computer:~ ghoetker$ exit
    Script done, output file is typescript
    glenn-hoetkers-computer:~ ghoetker$ type typescript
    -bash: type: typescript: not found
    glenn-hoetkers-computer:~ ghoetker$ cat typescript
    Script started on Wed Dec 27 08:56:26 2006
    glenn-hoetkers-computer:~ ghoetker$ ifconfig
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:17:f2:29:72:0b
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1356
    inet6 fe80::217:f2ff:fe47:dbff%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:17:f2:47:db:ff
    media: autoselect status: active
    supported media: autoselect
    wlt1: flags=41<UP,RUNNING> mtu 1500
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:17:f2:ff:fe:5b:44:1e
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:01:23:45:67:89
    media: <unknown type>
    supported media: autoselect
    en3: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:10:32:54:76:98
    media: <unknown type>
    supported media: autoselect
    glenn-hoetkers-computer:~ ghoetker$ sudo kextstat | grep parallels
    Password:
    81 0 0x900000 0x4000 0x3000 com.parallels.kext.ConnectUSB (2.5.0) <37 11 6 5 4 3>
    94 0 0x8fa000 0x6000 0x5000 com.parallels.kext.Pvsnet (2.2) <5 4 3 2>
    99 0 0x70b000 0x14000 0x13000 com.parallels.kext.hypervisor (2.2) <11 6 5 4 3 2>
    101 0 0x95b000 0xa000 0x9000 com.parallels.kext.vmmain (2.2) <11 6 5 4 3 2>
    103 0 0x5442a000 0x3000 0x2000 com.parallels.kext.Pvsvnic (2.2) <34 4 3>
    glenn-hoetkers-computer:~ ghoetker$ ps axuww | grep pvsnatd
    root 195 0.0 -0.0 28808 560 ?? S 8:52AM 0:00.03 /Library/StartupItems/Parallels/pvsnatd
    ghoetker 314 0.0 -0.0 27724 276 p2 R+ 8:56AM 0:00.00 grep pvsnatd
     
  5. serv

    serv Parallels Developers

    Messages:
    807
    ghoetker,

    execute the following commands from Mac Terminal (note backslash before space):
    sudo /Applications/Parallels/Parallels\ Desktop.app/Contents/Resources/PvsvnicConfigure
    sudo killall -HUP pvsnatd
    Then do ifconfig and see if en2 and en3 interfaces got IP addresses. If not, try rebooting your Mac and doing the above again.


    b117sat,

    You case is different. Can you provide 'ipconfig' output (assuming your guest is Windows)?
     
  6. b117sat

    b117sat

    Messages:
    3
    Well i tried again using shared networking after switching from bridged networking. At first it did not work. The two steps i took to get it to work were renewing the adapter in Mac OS X and disabling and renabling the adapter in windows XP SP2. After it was working i shutdown the VM and then restarted. The shared networking was still working after taking those steps. I restarted my macbook pro and then tried windows again and the networking was again not working. Here is my ipoconfig output:

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\stabbey>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : scott-cvaoiy994
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Parallels Network Adapter
    Physical Address. . . . . . . . . : 00-FA-3A-3A-6F-83
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 10.211.55.3
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 10.211.55.1
    DHCP Server . . . . . . . . . . . : 10.211.55.1
    DNS Servers . . . . . . . . . . . : 10.211.55.1
    Lease Obtained. . . . . . . . . . : Wednesday, December 27, 2006 8:48:26
    PM
    Lease Expires . . . . . . . . . . : Wednesday, January 03, 2007 8:48:26
    PM
     
  7. b117sat

    b117sat

    Messages:
    3
    Update: I released and renewed the adapter in Windows XP and at first i still had no internet connection but after a few refreshes in Internet Explorer it was working.
     
  8. ghoetker

    ghoetker

    Messages:
    6
    Thank you for the quick answer. I applied the two commands you recommended. Nothing. Rebooted and tried again. I was able to reach the net from Parallels, which is progress. However, bridged was still the only mode available, no shared. I suspect this will be a problem in navigating the VPN at work, so I still have a problem. Here is the output, should it be helpful.

    glenn-hoetkers-computer:~ ghoetker$ sudo /Applications/Parallels/Parallels\ Desktop.app/Contents/Resources/PvsvnicConfigure
    Password:
    Configuring en2...
    No System Preferences changes required.
    Configuring en3...
    No System Preferences changes required.
    glenn-hoetkers-computer:~ ghoetker$ sudo killall -HUP pvsnatd
    glenn-hoetkers-computer:~ ghoetker$
    glenn-hoetkers-computer:~ ghoetker$ ifconfig
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:17:f2:29:72:0b
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1356
    inet6 fe80::217:f2ff:fe47:dbff%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:17:f2:47:db:ff
    media: autoselect status: active
    supported media: autoselect
    wlt1: flags=41<UP,RUNNING> mtu 1500
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 2030
    lladdr 00:17:f2:ff:fe:5b:44:1e
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:01:23:45:67:89
    media: <unknown type>
    supported media: autoselect
    en3: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:10:32:54:76:98
    media: <unknown type>
    supported media: autoselect
    glenn-hoetkers-computer:~ ghoetker$
     
  9. serv

    serv Parallels Developers

    Messages:
    807
    ghoetker,

    Hmm... Can you plese do the following
    sudo killall -9 pvsnatd
    sudo /Library/StartupItems/Parallels/pvsnatd
    tail /var/log/system.log |grep pvsnatd
     
  10. ghoetker

    ghoetker

    Messages:
    6
    Thank you for the continued support. I have updated to the new beta and am happy to report that things seem to be MOSTLY working. Once I have Windoze up, I can connect select "Shared Networking" and which point everything I need to work works. it remains the case, however, that I cannot switch from Bridged Internet in the configuration settings, only once I have started Windows in the VM. That's an irritation that I'd love fixed, but not a crisis.

    When I quit after doing that, I found that in the configuration networking was set to Shared. But, when I tried to start it, I got an error message and a suggestion to reboot. After doing so, I found I was back at the same situation: only bridged available in the configuration, but I could change to shared once the VM was up.

    Perhaps related, or not, is that I can find no evidence of the "Parallels Network Adapter" (I think). The only type of adapter available in the popup menu on Config editor > Network>Advaced is "Realtek 8029(AS)".

    So, things appear to be workable (although I've not yet tried from work, which has funky VPN issues). However, they are clearly not where they should be in the final product. If I can provide any additional feedback, please let me know. Parallels is a great product.
     
  11. jwilker

    jwilker

    Messages:
    10
    similar networking problems

    I've noticed the same thing. my VM has only one option for networking, I've rebooted, removed the networking and re-added, nada.
     

Share This Page