A fix for a slow VM after build installation or upgrade

Discussion in 'Windows Guest OS Discussion' started by Jacksonhall, Apr 18, 2008.

  1. Jacksonhall

    Jacksonhall

    Messages:
    4
    Keywords: Leopard, upgrade, manual, install, reinstall, clean install, network, IP address, slow, sluggish, parallels tools, virtual machine, guest os


    I thought that I would post this solution since I have had the same issue twice, once on my machine and now on a coworkers. I wish that I would have stumbled upon this solution the first time I had this issue.

    Both machines are exactly the same configuration.
    OS: Leopard
    Parallels version: 3.0
    VM: Windows XP Pro SP2
    Mac:
    Model Name: MacBook Pro 15 inch
    Model Identifier: MacBookPro3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 4 GB
    Bus Speed: 800 MHz


    Issue:
    After installing a new build, from 4128 to 4560 (1st occurrence running Tiger) or 5582 to 5584 (2nd occurrence running Leopard) the VM ran slow with a 5-90 second delay. Many threads have attributed the sluggish behavior to Parallels Tools as I have. In both cases when Parallels Tools was turned off, or not installed, the VMs ran as fast as they ran before the upgrade. To no avail cleanly reinstalling Parallels or Parallels Tools didn't help. The VM also was never able to obtain an IP address no what Parallels network setting was engaged.

    Note: This issue is does not happen with every new upgrade/install/or reinstall. I have had successful first attempt build upgrades before. In fact I upgraded my machine without a problem from 5582 to 5584 before I ran into the issue at hand with my coworkers machine. My build upgrade was done before upgrading to Leopard and my coworkers was done after upgrading to Leopard.

    Solution:
    I didn't notice this until the very end but, the VM was not able to obtain an IP address. Neither changing Parallels' network settings nor restarting the VM helped. HOWEVER when I ran an ipconfig release/renew on the VM(manually releases and renews the computers IP address), within a minute the VM was back to running at normal speed. This leads me to believe that there is a bug with Parallels Tools and its virtual network adaptors. The VM seemed to be caught in an loop trying to obtain an IP address or renew an IP lease. This explains why the process monitor was not revealing anything running at 100% cpu.

    To run an ipconfig release/renew:
    Start > Run > type cmd (command prompt) > type " ipconfig /release" + enter (for help type "ipconfig help") > type "ipconfig /renew" + enter

    Other help:
    If you are upgrading to Leopard I would suggest upgrading your Parallels build to the most current version BEFORE starting with your Leopard upgrade. This is always best practice for all software before a OS upgrade. If you have problems with Parallels after you upgrade to Leopard, no worries, a clean reinstall should fix the problem. For information on this subject and other best known practices for Parallels upgrades see "Helpful Threads below".

    Helpful Threads: (Run a general search for the following thread titles)
    Known Issues and Workarounds for Parallels Desktop with Leopard
    Upgrading to Leopard (look at the second post)

    Knowledge base:
    KB #5116 - Uninstalling Parallels Tools Manually
    Best Practice for Upgrading Parallels:
    KB #4790 - Problems When Installing or Running Parallels Desktop
     
    Last edited: Apr 18, 2008

Share This Page