Accessing shared folders SLOW in Snow Leopard

Discussion in 'Windows Guest OS Discussion' started by Vaj, Sep 8, 2009.

  1. Vaj

    Vaj

    Messages:
    8
    Well, after paying 50 dollars to "upgrade" to the latest version of Parallels, I've found accessing my hard drives is extremely slow, taking several minutes to connect. Meanwhile, the rest of my install of XP is quick and fast. Upgraded to the most recent version of Parallels last night, and still the same sluggish connect. Also copying files from shared folders or drives is also quite slow.

    Any fix for this?
     
  2. VBR

    VBR

    Messages:
    63
  3. DonaldL

    DonaldL

    Messages:
    1
    Still slow

    I followed the solution specified in the tech note and it is still incredibly slow. Parallels, this 4.0 version is really killing me and I am using your product for work.
     
  4. Anupama A

    Anupama A

    Messages:
    286
    Hello,

    Please follow these steps in regards to the issue:

    Restart MAC, don't start any applications. Uninstall Parallels Desktop using the .dmg file.
    Now, please follow these steps :

    1. Open Finder.
    2. Go to Applications/Utilities/Disk Utilities.
    3. Choose MAC HD.
    4. Choose repair disk permissions.
    After running the repair disk permissions , restart the computer. Install Parallels Desktop.

    http://kb.wisc.edu/helpdesk/page.php?id=3810

    Also, follow the steps below in regards to the issue:

    1. The easiest way to fix the problem and get fast OS boot time again is to leave the VM being idle for 30-60 minutes.OS starts to optimize itself after ~30 minutes of being idle.

    2. Run cmd.exe (shell interpreter) and execute the following command:

    start /wait Rundll32.exe advapi32.dll,ProcessIdleTasks

    This command takes 2-3 minutes to complete after that applications and OS will be optimized out again.

    3. Disable Smart Mount. You can disable smart mount by clicking on Virtual Machine -> Configure -> Smart Mount.
     
  5. Vaj

    Vaj

    Messages:
    8
    I tried this twice. It's still as slow, if not slower.

    It's odd, as I'm able to still go under the "Start" menu and launch other apps; the rest of the system is still responsive. I can also still easily switch back and forth to the Mac OS, without any slowness. It's only connecting to my Snow Leopard hard drive and it's attached Firewire and USB 2.0 HD's.

    With a 2 megs of RAM, Activity Monitor shows it using 2-4% of the 200% of available resources (2 core system), and it's using about 470 megs of RAM for prl_vm_app. Parallels Desktop uses around 108 megs of RAM.
     
  6. Vaj

    Vaj

    Messages:
    8
    I tried the first four steps below and this has in fact fixed the problem of slow access to shared drives.

    It only makes sense that one should repair disk permissions before an install--esp. when the install involves an operating system that's going to try to "talk" to your drives, etc.

    In any event, the entire XP Pro VM is running fast as new on a Mac Mini with 2 gigs of memory. I should also point out that this is an old VM that's been updated across at least two versions of Parallels Desktop. I also noted that the previous problem with expanding the size of the VM in PD 3.x is gone. I was easily able to increase the size of the VM and on first boot into XP the new size shows in the "My Computer" info pane.

    Thanks for the suggestions! It worked perfectly.

     
  7. hsdajr

    hsdajr Bit Poster

    Messages:
    5
    This didn't help me either.

    I have the misfortune of running a proprietary VB6 app in Windows 2000 Professional that requires me to select numerous files. And now this is running on top of Snow Leopard (32-bit Kernel). Unfortunately for me, the files are generally around 12 folders deep (they used a hard-coded path structure). So every double-click in a File Dialog Box is running about 45 seconds EACH, times that by 12 and that's how long it's taking to select a SINGLE file and on average I have 6-7 files per project.

    A good portion of my company's business requires me to use this stupid program, and it's always been slower since I switched to Parallels 4 (in honesty, Parallels 3 ran quicker for me), but trying to run it on Snow Leopard has been difficult.

    Not necessarily blaming Parallels specifically, but the combination of the two (Parallels 4 and Snow Leopard 10.6 and 10.6.1) has made it pretty much unusable for me.
     

Share This Page