Already used in another Parallels window?

Discussion in 'Parallels Desktop for Mac' started by mikesax, Dec 2, 2006.

  1. mikesax


    Using 3036 I get the following error message when trying to load my VM:

    " VirtualMachine WinXP cannot be opened since it is already used in another Parallels Desktop window. "

    It's not... my system was just shut down in the middle of having a VM open.

    I've had a similar error message in previous builds, but I would always have to option to override and load the VM anyway. Rebooting doesn't help.

    I'm locked out of my VM, so any help/workarounds would be most welcome.

  2. SteveDemy


    Exactly the same condition here. Need to override a lock as in the past. Mac OS X restarts don't help.

    "Virtual machine Parallels_XP cannot be opened since it is already used in another Parallels Desktop window."

    It is not, Parallels was quit gracefully with the VM running and this message is presented upon Parallels relaunch.

    3036, latest parallels tools, MacBook Pro Core 2 Duo, 2Gb

    Tried repairing permissions - no parallels files were repaired.
    Last edited: Dec 2, 2006
  3. jelevy


    Same here...

    Same here, anyone know where VM configuration information is stored? It's probably just a flag or a file somewhere...
  4. SteveDemy


    winxp.pvs I suppose. username/Library/Parallels/Winxp/winxp.pvs
    Tried opening with TextEdit but no obvious candidates for unlocking (at least to my untrained eyes).
  5. dailo


    The only way I got around this was to delete the VM and make a new VM with the HD. Be sure you do not DELETE the .hdd file. Just move it to somewhere else and make a new VM and point the HD back to that .hdd when it asks you for it.

    It appears this version doesn't let you override that lock like previous versions, I'm sure they will fix this in the next release.
  6. jelevy


    It's got to be stored somewhere...
  7. SteveDemy


    Strange but true. Moving the .pvs file to an adjacent folder solved the problem. A new .sav file gets recreated in the same folder as the .pvs file. The old .sav file can be trashed. I didn't move the .hdd file.

    Thanks, it's nice to see the thing working again even if the files are strewn around a bit.
  8. jelevy


    I moved it out and put it back and that worked... weird.
  9. Serg Clein

    Serg Clein

    In order to unlock the virtual machine ...

    ... you need just delete the "lock"-file, which is always created in the same folder where the virtual machine configuration file (*.pvs) exists.

    To figure out the folder where this stuff is placed, move the mouse pointer over the operating system icon you can see on the virtual machine's property sheet. The path to the virtual machine's configuration file will be shown inside the statusbar (at the bottom of the application's window).

    Go to that folder, locate the file with the extension ".lock", and remove it. That's it.
    The only hint to keep in mind is that the file is hidden (its name starts with a dot - "." ).

    Certainly it is a bug and it will be fixed. The Parallels Desktop will not warn about VM is locked if it is not so, as it was in earlier versions. And of course you will not need to move your VM or re-create it somehow :)

    mikesax, SteveDemy, thanks for the report.


    Parallels Development Team member.
    Last edited: Dec 2, 2006
  10. MarkMc


    Deleting the .lock file worked for me. Thanks!
  11. joem


    You know, if Parallels would just stop using hidden files, a bunch of support questions would just vanish overnight. Why does a lock file have to be hidden? Same with the keyboard config file.

    I can see hiding the license file, but the others should never be hidden.

    Of course, hidden files are accessible in Terminal, and the Finder can be made to show hidden files by setting a status flag (AppleShowAllFiles Boolean) to yes in ~/library/preferences/

    Do this either by using the plist editor (install development tools to make this available), or by carefully editing the .plist file with a text editor (easy to mess up so be careful) or by downloading and installing a utility such as Onyx (my favorite).

    Once the change is made, relaunch the Finder (from the menu if enabled, or by force quitting it, or by logging out and then back in) and all the invisible files will appear. There are a lot of them, so you probably don't want to leave the flag on once you are done deleting the lock file or whatever else you are doing with hidden files.
  12. FiveO


    just enter this command in a new terminal window:

    rm library/parallels/<your_virtual_machine>/.<your_virtual_machine>.pvs.lock

    With this command you remove the lock file (don't forget to modify the <your_vitual_machine>).
  13. Hugh Watkins

    Hugh Watkins

    but where is the "property sheet" ?

    select virtual machine
    dialogue box

    Virtual machine FTM5DK cannot be opened since it is already used in another Parallels Desktop window.

    I clicked cancel and Parallels crashed this time

    i am not yet a terminal user

    Hugh W
  14. joem


    Becoming a "terminal user" is probably useful if you are going to do any more than use applications, but there is a way around this problem that doesn't require it.

    1) Find your VM. There's no way around this. You have to know where it is. Try navigating in Finder to your user ID / Library / Parallels. There you should find one or more folders containing your VMs. Find the VM folder that is having the problem.

    2) Create a new folder (anywhere) and drag all the files from your VM folder into it.

    3) Trash the original (now apparently empty) VM folder, and empty the trash.

    4) Recreate the original VM folder in its original location.

    5) Drag all the files you moved in step 2 into the newly recreated folder.

    6) Trash the new (empty) folder you created is step 2.

    You are done. The lock file is gone. Terminal is easier.
  15. SteveDemy


    Thanks Serg for the solution. I used the freeware Show & Hide to show the lock file, then deleted it and hid the hidden files again. It all works perfectly now.

    Parallels is excellent software, getting better every day. Thanks for the great support!

Share This Page