Anybody tried gaming yet in 3.0?

Discussion in 'Parallels Desktop for Mac' started by nickeleye, Jun 8, 2007.

  1. nickeleye


    I downloaded 3.0 earlier today and installed Age of Empires 3 a little bit ago and I ran into a problem where it said the game requires a minimum processor of 733 mhz and I ignored the error then the screen just went white instead of playing any video intro although I did hear some sound. I enabled DirectX in the VM video options. I'm not sure what I might be doing wrong. Also, I have a MacBook Pro running at 2.16 ghz with 2 gigs of RAM.
  2. akashra


    I've heard Quake4, Eve and Sam and Max work.. and that's it. Haven't seen reports of anything else working. Everything I've tried has failed.
  3. nickeleye


    I just tried AOE3 again after some Parallels adjustments. I was somehow able to finally get to the start menu of the game, but it was partially garbled and since the menu is in 3d too you could see the action in the background was running at a snail's pace. I was able to get into a tutorial, but it controlled real bad because of the game's interactions with the Parallel's window (I think). It was unplayable, but I did get video so that something. However, I had to promptly uninstall the game so on to the next thing I guess.
  4. crag


    Forget it...

    See this thread:

    many have tried various games. Very few work. And if they even boot most are dog slow. Even most of the games on their list. I hope you didn't pay for it? if so, contact support and ask for a refund.
    Last edited: Jun 9, 2007
  5. perfection


    yeah i tried counterstrike and condition zero. everything i see in the game was white in color?? how fun .... not to mention the poor fps ....

Share This Page